Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Счёт значений по диагонале, только числа - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Счёт значений по диагонале, только числа (Формулы/Formulas)
Счёт значений по диагонале, только числа
negodyaj Дата: Суббота, 25.01.2020, 01:00 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 68
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Доброго вечера

Код
=СУММПРОИЗВ((СТОЛБЕЦ(A1:O1)-СТОЛБЕЦ()+1=16-СТРОКА(A1:A15))*(A1:O15="+"))


Есть такая формула, считает все + по диагонали, но как ей посчитать кол-во где содержатся числа?
ЕЧИСЛО() требует ссылку на ячейку
К сообщению приложен файл: 4980156.xlsx(59.3 Kb)


Сообщение отредактировал negodyaj - Суббота, 25.01.2020, 13:39
 
Ответить
СообщениеДоброго вечера

Код
=СУММПРОИЗВ((СТОЛБЕЦ(A1:O1)-СТОЛБЕЦ()+1=16-СТРОКА(A1:A15))*(A1:O15="+"))


Есть такая формула, считает все + по диагонали, но как ей посчитать кол-во где содержатся числа?
ЕЧИСЛО() требует ссылку на ячейку

Автор - negodyaj
Дата добавления - 25.01.2020 в 01:00
Светлый Дата: Суббота, 25.01.2020, 08:03 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1474
Репутация: 385 ±
Замечаний: 0% ±

Excel 2010, 2013
Доброе утро!
Формулы готовы. Выложу, когда оформите тегами свою формулу. Выделить и нажать fx.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДоброе утро!
Формулы готовы. Выложу, когда оформите тегами свою формулу. Выделить и нажать fx.

Автор - Светлый
Дата добавления - 25.01.2020 в 08:03
Pelena Дата: Суббота, 25.01.2020, 10:34 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 16499
Репутация: 3566 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
[offtop]
Цитата Светлый, 25.01.2020 в 08:03, в сообщении № 2 ()
Выложу, когда оформите тегами

Спасибо!)[/offtop]


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение[offtop]
Цитата Светлый, 25.01.2020 в 08:03, в сообщении № 2 ()
Выложу, когда оформите тегами

Спасибо!)[/offtop]

Автор - Pelena
Дата добавления - 25.01.2020 в 10:34
negodyaj Дата: Суббота, 25.01.2020, 13:39 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 68
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Цитата Светлый, 25.01.2020 в 08:03, в сообщении № 2 ()
Выложу, когда оформите тегами свою формулу.

упс) сделал
 
Ответить
Сообщение
Цитата Светлый, 25.01.2020 в 08:03, в сообщении № 2 ()
Выложу, когда оформите тегами свою формулу.

упс) сделал

Автор - negodyaj
Дата добавления - 25.01.2020 в 13:39
Светлый Дата: Суббота, 25.01.2020, 14:28 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1474
Репутация: 385 ±
Замечаний: 0% ±

Excel 2010, 2013
Количество чисел:
Код
=СУММПРОИЗВ((СТОЛБЕЦ(A1:O1)-СТОЛБЕЦ()+1=16-СТРОКА(A1:A15))*ЕЧИСЛО(-A1:O15))
И сумма чисел:
Код
=СУММПРОИЗВ((СТОЛБЕЦ(A1:O1)-СТОЛБЕЦ()+1=16-СТРОКА(A1:A15))*Ч(+A1:O15))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеКоличество чисел:
Код
=СУММПРОИЗВ((СТОЛБЕЦ(A1:O1)-СТОЛБЕЦ()+1=16-СТРОКА(A1:A15))*ЕЧИСЛО(-A1:O15))
И сумма чисел:
Код
=СУММПРОИЗВ((СТОЛБЕЦ(A1:O1)-СТОЛБЕЦ()+1=16-СТРОКА(A1:A15))*Ч(+A1:O15))

Автор - Светлый
Дата добавления - 25.01.2020 в 14:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Счёт значений по диагонале, только числа (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!