Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как изменить значания чисел в ячейках под необходимую сумму - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как изменить значания чисел в ячейках под необходимую сумму (Формулы/Formulas)
Как изменить значания чисел в ячейках под необходимую сумму
esculap Дата: Суббота, 25.01.2020, 12:12 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Автосумма чисел в этих ячейках составляет 32137. Возможно ли автоматически (скрипт, формула, и т.д.) пропорционально изменить значения чисел в указанных ячейках так, чтобы сумма их составляла 31500?
К сообщению приложен файл: 0412402.xlsx(9.5 Kb)
 
Ответить
СообщениеАвтосумма чисел в этих ячейках составляет 32137. Возможно ли автоматически (скрипт, формула, и т.д.) пропорционально изменить значения чисел в указанных ячейках так, чтобы сумма их составляла 31500?

Автор - esculap
Дата добавления - 25.01.2020 в 12:12
Nic70y Дата: Суббота, 25.01.2020, 12:24 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5979
Репутация: 1308 ±
Замечаний: 0% ±

ru13;10;03
Код
=ЕСЛИ(C3;ОКРУГЛ(D$10/C$10*C1;0);D$10-СУММ(D$1:ИНДЕКС(D:D;СТРОКА()-1)))
где D$10=31500
К сообщению приложен файл: 7129070.xlsx(9.7 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИ(C3;ОКРУГЛ(D$10/C$10*C1;0);D$10-СУММ(D$1:ИНДЕКС(D:D;СТРОКА()-1)))
где D$10=31500

Автор - Nic70y
Дата добавления - 25.01.2020 в 12:24
Светлый Дата: Суббота, 25.01.2020, 13:08 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1433
Репутация: 377 ±
Замечаний: 0% ±

Excel 2010, 2013
Упрощённо:
Код
=ОКРУГЛ(C$11/C$10*C1;)
и в последней:
Код
=C11-СУММ(D1:D8)
, где в C11 требуемая сумма.
По-хорошему:
Код
=ОТБР(C1*C$11/C$10)+(СУММПРОИЗВ(Ч(ОСТАТ(C1*C$11/C$10;1)/C1>=ОСТАТ(C$1:C$9*C$11/C$10;1)/C$1:C$9))<=C$11-СУММПРОИЗВ(ОТБР(C$1:C$9*C$11/C$10)))
*Но, если есть одинаковые значения, то лучше:
Код
=ОТБР(C1*C$11/C$10)+(СУММПРОИЗВ(Ч((ОСТАТ(C1*C$11/C$10;1)+СТРОКА()%%%)/C1>=(ОСТАТ(C$1:C$9*C$11/C$10;1)+СТРОКА($1:$9)%%%)/C$1:C$9))<=C$11-СУММПРОИЗВ(ОТБР(C$1:C$9*C$11/C$10)))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Суббота, 25.01.2020, 13:18
 
Ответить
СообщениеУпрощённо:
Код
=ОКРУГЛ(C$11/C$10*C1;)
и в последней:
Код
=C11-СУММ(D1:D8)
, где в C11 требуемая сумма.
По-хорошему:
Код
=ОТБР(C1*C$11/C$10)+(СУММПРОИЗВ(Ч(ОСТАТ(C1*C$11/C$10;1)/C1>=ОСТАТ(C$1:C$9*C$11/C$10;1)/C$1:C$9))<=C$11-СУММПРОИЗВ(ОТБР(C$1:C$9*C$11/C$10)))
*Но, если есть одинаковые значения, то лучше:
Код
=ОТБР(C1*C$11/C$10)+(СУММПРОИЗВ(Ч((ОСТАТ(C1*C$11/C$10;1)+СТРОКА()%%%)/C1>=(ОСТАТ(C$1:C$9*C$11/C$10;1)+СТРОКА($1:$9)%%%)/C$1:C$9))<=C$11-СУММПРОИЗВ(ОТБР(C$1:C$9*C$11/C$10)))

Автор - Светлый
Дата добавления - 25.01.2020 в 13:08
esculap Дата: Суббота, 25.01.2020, 19:15 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Светлый, скажите, пожалуйста, а как быть с таким примером?
К сообщению приложен файл: 2466633.xlsx(9.5 Kb)
 
Ответить
СообщениеСветлый, скажите, пожалуйста, а как быть с таким примером?

Автор - esculap
Дата добавления - 25.01.2020 в 19:15
Pelena Дата: Суббота, 25.01.2020, 19:51 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 15242
Репутация: 3340 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Вариант через Подбор параметра (Данные -- Анализ "что если" -- Подбор параметра)
К сообщению приложен файл: 6828339.xlsx(26.3 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВариант через Подбор параметра (Данные -- Анализ "что если" -- Подбор параметра)

Автор - Pelena
Дата добавления - 25.01.2020 в 19:51
Светлый Дата: Воскресенье, 26.01.2020, 00:25 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1433
Репутация: 377 ±
Замечаний: 0% ±

Excel 2010, 2013
Легко.
*Файл перезалил.
К сообщению приложен файл: 2466633-1.xlsx(10.2 Kb)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Воскресенье, 26.01.2020, 00:30
 
Ответить
СообщениеЛегко.
*Файл перезалил.

Автор - Светлый
Дата добавления - 26.01.2020 в 00:25
Светлый Дата: Вторник, 28.01.2020, 09:18 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1433
Репутация: 377 ±
Замечаний: 0% ±

Excel 2010, 2013
Ошибся. Неправильно условие задал. Формула должна быть такой:
Код
=ОТБР(C1*C$11/C$10)+(СУММПРОИЗВ(Ч((ОСТАТ(C1*C$11/C$10;1)+СТРОКА()%%%)<=(ОСТАТ(C$1:C$9*C$11/C$10;1)+СТРОКА($1:$9)%%%)))<=C$11-СУММПРОИЗВ(ОТБР(C$1:C$9*C$11/C$10)))
*Добавил файл с несколькими вариантами формул и проверкой оптимальности результата.
К сообщению приложен файл: 0412402-2.xlsx(11.5 Kb)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Вторник, 28.01.2020, 10:49
 
Ответить
СообщениеОшибся. Неправильно условие задал. Формула должна быть такой:
Код
=ОТБР(C1*C$11/C$10)+(СУММПРОИЗВ(Ч((ОСТАТ(C1*C$11/C$10;1)+СТРОКА()%%%)<=(ОСТАТ(C$1:C$9*C$11/C$10;1)+СТРОКА($1:$9)%%%)))<=C$11-СУММПРОИЗВ(ОТБР(C$1:C$9*C$11/C$10)))
*Добавил файл с несколькими вариантами формул и проверкой оптимальности результата.

Автор - Светлый
Дата добавления - 28.01.2020 в 09:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как изменить значания чисел в ячейках под необходимую сумму (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!