Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/перевести трёхзначное число в двузначное - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » перевести трёхзначное число в двузначное (Формулы/Formulas)
перевести трёхзначное число в двузначное
Didya Дата: Воскресенье, 26.01.2020, 06:08 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
трёхзначное число преобразовать в двухзначное с запятой. например: результат разницы чисел должен быть двузначным, но иногда результат может быть
трёхзначным 123 преобразуем в 12,3
 
Ответить
Сообщениетрёхзначное число преобразовать в двухзначное с запятой. например: результат разницы чисел должен быть двузначным, но иногда результат может быть
трёхзначным 123 преобразуем в 12,3

Автор - Didya
Дата добавления - 26.01.2020 в 06:08
TimSha Дата: Воскресенье, 26.01.2020, 07:28 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 627
Репутация: 94 ±
Замечаний: 0% ±

Excel 2013 Pro +
трёхзначное число преобразовать в двухзначное

Разделить на 10 не пробовали?
И в чем целесообразность вашей затеи?
ps Словесный "например" принято подкреплять примером в конкретном файле, с толкованием что из чего для чего и как желательно получить.


"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Ответить
Сообщение
трёхзначное число преобразовать в двухзначное

Разделить на 10 не пробовали?
И в чем целесообразность вашей затеи?
ps Словесный "например" принято подкреплять примером в конкретном файле, с толкованием что из чего для чего и как желательно получить.

Автор - TimSha
Дата добавления - 26.01.2020 в 07:28
Didya Дата: Воскресенье, 26.01.2020, 09:58 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Повседневные расчёты. это число загоняется в корень, ну и соответственно в корне может быть только двузначное число. Ежедневно всё на калькуляторе, надоело, расчётов много. таблицу создал, а с этим не получается. Возможно, разделить на 10, но как это прописать в случае с трёхзначным?
 
Ответить
СообщениеПовседневные расчёты. это число загоняется в корень, ну и соответственно в корне может быть только двузначное число. Ежедневно всё на калькуляторе, надоело, расчётов много. таблицу создал, а с этим не получается. Возможно, разделить на 10, но как это прописать в случае с трёхзначным?

Автор - Didya
Дата добавления - 26.01.2020 в 09:58
Pelena Дата: Воскресенье, 26.01.2020, 10:03 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 15213
Репутация: 3334 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
=ЕСЛИ(A1>=100;A1/10;A1)


в корне может быть только двузначное число
странное правило %)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ЕСЛИ(A1>=100;A1/10;A1)


в корне может быть только двузначное число
странное правило %)

Автор - Pelena
Дата добавления - 26.01.2020 в 10:03
Светлый Дата: Воскресенье, 26.01.2020, 10:07 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1425
Репутация: 374 ±
Замечаний: 0% ±

Excel 2010, 2013
За недостатком информации, думаю, подойдёт такая формула:
Код
=--ЗАМЕНИТЬ(A5&0;3;;",")
*Или так:
Код
=A5/10^(A5>99)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Воскресенье, 26.01.2020, 10:11
 
Ответить
СообщениеЗа недостатком информации, думаю, подойдёт такая формула:
Код
=--ЗАМЕНИТЬ(A5&0;3;;",")
*Или так:
Код
=A5/10^(A5>99)

Автор - Светлый
Дата добавления - 26.01.2020 в 10:07
Didya Дата: Вторник, 28.01.2020, 16:49 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Светлый, Спасибо, но не получается. Образец вложил, в столбце Е1 разница чисел, которая в корне не может быть трёхзначной, её и надо перевести в двузнак, а в F1 извлечётся корень.


Сообщение отредактировал Didya - Вторник, 28.01.2020, 16:54
 
Ответить
СообщениеСветлый, Спасибо, но не получается. Образец вложил, в столбце Е1 разница чисел, которая в корне не может быть трёхзначной, её и надо перевести в двузнак, а в F1 извлечётся корень.

Автор - Didya
Дата добавления - 28.01.2020 в 16:49
Didya Дата: Вторник, 28.01.2020, 16:52 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Файл не сохранил.
К сообщению приложен файл: 4772338.xlsx(8.2 Kb)
 
Ответить
СообщениеФайл не сохранил.

Автор - Didya
Дата добавления - 28.01.2020 в 16:52
YouGreed Дата: Вторник, 28.01.2020, 17:04 | Сообщение № 8
Группа: Проверенные
Ранг: Ветеран
Сообщений: 517
Репутация: 109 ±
Замечаний: 0% ±

Excel 2010
Didya, Так что ли?

Код
=ЕСЛИ(ДЛСТР(C1-D1)=3;(C1-D1)/10;C1-D1)
К сообщению приложен файл: 8228479.xlsx(8.7 Kb)
 
Ответить
СообщениеDidya, Так что ли?

Код
=ЕСЛИ(ДЛСТР(C1-D1)=3;(C1-D1)/10;C1-D1)

Автор - YouGreed
Дата добавления - 28.01.2020 в 17:04
Didya Дата: Вторник, 28.01.2020, 17:16 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
YouGreed, Точно!!! Получилось, всем огромное спасибо!!! hands
 
Ответить
СообщениеYouGreed, Точно!!! Получилось, всем огромное спасибо!!! hands

Автор - Didya
Дата добавления - 28.01.2020 в 17:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » перевести трёхзначное число в двузначное (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!