Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчитать сумму по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчитать сумму по условию (Формулы/Formulas)
Подсчитать сумму по условию
maxcet Дата: Воскресенье, 26.01.2020, 20:02 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день!

Возникла такая ситуация, что требуется составить формулу, которая будет считать сумму (цен/кол-во/и т.д.) при условии, что заведомо не известен лист с данными, его должен пользователь указать ручками в определенной ячейке
Как ссылаться на конкретную ячейку я понимаю, но не понимаю как из этой ячейки вытащить другую ссылку.

Код
=СУММ(Лист2!B1:$B$7)


Чисто логически код должен быть примерно таким
Код
=ЕСЛИ(A1<>0;СУММ(Лист_из_ячейкиА1!$B$1:$B$7;0)


Прошу помощи, совета или даже ссылки на источники, где можно подробнее прочитать.
К сообщению приложен файл: 3054956.xlsx(9.5 Kb)


Сообщение отредактировал maxcet - Воскресенье, 26.01.2020, 20:02
 
Ответить
СообщениеДобрый день!

Возникла такая ситуация, что требуется составить формулу, которая будет считать сумму (цен/кол-во/и т.д.) при условии, что заведомо не известен лист с данными, его должен пользователь указать ручками в определенной ячейке
Как ссылаться на конкретную ячейку я понимаю, но не понимаю как из этой ячейки вытащить другую ссылку.

Код
=СУММ(Лист2!B1:$B$7)


Чисто логически код должен быть примерно таким
Код
=ЕСЛИ(A1<>0;СУММ(Лист_из_ячейкиА1!$B$1:$B$7;0)


Прошу помощи, совета или даже ссылки на источники, где можно подробнее прочитать.

Автор - maxcet
Дата добавления - 26.01.2020 в 20:02
gling Дата: Воскресенье, 26.01.2020, 20:40 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2016
Репутация: 508 ±
Замечаний: 0% ±

2010
Здравствуйте. Попробуйте так
Код
=СУММ(ДВССЫЛ(A2&"!B1:$B$7"))


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте. Попробуйте так
Код
=СУММ(ДВССЫЛ(A2&"!B1:$B$7"))

Автор - gling
Дата добавления - 26.01.2020 в 20:40
maxcet Дата: Воскресенье, 26.01.2020, 20:41 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Смог сам разобраться. До этого не встречался с таким понятием как ДВСЫЛ
Код
=СУММ(ДВССЫЛ(A2&"!"&"B"&2&":B"&7))

Оставлю здесь, может кому пригодится.
В А2 хранится название листа в формате "Лист2", где это конкретное наименование листа, а дальше склеиваем с ! и задаем нужный диапазон
 
Ответить
СообщениеСмог сам разобраться. До этого не встречался с таким понятием как ДВСЫЛ
Код
=СУММ(ДВССЫЛ(A2&"!"&"B"&2&":B"&7))

Оставлю здесь, может кому пригодится.
В А2 хранится название листа в формате "Лист2", где это конкретное наименование листа, а дальше склеиваем с ! и задаем нужный диапазон

Автор - maxcet
Дата добавления - 26.01.2020 в 20:41
maxcet Дата: Воскресенье, 26.01.2020, 20:42 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
gling, Спасибо, я уже сам смог х) Как раз только наткнулся на это понятие ) Не успел отписаться ))
Но всё равно, спасибо Вам!!!
 
Ответить
Сообщениеgling, Спасибо, я уже сам смог х) Как раз только наткнулся на это понятие ) Не успел отписаться ))
Но всё равно, спасибо Вам!!!

Автор - maxcet
Дата добавления - 26.01.2020 в 20:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчитать сумму по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!