Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вставить на другой лист значения ячеек с ненулевым значени - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вставить на другой лист значения ячеек с ненулевым значени (Формулы/Formulas)
Вставить на другой лист значения ячеек с ненулевым значени
Нюта Дата: Понедельник, 27.01.2020, 09:22 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день! Никак не могу подобрать формулу, нужно из столбца C на листе 1 выбрать значения больше 0 и скопировать их в столбец B на лист 2. При этом желательно чтоб подтягивались на лист 2 все заполненные ячейки из строки, где в столбце С значение больше 0 листа 1.
К сообщению приложен файл: 6050332.xlsx(15.8 Kb)


Сообщение отредактировал Нюта - Понедельник, 27.01.2020, 10:31
 
Ответить
СообщениеДобрый день! Никак не могу подобрать формулу, нужно из столбца C на листе 1 выбрать значения больше 0 и скопировать их в столбец B на лист 2. При этом желательно чтоб подтягивались на лист 2 все заполненные ячейки из строки, где в столбце С значение больше 0 листа 1.

Автор - Нюта
Дата добавления - 27.01.2020 в 09:22
китин Дата: Понедельник, 27.01.2020, 09:25 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6122
Репутация: 947 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Нюта, - Прочитайте Правила форума
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 100кб согласно п.3 Правил форума


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеНюта, - Прочитайте Правила форума
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 100кб согласно п.3 Правил форума

Автор - китин
Дата добавления - 27.01.2020 в 09:25
китин Дата: Понедельник, 27.01.2020, 11:14 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 6122
Репутация: 947 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Доброго и вам. так?,
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!A$3:A$61;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(Лист1!$C$3:$C$61);СТРОКА(Лист1!$C$3:$C$61)-2);СТРОКА(A1)));0)

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 9147979.xlsx(18.5 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеДоброго и вам. так?,
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!A$3:A$61;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(Лист1!$C$3:$C$61);СТРОКА(Лист1!$C$3:$C$61)-2);СТРОКА(A1)));0)

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - китин
Дата добавления - 27.01.2020 в 11:14
pabchek Дата: Понедельник, 27.01.2020, 11:43 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 929
Репутация: 218 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте!
Простите, не по ТЗ, но я предпочитаю когда это возможно, вместо громоздких медленносчитающихся формул использовать сводные таблицы.
Посмотрите, вдруг Вам понравится :)))
К сообщению приложен файл: 3894316.xlsb(19.4 Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеЗдравствуйте!
Простите, не по ТЗ, но я предпочитаю когда это возможно, вместо громоздких медленносчитающихся формул использовать сводные таблицы.
Посмотрите, вдруг Вам понравится :)))

Автор - pabchek
Дата добавления - 27.01.2020 в 11:43
Нюта Дата: Понедельник, 27.01.2020, 11:54 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Спасибо! hands два дня мучилась %)
 
Ответить
СообщениеСпасибо! hands два дня мучилась %)

Автор - Нюта
Дата добавления - 27.01.2020 в 11:54
Нюта Дата: Воскресенье, 09.02.2020, 21:47 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
китин, помогите пожалуйста еще раз ) нужно то же самое - чтоб заполненные строки с листа 1 вставлялись на лист 2 но начиная с 17 строки листа 2, так как вверху на листе 2 будет еще шапка, я не смогла сделать :facepalm: :facepalm:
К сообщению приложен файл: 9329231.xlsx(19.4 Kb)
 
Ответить
Сообщениекитин, помогите пожалуйста еще раз ) нужно то же самое - чтоб заполненные строки с листа 1 вставлялись на лист 2 но начиная с 17 строки листа 2, так как вверху на листе 2 будет еще шапка, я не смогла сделать :facepalm: :facepalm:

Автор - Нюта
Дата добавления - 09.02.2020 в 21:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вставить на другой лист значения ячеек с ненулевым значени (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!