Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывести в ячейке часть текста, который есть в списке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести в ячейке часть текста, который есть в списке (Формулы/Formulas)
Вывести в ячейке часть текста, который есть в списке
Elba Дата: Вторник, 28.01.2020, 17:49 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Доброго времени суток! Помогите написать формулу, пожалуйста. Нужно, чтоб она искала в столбце "Характеристика" текст, который есть в столбце "Список размеров" и выводила этот самый размер. Файл прикрепляю. Заранее благодарю.
К сообщению приложен файл: 1451186.xlsx(8.6 Kb)
 
Ответить
СообщениеДоброго времени суток! Помогите написать формулу, пожалуйста. Нужно, чтоб она искала в столбце "Характеристика" текст, который есть в столбце "Список размеров" и выводила этот самый размер. Файл прикрепляю. Заранее благодарю.

Автор - Elba
Дата добавления - 28.01.2020 в 17:49
gling Дата: Вторник, 28.01.2020, 22:59 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2015
Репутация: 507 ±
Замечаний: 0% ±

2010
Здравствуйте. Попробуйте такую формулу
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$A$48;ПРОСМОТР(1;1/СЧЁТЕСЛИ(B2;"*"&$A$2:$A$48&"*");СТРОКА($A$2:$A$48)));"")
К сообщению приложен файл: 8415420.xlsx(10.1 Kb)


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте. Попробуйте такую формулу
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$A$48;ПРОСМОТР(1;1/СЧЁТЕСЛИ(B2;"*"&$A$2:$A$48&"*");СТРОКА($A$2:$A$48)));"")

Автор - gling
Дата добавления - 28.01.2020 в 22:59
Pelena Дата: Вторник, 28.01.2020, 23:22 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 15209
Репутация: 3332 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Можно ещё так:
формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$48;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК($A$2:$A$48;B2));0));"нет в списке")

обычная
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$48;АГРЕГАТ(15;6;(СТРОКА($A$2:$A$48)-1)/ЕЧИСЛО(ПОИСК($A$2:$A$48;B2));1));"нет в списке")
К сообщению приложен файл: 1284090.xlsx(10.4 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеМожно ещё так:
формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$48;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК($A$2:$A$48;B2));0));"нет в списке")

обычная
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$48;АГРЕГАТ(15;6;(СТРОКА($A$2:$A$48)-1)/ЕЧИСЛО(ПОИСК($A$2:$A$48;B2));1));"нет в списке")

Автор - Pelena
Дата добавления - 28.01.2020 в 23:22
Elba Дата: Среда, 29.01.2020, 09:20 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
gling, Pelena, благодарю, работает
 
Ответить
Сообщениеgling, Pelena, благодарю, работает

Автор - Elba
Дата добавления - 29.01.2020 в 09:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести в ячейке часть текста, который есть в списке (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!