Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Присвоение значения объектам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Присвоение значения объектам (Формулы/Formulas)
Присвоение значения объектам
vsg-good Дата: Среда, 29.01.2020, 11:05 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте.

Прошу помочь с формулой, которая бы решала следующую задачу: присвоить объекту признак 2 в зависимости от значения признака 1. Признак 2 принимает значение 1 только если признак 1 всех объектов определенной группы имеет значение 1. В противном случае признаку 2 присваивается значение 2.

Условный пример прилагаю. В столбце D указал значения "как должно быть". Прошу помочь с формулой под это решение.
К сообщению приложен файл: 6630910.xlsx(8.8 Kb)
 
Ответить
СообщениеЗдравствуйте.

Прошу помочь с формулой, которая бы решала следующую задачу: присвоить объекту признак 2 в зависимости от значения признака 1. Признак 2 принимает значение 1 только если признак 1 всех объектов определенной группы имеет значение 1. В противном случае признаку 2 присваивается значение 2.

Условный пример прилагаю. В столбце D указал значения "как должно быть". Прошу помочь с формулой под это решение.

Автор - vsg-good
Дата добавления - 29.01.2020 в 11:05
Nic70y Дата: Среда, 29.01.2020, 11:11 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6214
Репутация: 1378 ±
Замечаний: 0% ±

ru13;10;03
по данному примеру
Код
=МИН(СЧЁТЕСЛИМН(B:B;B2;C:C;2)+1;2)
на всякий случай
Код
=2-(СЧЁТЕСЛИМН(B:B;B2;C:C;1)=СЧЁТЕСЛИ(B:B;B2))


Яндекс Деньги 41001841029809
 
Ответить
Сообщениепо данному примеру
Код
=МИН(СЧЁТЕСЛИМН(B:B;B2;C:C;2)+1;2)
на всякий случай
Код
=2-(СЧЁТЕСЛИМН(B:B;B2;C:C;1)=СЧЁТЕСЛИ(B:B;B2))

Автор - Nic70y
Дата добавления - 29.01.2020 в 11:11
Serge_007 Дата: Среда, 29.01.2020, 11:13 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 13305
Репутация: ±
Замечаний: ±

Excel 2010
Здравствуйте

Как вариант:
Код
=НЕ(СУММПРОИЗВ((B$2:B$10=B2)*C$2:C$10)=СЧЁТЕСЛИ(B$2:B$10;B2))+1


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Как вариант:
Код
=НЕ(СУММПРОИЗВ((B$2:B$10=B2)*C$2:C$10)=СЧЁТЕСЛИ(B$2:B$10;B2))+1

Автор - Serge_007
Дата добавления - 29.01.2020 в 11:13
vsg-good Дата: Среда, 29.01.2020, 11:27 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо!
 
Ответить
СообщениеСпасибо!

Автор - vsg-good
Дата добавления - 29.01.2020 в 11:27
китин Дата: Среда, 29.01.2020, 11:29 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 6215
Репутация: 957 ±
Замечаний: 0% ±

Excel 2007;Excel 2010


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениетут тоже думают

Автор - китин
Дата добавления - 29.01.2020 в 11:29
vsg-good Дата: Среда, 29.01.2020, 11:32 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Да, я продублировал тему на этом форуме, т.к. на том форуме не получал ответа, а вопрос был срочный.
 
Ответить
СообщениеДа, я продублировал тему на этом форуме, т.к. на том форуме не получал ответа, а вопрос был срочный.

Автор - vsg-good
Дата добавления - 29.01.2020 в 11:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Присвоение значения объектам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!