Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/формула суммы ряда натуральных чисел - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » формула суммы ряда натуральных чисел (Формулы/Formulas)
формула суммы ряда натуральных чисел
scared Дата: Понедельник, 03.02.2020, 16:25 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день.

В математике насколько помню это называется частичной суммой натурального ряда.
Есть исходный столбец, который содержит некий набор номеров - назовем их k.
Требуется получить столбец, содержащий набор Sk=1+2+3+...+k (см. файл)

Можно ли использовать какую-то простую формулу для решения этой задачи?
Мне приходит в голову только растянуть в каком-то промежуточном столбце натуральную последовательность 1, 2, 3, 4, 5..., обозвать его допустим |nat, а в итоговом столбце использовать формулу суммы элементов массива, образованного смещением от 1го элемента nat на k ячеек.
Но может кто-то предложит более простой вариант, без массивов?
К сообщению приложен файл: 1694158.xlsx(8.1 Kb)
 
Ответить
СообщениеДобрый день.

В математике насколько помню это называется частичной суммой натурального ряда.
Есть исходный столбец, который содержит некий набор номеров - назовем их k.
Требуется получить столбец, содержащий набор Sk=1+2+3+...+k (см. файл)

Можно ли использовать какую-то простую формулу для решения этой задачи?
Мне приходит в голову только растянуть в каком-то промежуточном столбце натуральную последовательность 1, 2, 3, 4, 5..., обозвать его допустим |nat, а в итоговом столбце использовать формулу суммы элементов массива, образованного смещением от 1го элемента nat на k ячеек.
Но может кто-то предложит более простой вариант, без массивов?

Автор - scared
Дата добавления - 03.02.2020 в 16:25
bmv98rus Дата: Понедельник, 03.02.2020, 16:38 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3180
Репутация: 545 ±
Замечаний: 0% ±

Excel 2013/2016
Масивы есть, но их не видно. - это вариант програмистический
Код
=SUMPRODUCT(ROW($A$1:INDEX($A:$A;B2)))

а тут и вовсе все просто, и это вариант математический
Код
=B2*(B2+1)/2


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Понедельник, 03.02.2020, 16:43
 
Ответить
СообщениеМасивы есть, но их не видно. - это вариант програмистический
Код
=SUMPRODUCT(ROW($A$1:INDEX($A:$A;B2)))

а тут и вовсе все просто, и это вариант математический
Код
=B2*(B2+1)/2

Автор - bmv98rus
Дата добавления - 03.02.2020 в 16:38
Nic70y Дата: Понедельник, 03.02.2020, 16:38 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 6445
Репутация: 1418 ±
Замечаний: 0% ±

ru13;10;03
Код
=СУММПРОИЗВ(СТРОКА(ДВССЫЛ("1:"&B2)))
лучше конечно индекс, двссыл не очень

Цитата
а тут и вовсе все просто, и это вариант математический
точно, этож школьная программа %)


Яндекс Деньги 41001841029809

Сообщение отредактировал Nic70y - Понедельник, 03.02.2020, 16:52
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(СТРОКА(ДВССЫЛ("1:"&B2)))
лучше конечно индекс, двссыл не очень

Цитата
а тут и вовсе все просто, и это вариант математический
точно, этож школьная программа %)

Автор - Nic70y
Дата добавления - 03.02.2020 в 16:38
scared Дата: Понедельник, 03.02.2020, 16:58 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
а тут и вовсе все просто, и это вариант математический

спасибо большое!
вот чувствовал же, что есть простое решение! но сам никак не мог додуматься hands
 
Ответить
Сообщение
а тут и вовсе все просто, и это вариант математический

спасибо большое!
вот чувствовал же, что есть простое решение! но сам никак не мог додуматься hands

Автор - scared
Дата добавления - 03.02.2020 в 16:58
bmv98rus Дата: Понедельник, 03.02.2020, 17:01 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3180
Репутация: 545 ±
Замечаний: 0% ±

Excel 2013/2016
но сам никак не мог додуматься

Иной раз достаточно спросить у yandex


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
но сам никак не мог додуматься

Иной раз достаточно спросить у yandex

Автор - bmv98rus
Дата добавления - 03.02.2020 в 17:01
scared Дата: Вторник, 04.02.2020, 09:36 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Иной раз достаточно спросить у yandex

чесслово, спрашивал! но почему-то такую простую формулу не увидел )
 
Ответить
Сообщение
Иной раз достаточно спросить у yandex

чесслово, спрашивал! но почему-то такую простую формулу не увидел )

Автор - scared
Дата добавления - 04.02.2020 в 09:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » формула суммы ряда натуральных чисел (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!