Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Просуммировать значения через ВПР - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Просуммировать значения через ВПР (Формулы/Formulas)
Просуммировать значения через ВПР
танбраун Дата: Вторник, 04.02.2020, 12:11 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем доброго дня. Прошу помощи в решении задачки.
В столбце А прописаны символы (один или несколько через дефис), значение которых определено в столбце I.
Нужно в столбце В прописать значение этих символов.
Не могу прописать формулу в том случае, когда символов несколько
 
Ответить
СообщениеВсем доброго дня. Прошу помощи в решении задачки.
В столбце А прописаны символы (один или несколько через дефис), значение которых определено в столбце I.
Нужно в столбце В прописать значение этих символов.
Не могу прописать формулу в том случае, когда символов несколько

Автор - танбраун
Дата добавления - 04.02.2020 в 12:11
танбраун Дата: Вторник, 04.02.2020, 12:12 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
не прикрепил файл
К сообщению приложен файл: 0592303.xlsx(9.2 Kb)
 
Ответить
Сообщениене прикрепил файл

Автор - танбраун
Дата добавления - 04.02.2020 в 12:12
китин Дата: Вторник, 04.02.2020, 12:21 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 6122
Репутация: 947 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ну уж если так хочется с ВПР то ловите монстра
Код
=ЕСЛИОШИБКА(ВПР(ЛЕВБ(A2;ПОИСК("-";A2)-1);$H$2:$I$10;2;0)+ВПР(ПСТР(A2;ПОИСК("-";A2)+1;ДЛСТР(A2));$H$2:$I$10;2;0);ВПР(A2;$H$2:$I$10;2;0))
К сообщению приложен файл: 1878199.xlsx(9.3 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениену уж если так хочется с ВПР то ловите монстра
Код
=ЕСЛИОШИБКА(ВПР(ЛЕВБ(A2;ПОИСК("-";A2)-1);$H$2:$I$10;2;0)+ВПР(ПСТР(A2;ПОИСК("-";A2)+1;ДЛСТР(A2));$H$2:$I$10;2;0);ВПР(A2;$H$2:$I$10;2;0))

Автор - китин
Дата добавления - 04.02.2020 в 12:21
танбраун Дата: Вторник, 04.02.2020, 12:40 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
китин, спасибо за быструю помощь hands hands hands
 
Ответить
Сообщениекитин, спасибо за быструю помощь hands hands hands

Автор - танбраун
Дата добавления - 04.02.2020 в 12:40
Светлый Дата: Вторник, 04.02.2020, 13:24 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1432
Репутация: 376 ±
Замечаний: 0% ±

Excel 2010, 2013
Ещё пара вариантов:
Код
=ВПР(ЛЕВБ(A2;ПОИСК("-";A2&"-")-1);H$2:I$10;2;)+ЕСЛИОШИБКА(ВПР(ПСТР(A2;ПОИСК("-";A2&"-")+1;99);H$2:I$10;2;);)
Код
=СУММПРОИЗВ((СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(A2;"-";"    ");{1;6};5))=H$2:H$10)*I$2:I$10)
*Можно массивной формулой:
Код
=СУММ((H$2:H$11&ЕСЛИ(H$2:H$11="";"";"-")&ТРАНСП(H$2:H$11)=A2)*(I$2:I$11+ТРАНСП(I$2:I$11)))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Вторник, 04.02.2020, 15:02
 
Ответить
СообщениеЕщё пара вариантов:
Код
=ВПР(ЛЕВБ(A2;ПОИСК("-";A2&"-")-1);H$2:I$10;2;)+ЕСЛИОШИБКА(ВПР(ПСТР(A2;ПОИСК("-";A2&"-")+1;99);H$2:I$10;2;);)
Код
=СУММПРОИЗВ((СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(A2;"-";"    ");{1;6};5))=H$2:H$10)*I$2:I$10)
*Можно массивной формулой:
Код
=СУММ((H$2:H$11&ЕСЛИ(H$2:H$11="";"";"-")&ТРАНСП(H$2:H$11)=A2)*(I$2:I$11+ТРАНСП(I$2:I$11)))

Автор - Светлый
Дата добавления - 04.02.2020 в 13:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Просуммировать значения через ВПР (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!