Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Уникальные значения двух рядов, расчет количества совпадений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Уникальные значения двух рядов, расчет количества совпадений (Формулы/Formulas)
Уникальные значения двух рядов, расчет количества совпадений
Serge171 Дата: Среда, 05.02.2020, 10:55 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Помогите, пожалуйста, решить 2 задачи. Имеется два ряда чисел.
1. Необходимо вывести список уникальных значений двух рядов чисел.
2. Затем рядом с этими числами указать количество совпадений в двух этих рядах.
Файл с примером во вложении.
Буду очень благодарен за помощь.
К сообщению приложен файл: 232124.xls(25.0 Kb)
 
Ответить
СообщениеДобрый день!
Помогите, пожалуйста, решить 2 задачи. Имеется два ряда чисел.
1. Необходимо вывести список уникальных значений двух рядов чисел.
2. Затем рядом с этими числами указать количество совпадений в двух этих рядах.
Файл с примером во вложении.
Буду очень благодарен за помощь.

Автор - Serge171
Дата добавления - 05.02.2020 в 10:55
Nic70y Дата: Среда, 05.02.2020, 11:36 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5963
Репутация: 1306 ±
Замечаний: 0% ±

ru13;10;03
в реале ряды так и располагаются друг под другом?


ЯД(poison) 41001841029809
 
Ответить
Сообщениев реале ряды так и располагаются друг под другом?

Автор - Nic70y
Дата добавления - 05.02.2020 в 11:36
Russel Дата: Среда, 05.02.2020, 11:42 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1357
Репутация: 305 ±
Замечаний: 0% ±

Excel 2010
Добрый день!

Сводная + формулы рядом.
К сообщению приложен файл: 2233330.xls(21.5 Kb)


QIWI 9173973973
 
Ответить
СообщениеДобрый день!

Сводная + формулы рядом.

Автор - Russel
Дата добавления - 05.02.2020 в 11:42
Serge171 Дата: Среда, 05.02.2020, 11:48 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Да. Причем таких двойных рядов порядка 70 - это регионы РФ. Поэтому визуально удобнее смотреть, когда именно один под другим. Количество значений в каждом ряде также величина примерно постоянная - 20-23, я просто для примера 10 значений привел. Поэтому если нет возможности прописать формулы под этими рядами, можно и отдельный лист сделать и расположить как будет удобно, подтянув просто ссылками из исходных данных, а на итоговый лист вывести итоговые вычисления.
 
Ответить
СообщениеДа. Причем таких двойных рядов порядка 70 - это регионы РФ. Поэтому визуально удобнее смотреть, когда именно один под другим. Количество значений в каждом ряде также величина примерно постоянная - 20-23, я просто для примера 10 значений привел. Поэтому если нет возможности прописать формулы под этими рядами, можно и отдельный лист сделать и расположить как будет удобно, подтянув просто ссылками из исходных данных, а на итоговый лист вывести итоговые вычисления.

Автор - Serge171
Дата добавления - 05.02.2020 в 11:48
Светлый Дата: Среда, 05.02.2020, 11:50 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1432
Репутация: 376 ±
Замечаний: 0% ±

Excel 2010, 2013
Добрый день!
Можно так.
К сообщению приложен файл: 232124-1.xls(26.5 Kb)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДобрый день!
Можно так.

Автор - Светлый
Дата добавления - 05.02.2020 в 11:50
Nic70y Дата: Среда, 05.02.2020, 11:58 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 5963
Репутация: 1306 ±
Замечаний: 0% ±

ru13;10;03
массивная
Код
=ЕСЛИОШИБКА(ИНДЕКС(B$4:B$25;НАИМЕНЬШИЙ(ЕСЛИ(ЕСЛИОШИБКА(ПОИСКПОЗ(ЕСЛИ(ЕЧИСЛО(B$4:B$25);B$4:B$25);B$4:B$25;);)=СТРОКА(B$4:B$25)-3;СТРОКА(B$4:B$25)-3);СТРОКА(A1)));"ВСЕГО")
+счётесли
К сообщению приложен файл: 8330714.xls(26.5 Kb)


ЯД(poison) 41001841029809

Сообщение отредактировал Nic70y - Среда, 05.02.2020, 12:02
 
Ответить
Сообщениемассивная
Код
=ЕСЛИОШИБКА(ИНДЕКС(B$4:B$25;НАИМЕНЬШИЙ(ЕСЛИ(ЕСЛИОШИБКА(ПОИСКПОЗ(ЕСЛИ(ЕЧИСЛО(B$4:B$25);B$4:B$25);B$4:B$25;);)=СТРОКА(B$4:B$25)-3;СТРОКА(B$4:B$25)-3);СТРОКА(A1)));"ВСЕГО")
+счётесли

Автор - Nic70y
Дата добавления - 05.02.2020 в 11:58
Serge171 Дата: Среда, 05.02.2020, 12:18 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо вам ОГРОМНОЕ!!! Все работает hands
 
Ответить
СообщениеСпасибо вам ОГРОМНОЕ!!! Все работает hands

Автор - Serge171
Дата добавления - 05.02.2020 в 12:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Уникальные значения двух рядов, расчет количества совпадений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!