Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/условное форматирование одного столбца по данным других - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » условное форматирование одного столбца по данным других (Формулы/Formulas)
условное форматирование одного столбца по данным других
ovechkin1973 Дата: Среда, 05.02.2020, 19:30 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 394
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Всем привет! Частенько нужно в одном столбце найти совпадающие данные. Это можно делать с помощью условного форматирования. Если нужно найти повторы по "сумме" текста нескольких столбцов - я решаю проблему, как в приложенном файле. В свободном стобце через"&" сращиваю текст нужных столбцов и делаю условное форматирование. Но это не совсем удобно. Можно это решить более технично? Хотелось в первом столбце делать условное форматирование..
К сообщению приложен файл: 1756242.xlsx(9.4 Kb)


Плохо когда не знаешь, да еще забудешь.

Сообщение отредактировал ovechkin1973 - Среда, 05.02.2020, 19:30
 
Ответить
СообщениеВсем привет! Частенько нужно в одном столбце найти совпадающие данные. Это можно делать с помощью условного форматирования. Если нужно найти повторы по "сумме" текста нескольких столбцов - я решаю проблему, как в приложенном файле. В свободном стобце через"&" сращиваю текст нужных столбцов и делаю условное форматирование. Но это не совсем удобно. Можно это решить более технично? Хотелось в первом столбце делать условное форматирование..

Автор - ovechkin1973
Дата добавления - 05.02.2020 в 19:30
Светлый Дата: Четверг, 06.02.2020, 06:52 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1433
Репутация: 377 ±
Замечаний: 0% ±

Excel 2010, 2013
Доброе утро!
Сделал пример УФ на две группы совпадений:
Код
=ПОИСКПОЗ(A2&B2&C2;A$1:A$35&B$1:B$35&C$1:C$35;)=АГРЕГАТ(15;6;СТРОКА($2:$35)/(ПОИСКПОЗ(A$2:A$35&B$2:B$35&C$2:C$35;A$2:A$35&B$2:B$35&C$2:C$35;)=СТРОКА($1:$34))/(СЧЁТЕСЛИМН(A$2:A$35;A$2:A$35;B$2:B$35;B$2:B$35;C$2:C$35;C$2:C$35)>1);1)
*В столбце B упрощённая формула на один цвет:
Код
=СУММ((A2&B2&C2=A$1:A$35&B$1:B$35&C$1:C$35)*(A$1:A$35>0))>1
Файл перезалил.
К сообщению приложен файл: 1756242-1.xlsx(11.0 Kb)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Четверг, 06.02.2020, 07:18
 
Ответить
СообщениеДоброе утро!
Сделал пример УФ на две группы совпадений:
Код
=ПОИСКПОЗ(A2&B2&C2;A$1:A$35&B$1:B$35&C$1:C$35;)=АГРЕГАТ(15;6;СТРОКА($2:$35)/(ПОИСКПОЗ(A$2:A$35&B$2:B$35&C$2:C$35;A$2:A$35&B$2:B$35&C$2:C$35;)=СТРОКА($1:$34))/(СЧЁТЕСЛИМН(A$2:A$35;A$2:A$35;B$2:B$35;B$2:B$35;C$2:C$35;C$2:C$35)>1);1)
*В столбце B упрощённая формула на один цвет:
Код
=СУММ((A2&B2&C2=A$1:A$35&B$1:B$35&C$1:C$35)*(A$1:A$35>0))>1
Файл перезалил.

Автор - Светлый
Дата добавления - 06.02.2020 в 06:52
ovechkin1973 Дата: Четверг, 06.02.2020, 09:55 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 394
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Цитата Светлый, 06.02.2020 в 06:52, в сообщении № 2 ()
*В столбце B упрощённая формула на один цвет:

Спасибо Светлый, Формула попроще понятна, АГРЕГАТ никогда не пользовался.


Плохо когда не знаешь, да еще забудешь.
 
Ответить
Сообщение
Цитата Светлый, 06.02.2020 в 06:52, в сообщении № 2 ()
*В столбце B упрощённая формула на один цвет:

Спасибо Светлый, Формула попроще понятна, АГРЕГАТ никогда не пользовался.

Автор - ovechkin1973
Дата добавления - 06.02.2020 в 09:55
Светлый Дата: Четверг, 06.02.2020, 10:25 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1433
Репутация: 377 ±
Замечаний: 0% ±

Excel 2010, 2013
Можно ещё проще для одного цвета:
Код
=СЧЁТЕСЛИМН(A$2:A$35;A2;B$2:B$35;B2;C$2:C$35;C2)>1
А в большой формуле последнюю единичку можно заменять на 2, 3 и т.д. и задавать для УФ свой цвет для этой группы.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеМожно ещё проще для одного цвета:
Код
=СЧЁТЕСЛИМН(A$2:A$35;A2;B$2:B$35;B2;C$2:C$35;C2)>1
А в большой формуле последнюю единичку можно заменять на 2, 3 и т.д. и задавать для УФ свой цвет для этой группы.

Автор - Светлый
Дата добавления - 06.02.2020 в 10:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » условное форматирование одного столбца по данным других (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!