Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выделение ячеек усл.форматированием по нескольким значениям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выделение ячеек усл.форматированием по нескольким значениям (Формулы/Formulas)
Выделение ячеек усл.форматированием по нескольким значениям
Shtein Дата: Четверг, 06.02.2020, 13:23 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 73
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день. Помогите, пожалуйста, с задачкой.
Нужно чтобы цифры из каждой ячейки из столбца А (в нем цифры могут повторяться) сравнивались с эталонном блоком цифр из столбца С (в нем каждая цифра уникальна).
Если цифра из ячейки ст.А соответствует какой-то из столбца С, то выделять цветом.

В столбцах N и R я указал, как это примерно должно выглядеть, но там проверка идет только по одной ячейке. Можно, наверное, сделать многократно правило ус.форматирования, но указывать каждый раз другую ячейку, но если в этом эталонном столбце будут сотни цифр, будет времезатратно.
Может это можно не условным форматированием, а просто формулой в столбце рядом реализовать? Способ не важен, важно, чтобы потом понять, соответствует ли цифра из ячейки ст.А хоть какой-то из ст.С.
К сообщению приложен файл: Example1.xlsx(9.7 Kb)


"В мире давным давно все известно, главное знать у кого спросить"
Рэй Бредбери.


Сообщение отредактировал Shtein - Четверг, 06.02.2020, 13:24
 
Ответить
СообщениеДобрый день. Помогите, пожалуйста, с задачкой.
Нужно чтобы цифры из каждой ячейки из столбца А (в нем цифры могут повторяться) сравнивались с эталонном блоком цифр из столбца С (в нем каждая цифра уникальна).
Если цифра из ячейки ст.А соответствует какой-то из столбца С, то выделять цветом.

В столбцах N и R я указал, как это примерно должно выглядеть, но там проверка идет только по одной ячейке. Можно, наверное, сделать многократно правило ус.форматирования, но указывать каждый раз другую ячейку, но если в этом эталонном столбце будут сотни цифр, будет времезатратно.
Может это можно не условным форматированием, а просто формулой в столбце рядом реализовать? Способ не важен, важно, чтобы потом понять, соответствует ли цифра из ячейки ст.А хоть какой-то из ст.С.

Автор - Shtein
Дата добавления - 06.02.2020 в 13:23
amfor Дата: Четверг, 06.02.2020, 13:35 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 195
Репутация: 54 ±
Замечаний: 0% ±

Excel 2016
Добрый.Так?
Код
=СЧЁТЕСЛИ($C$3:$C$23;$A2)>0
К сообщению приложен файл: 5481531.xlsx(11.3 Kb)


Семь бед - один RESET.
 
Ответить
СообщениеДобрый.Так?
Код
=СЧЁТЕСЛИ($C$3:$C$23;$A2)>0

Автор - amfor
Дата добавления - 06.02.2020 в 13:35
Shtein Дата: Четверг, 06.02.2020, 13:39 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 73
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
работает hands
спасибо!


"В мире давным давно все известно, главное знать у кого спросить"
Рэй Бредбери.
 
Ответить
Сообщениеработает hands
спасибо!

Автор - Shtein
Дата добавления - 06.02.2020 в 13:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выделение ячеек усл.форматированием по нескольким значениям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!