Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Обрезка текста в ячейке по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Обрезка текста в ячейке по условию (Формулы/Formulas)
Обрезка текста в ячейке по условию
gnus1012 Дата: Понедельник, 10.02.2020, 14:24 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Прошу помочь с функцией обрезки текста по условию. Задача:
Ячейка А1 содержит текст с n-количеством запятых, необходимо в ячейку B1 вставить текст из ячейки А1 до 5-ой запятой, если же запятых меньше, то исходный текст.
функция
Код
=ЛЕВБ(A1;ПОИСК(A1;ПОДСТАВИТЬ(A1;", ";A1;5))-1)
работает, но не вставляет текст если запятых меньше, пробовал
Код
=ЕСЛИОШИБКА(ЛЕВБ(A1;ПОИСК(A1;ПОДСТАВИТЬ(A1;", ";A1;5))-1);A1)
тоже не получилось. Задача вроде не сложная, но знаний не хватает. Буду признателен за помощь.


Сообщение отредактировал gnus1012 - Понедельник, 10.02.2020, 14:31
 
Ответить
СообщениеПрошу помочь с функцией обрезки текста по условию. Задача:
Ячейка А1 содержит текст с n-количеством запятых, необходимо в ячейку B1 вставить текст из ячейки А1 до 5-ой запятой, если же запятых меньше, то исходный текст.
функция
Код
=ЛЕВБ(A1;ПОИСК(A1;ПОДСТАВИТЬ(A1;", ";A1;5))-1)
работает, но не вставляет текст если запятых меньше, пробовал
Код
=ЕСЛИОШИБКА(ЛЕВБ(A1;ПОИСК(A1;ПОДСТАВИТЬ(A1;", ";A1;5))-1);A1)
тоже не получилось. Задача вроде не сложная, но знаний не хватает. Буду признателен за помощь.

Автор - gnus1012
Дата добавления - 10.02.2020 в 14:24
Nic70y Дата: Понедельник, 10.02.2020, 14:43 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5945
Репутация: 1299 ±
Замечаний: 0% ±

ru13;10;03
Код
=ЛЕВБ(A1;ПОИСК("\";ПОДСТАВИТЬ(A1&"\";",";"\";5))-1)


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Код
=ЛЕВБ(A1;ПОИСК("\";ПОДСТАВИТЬ(A1&"\";",";"\";5))-1)

Автор - Nic70y
Дата добавления - 10.02.2020 в 14:43
gnus1012 Дата: Понедельник, 10.02.2020, 15:20 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Nic70y, Спасибо, сработало. Интересное решение.
 
Ответить
СообщениеNic70y, Спасибо, сработало. Интересное решение.

Автор - gnus1012
Дата добавления - 10.02.2020 в 15:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Обрезка текста в ячейке по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!