Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Рассортировать 1 столбец на несколько столбцов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Рассортировать 1 столбец на несколько столбцов (Формулы/Formulas)
Рассортировать 1 столбец на несколько столбцов
Privet2020 Дата: Понедельник, 10.02.2020, 16:00 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день. Есть вот такой список слева, там указаны графики работы (таких графиков 6000шт). Нужно чтобы из этого списка данные рассортировались в правые колонки на каждый день и в каждый столбец Открыты ОТ и ДО. Думаю тут нужно смысловые формулы какие-то. Кароче задачка не из легких.


Вот ссылка на весь список https://docs.google.com/spreads....sharing
Подскажите формулу, которой можно было бы это рассортировать. Как бы Вы действовали?
К сообщению приложен файл: _-2-.xlsx(71.0 Kb)


Сообщение отредактировал Privet2020 - Понедельник, 10.02.2020, 16:01
 
Ответить
СообщениеДобрый день. Есть вот такой список слева, там указаны графики работы (таких графиков 6000шт). Нужно чтобы из этого списка данные рассортировались в правые колонки на каждый день и в каждый столбец Открыты ОТ и ДО. Думаю тут нужно смысловые формулы какие-то. Кароче задачка не из легких.


Вот ссылка на весь список https://docs.google.com/spreads....sharing
Подскажите формулу, которой можно было бы это рассортировать. Как бы Вы действовали?

Автор - Privet2020
Дата добавления - 10.02.2020 в 16:00
Светлый Дата: Пятница, 14.02.2020, 11:40 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1432
Репутация: 376 ±
Замечаний: 0% ±

Excel 2010, 2013
Добрый день!
Вот такую массивную формулу можно использовать:
Код
=ПСТР($B2;2+ОСТАТ(СТОЛБЕЦ(B2);2)*6+АГРЕГАТ(14;6;ПОИСК(": ";$B2;ПОИСК(ЕСЛИ((СТОЛБЕЦ(B2)/2>=СТОЛБЕЦ($A:$G))*(СТОЛБЕЦ(B2)/2<СТРОКА($3:$9));ПОДСТАВИТЬ(ПСТР("пн-вт-ср-чт-пт-сб-вс-";СТОЛБЕЦ($A:$G)*3-2;3)&ПСТР("пн-вт-ср-чт-пт-сб-вс--";СТРОКА($2:$8)*3-2;2);"--";));$B2));1);5)
, но должен строго соблюдаться формат исходных данных.
*Для пустых дней работает некорректно. Берёт значение предыдущего непустого дня.
Дорабатывать? Или уже нет необходимости?
К сообщению приложен файл: -2-1.xlsx(73.9 Kb)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Пятница, 14.02.2020, 13:38
 
Ответить
СообщениеДобрый день!
Вот такую массивную формулу можно использовать:
Код
=ПСТР($B2;2+ОСТАТ(СТОЛБЕЦ(B2);2)*6+АГРЕГАТ(14;6;ПОИСК(": ";$B2;ПОИСК(ЕСЛИ((СТОЛБЕЦ(B2)/2>=СТОЛБЕЦ($A:$G))*(СТОЛБЕЦ(B2)/2<СТРОКА($3:$9));ПОДСТАВИТЬ(ПСТР("пн-вт-ср-чт-пт-сб-вс-";СТОЛБЕЦ($A:$G)*3-2;3)&ПСТР("пн-вт-ср-чт-пт-сб-вс--";СТРОКА($2:$8)*3-2;2);"--";));$B2));1);5)
, но должен строго соблюдаться формат исходных данных.
*Для пустых дней работает некорректно. Берёт значение предыдущего непустого дня.
Дорабатывать? Или уже нет необходимости?

Автор - Светлый
Дата добавления - 14.02.2020 в 11:40
Светлый Дата: Пятница, 14.02.2020, 23:26 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1432
Репутация: 376 ±
Замечаний: 0% ±

Excel 2010, 2013
Исправил:
Код
=ЕСЛИОШИБКА(ПСТР($B2;2+ОСТАТ(СТОЛБЕЦ(B2);2)*6+АГРЕГАТ(14;6;ПОИСК(": ";$B2;ПОИСК(ЕСЛИ((СТОЛБЕЦ(B2)/2>=СТОЛБЕЦ($A:$G))*(СТОЛБЕЦ(B2)/2<СТРОКА($3:$9))*(9>СТРОКА($3:$9))+(ОТБР(СТОЛБЕЦ(B2)/2)=СТОЛБЕЦ($A:$G));ПОДСТАВИТЬ(ПСТР("пн-вт-ср-чт-пт-сб-вс-";СТОЛБЕЦ($A:$G)*3-2;3)&ПСТР("пн-вт-ср-чт-пт-сб-вс--";СТРОКА($2:$8)*3-2;2);"--";));$B2));1);5);"")
К сообщению приложен файл: -2-2.xlsx(83.0 Kb)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Пятница, 14.02.2020, 23:28
 
Ответить
СообщениеИсправил:
Код
=ЕСЛИОШИБКА(ПСТР($B2;2+ОСТАТ(СТОЛБЕЦ(B2);2)*6+АГРЕГАТ(14;6;ПОИСК(": ";$B2;ПОИСК(ЕСЛИ((СТОЛБЕЦ(B2)/2>=СТОЛБЕЦ($A:$G))*(СТОЛБЕЦ(B2)/2<СТРОКА($3:$9))*(9>СТРОКА($3:$9))+(ОТБР(СТОЛБЕЦ(B2)/2)=СТОЛБЕЦ($A:$G));ПОДСТАВИТЬ(ПСТР("пн-вт-ср-чт-пт-сб-вс-";СТОЛБЕЦ($A:$G)*3-2;3)&ПСТР("пн-вт-ср-чт-пт-сб-вс--";СТРОКА($2:$8)*3-2;2);"--";));$B2));1);5);"")

Автор - Светлый
Дата добавления - 14.02.2020 в 23:26
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Рассортировать 1 столбец на несколько столбцов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!