Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет уникальных значений кроме пустых и с одним условием - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет уникальных значений кроме пустых и с одним условием (Формулы/Formulas)
Подсчет уникальных значений кроме пустых и с одним условием
Лорик Дата: Среда, 12.02.2020, 10:42 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 109
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте!
Перепробовала разные известные мне варианты, но чего то у меня не получилось ничего. Нужна формула для подсчета уникальных значений (кроме пустых) из пяти списков и с одним условием. Посмотрите, пожалуйста.
На листе (в разных диапазонах) есть пять списков наименований. Нужно посчитать количество уникальных значений из этих списков (кроме пустых) и кроме слова "яблоко". Пример в файле.
К сообщению приложен файл: __-_-_..xlsx(10.0 Kb)
 
Ответить
СообщениеЗдравствуйте!
Перепробовала разные известные мне варианты, но чего то у меня не получилось ничего. Нужна формула для подсчета уникальных значений (кроме пустых) из пяти списков и с одним условием. Посмотрите, пожалуйста.
На листе (в разных диапазонах) есть пять списков наименований. Нужно посчитать количество уникальных значений из этих списков (кроме пустых) и кроме слова "яблоко". Пример в файле.

Автор - Лорик
Дата добавления - 12.02.2020 в 10:42
Pelena Дата: Среда, 12.02.2020, 11:12 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18556
Репутация: 4203 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Формула массива
Код
=СУММ(ЕСЛИОШИБКА(1/СЧЁТЕСЛИ(B2:J24;B2:J24)/(B2:J24<>"")/(B2:J24<>"яблоко");0))
К сообщению приложен файл: 1571225.xlsx(11.2 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Формула массива
Код
=СУММ(ЕСЛИОШИБКА(1/СЧЁТЕСЛИ(B2:J24;B2:J24)/(B2:J24<>"")/(B2:J24<>"яблоко");0))

Автор - Pelena
Дата добавления - 12.02.2020 в 11:12
Лорик Дата: Четверг, 13.02.2020, 03:08 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 109
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте!
Pelena, спасибо. Но подсчет должен вестись не во всем диапазоне B2:J24, а учитывать только диапазоны списков, так как они будут размещаться в разных местах листа
На листе (в разных диапазонах)
и между ними могут быть другие показатели, которые не нужно включать в подсчет (в этом у меня и возникла проблема). Примерно в файле. Извините, если непонятно объяснила.
К сообщению приложен файл: _..xlsx(11.6 Kb)


Сообщение отредактировал Лорик - Четверг, 13.02.2020, 03:08
 
Ответить
СообщениеЗдравствуйте!
Pelena, спасибо. Но подсчет должен вестись не во всем диапазоне B2:J24, а учитывать только диапазоны списков, так как они будут размещаться в разных местах листа
На листе (в разных диапазонах)
и между ними могут быть другие показатели, которые не нужно включать в подсчет (в этом у меня и возникла проблема). Примерно в файле. Извините, если непонятно объяснила.

Автор - Лорик
Дата добавления - 13.02.2020 в 03:08
Лорик Дата: Понедельник, 17.02.2020, 07:30 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 109
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте!
Вот подсказали варианты (формулы массива):

Код
=СУММ(ЕСЛИОШИБКА(1/СЧЁТЕСЛИ(B2:M24;B2:M24)/(Т(+B2:M24)<>"")/(B2:M24<>"яблоко");0))


Код
=SUM(IFERROR(1/COUNTIF(B2:M24;B2:M24)/(B2:M24<>"")/(B2:M24<>"яблоко")/(ISTEXT(B2:M24));0))


Код
=SUM(IFERROR(1/COUNTIF(B2:M24;B2:M24)/(B2:M24<>"")/(B2:M24<>"яблоко")/ISNUMBER(FIND(" "&COLUMN(B2:M24)&" ";" 2 4 6 8 10 13 "));0))


Сообщение отредактировал Лорик - Понедельник, 17.02.2020, 07:32
 
Ответить
СообщениеЗдравствуйте!
Вот подсказали варианты (формулы массива):

Код
=СУММ(ЕСЛИОШИБКА(1/СЧЁТЕСЛИ(B2:M24;B2:M24)/(Т(+B2:M24)<>"")/(B2:M24<>"яблоко");0))


Код
=SUM(IFERROR(1/COUNTIF(B2:M24;B2:M24)/(B2:M24<>"")/(B2:M24<>"яблоко")/(ISTEXT(B2:M24));0))


Код
=SUM(IFERROR(1/COUNTIF(B2:M24;B2:M24)/(B2:M24<>"")/(B2:M24<>"яблоко")/ISNUMBER(FIND(" "&COLUMN(B2:M24)&" ";" 2 4 6 8 10 13 "));0))

Автор - Лорик
Дата добавления - 17.02.2020 в 07:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет уникальных значений кроме пустых и с одним условием (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!