Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос ячеек из нескольких столбцов в один - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос ячеек из нескольких столбцов в один (Формулы/Formulas)
Перенос ячеек из нескольких столбцов в один
txgwy Дата: Понедельник, 17.02.2020, 10:49 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте! Ищу возможность как перенести содержимое нескольких разбросанных ячеек из нескольких столбцов в один, с сохранением порядка строк.
У нужных ячеек есть общая часть - FFFFF. Такая ячейка одна в строке



В сети нашел вариант решения моей задачи, человеку предложили такой макрос:

[vba]
Код

Sub Find_All()
Dim FindRange As Range, c As Range
Dim OutColumn As String, x As Long
'Column Where we put the data, change to suit
OutColumn = "Z"
x = 1
For Each c In ActiveSheet.UsedRange
If c.Font.Color = RGB(255, 0, 0) Then
If FindRange Is Nothing Then
Set FindRange = c
Else
Set FindRange = Union(FindRange, c)
End If
End If
Next

If Not FindRange Is Nothing Then
For Each c In FindRange
Cells(x, OutColumn) = c.Address
Cells(x, OutColumn).Offset(, 1) = c.Value
x = x + 1
Next
End If

End Sub
[/vba]

(https://answers.microsoft.com/en-us/office/forum/office_2010-excel/how-to-copy-results-from-find-and-replace-dialog/951f6128-8917-450e-98c1-6c13711c40f0)

Для его работы я форматирую нужные ячейки в красный текст через найти-заменить-формат. Макрос в принципе работает у меня, но только наполовину, т.е. нужные ячейки находит, но в целевом столбце он показывает только ссылки на них (формата S$12$), и они почему-то располагаются со смещением на пару строк.

Помогите пожалуйста
К сообщению приложен файл: 1788119.xlsx(9.7 Kb) · 9992027.png(95.1 Kb)


Сообщение отредактировал txgwy - Понедельник, 17.02.2020, 16:16
 
Ответить
СообщениеЗдравствуйте! Ищу возможность как перенести содержимое нескольких разбросанных ячеек из нескольких столбцов в один, с сохранением порядка строк.
У нужных ячеек есть общая часть - FFFFF. Такая ячейка одна в строке



В сети нашел вариант решения моей задачи, человеку предложили такой макрос:

[vba]
Код

Sub Find_All()
Dim FindRange As Range, c As Range
Dim OutColumn As String, x As Long
'Column Where we put the data, change to suit
OutColumn = "Z"
x = 1
For Each c In ActiveSheet.UsedRange
If c.Font.Color = RGB(255, 0, 0) Then
If FindRange Is Nothing Then
Set FindRange = c
Else
Set FindRange = Union(FindRange, c)
End If
End If
Next

If Not FindRange Is Nothing Then
For Each c In FindRange
Cells(x, OutColumn) = c.Address
Cells(x, OutColumn).Offset(, 1) = c.Value
x = x + 1
Next
End If

End Sub
[/vba]

(https://answers.microsoft.com/en-us/office/forum/office_2010-excel/how-to-copy-results-from-find-and-replace-dialog/951f6128-8917-450e-98c1-6c13711c40f0)

Для его работы я форматирую нужные ячейки в красный текст через найти-заменить-формат. Макрос в принципе работает у меня, но только наполовину, т.е. нужные ячейки находит, но в целевом столбце он показывает только ссылки на них (формата S$12$), и они почему-то располагаются со смещением на пару строк.

Помогите пожалуйста

Автор - txgwy
Дата добавления - 17.02.2020 в 10:49
Pelena Дата: Понедельник, 17.02.2020, 13:01 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18551
Репутация: 4200 ±
Замечаний: ±

Excel 2016 & Mac Excel
txgwy, оформите макрос тегами с помощью кнопки # в режиме правки поста


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
Сообщениеtxgwy, оформите макрос тегами с помощью кнопки # в режиме правки поста

Автор - Pelena
Дата добавления - 17.02.2020 в 13:01
txgwy Дата: Вторник, 18.02.2020, 10:21 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
В общем все оказалось просто, помогла формула
[vba]
Код
=ИНДЕКС(B1:E1;ПОИСКПОЗ("*FFFF*";B1:E1;))
[/vba]

осталось выяснить как собирать несколько значений, если найденных ячеек будет 2 и больше в строке


Сообщение отредактировал txgwy - Вторник, 18.02.2020, 10:58
 
Ответить
СообщениеВ общем все оказалось просто, помогла формула
[vba]
Код
=ИНДЕКС(B1:E1;ПОИСКПОЗ("*FFFF*";B1:E1;))
[/vba]

осталось выяснить как собирать несколько значений, если найденных ячеек будет 2 и больше в строке

Автор - txgwy
Дата добавления - 18.02.2020 в 10:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос ячеек из нескольких столбцов в один (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!