Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет времени по нескольким критериям - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет времени по нескольким критериям (Формулы/Formulas)
Подсчет времени по нескольким критериям
Shtalker Дата: Среда, 19.02.2020, 08:55 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Суть задачи:
1. Посчитать кол-во минут только у исходящих звонков.
Но один нюанс. Я делал так: значение в минутах и секундах в каждой строчке я переводил в число с помощью:
Код
=ЕСЛИОШИБКА(--("0:0:"&ПОДСТАВИТЬ(I3821," сек.","")),--("0:"&ПОДСТАВИТЬ(ПОДСТАВИТЬ(I3821," сек.","")," мин. ",":")))

для этого приходилось в ручную добавлять еще один столбец.
Потом с помощью СУММЕСЛИМН, складывал по нескольким критериям и получал результат.:
Код
=СУММЕСЛИМН(J:J,G:G,"Исходящий")


Считать общее кол-во минут без критериев и дополнительного столбца можно с помощью формулы массива :
Код
=СУММ(ЕСЛИОШИБКА(--("0:0:"&ПОДСТАВИТЬ(I2:I3893," сек.","")),--("0:"&ПОДСТАВИТЬ(ПОДСТАВИТЬ(I2:I3893," сек.","")," мин. ",":"))))

Помогите посчитать кол-во минут только у исходящих звонков не используя доп.столбец потому что добавлять столбец не удобно так как записей бывает по 10 тысяч.
Пробовал в формулу массива вместо СУММ подставить СУММЕСЛИМН и добавить критерии но получал ошибку.
К сообщению приложен файл: 8044944.xlsx(8.5 Kb)
 
Ответить
СообщениеСуть задачи:
1. Посчитать кол-во минут только у исходящих звонков.
Но один нюанс. Я делал так: значение в минутах и секундах в каждой строчке я переводил в число с помощью:
Код
=ЕСЛИОШИБКА(--("0:0:"&ПОДСТАВИТЬ(I3821," сек.","")),--("0:"&ПОДСТАВИТЬ(ПОДСТАВИТЬ(I3821," сек.","")," мин. ",":")))

для этого приходилось в ручную добавлять еще один столбец.
Потом с помощью СУММЕСЛИМН, складывал по нескольким критериям и получал результат.:
Код
=СУММЕСЛИМН(J:J,G:G,"Исходящий")


Считать общее кол-во минут без критериев и дополнительного столбца можно с помощью формулы массива :
Код
=СУММ(ЕСЛИОШИБКА(--("0:0:"&ПОДСТАВИТЬ(I2:I3893," сек.","")),--("0:"&ПОДСТАВИТЬ(ПОДСТАВИТЬ(I2:I3893," сек.","")," мин. ",":"))))

Помогите посчитать кол-во минут только у исходящих звонков не используя доп.столбец потому что добавлять столбец не удобно так как записей бывает по 10 тысяч.
Пробовал в формулу массива вместо СУММ подставить СУММЕСЛИМН и добавить критерии но получал ошибку.

Автор - Shtalker
Дата добавления - 19.02.2020 в 08:55
Pelena Дата: Среда, 19.02.2020, 09:19 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18561
Репутация: 4204 ±
Замечаний: ±

Excel 2016 & Mac Excel
Формула массива
Код
=СУММ(ЕСЛИОШИБКА(--("0:0:"&ПОДСТАВИТЬ(D1:D3893;" сек.";""));--("0:"&ПОДСТАВИТЬ(ПОДСТАВИТЬ(D1:D3893;" сек.";"");" мин. ";":")))*(B1:B3893="Исходящий"))
К сообщению приложен файл: 2536071.xlsx(9.4 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеФормула массива
Код
=СУММ(ЕСЛИОШИБКА(--("0:0:"&ПОДСТАВИТЬ(D1:D3893;" сек.";""));--("0:"&ПОДСТАВИТЬ(ПОДСТАВИТЬ(D1:D3893;" сек.";"");" мин. ";":")))*(B1:B3893="Исходящий"))

Автор - Pelena
Дата добавления - 19.02.2020 в 09:19
Shtalker Дата: Четверг, 20.02.2020, 10:51 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Формула массива

Спасибо!
 
Ответить
Сообщение
Формула массива

Спасибо!

Автор - Shtalker
Дата добавления - 20.02.2020 в 10:51
Shtalker Дата: Четверг, 20.02.2020, 13:58 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Подскажите пожалуйста как в том же примере посчитать кол-во ячеек в которых, время больше 30 сек?
 
Ответить
СообщениеПодскажите пожалуйста как в том же примере посчитать кол-во ячеек в которых, время больше 30 сек?

Автор - Shtalker
Дата добавления - 20.02.2020 в 13:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет времени по нескольким критериям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!