Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула для вывода номера строки - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для вывода номера строки (Формулы/Formulas)
Формула для вывода номера строки
Welets Дата: Среда, 19.02.2020, 11:24 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Есть файл с подобными записями, разделённый проблемами

0 Картофель
0 Баклажан
1 Морковь

0 Маша
0 Петя
1 Даша
1 Глаша

1 - это правильный ответ, 0 - нет

Как преобразовать 1 в номер строки? (Даша - 3, Глаша - 4, Морковь -3)


Сообщение отредактировал Serge_007 - Среда, 19.02.2020, 17:21
 
Ответить
СообщениеДобрый день.
Есть файл с подобными записями, разделённый проблемами

0 Картофель
0 Баклажан
1 Морковь

0 Маша
0 Петя
1 Даша
1 Глаша

1 - это правильный ответ, 0 - нет

Как преобразовать 1 в номер строки? (Даша - 3, Глаша - 4, Морковь -3)

Автор - Welets
Дата добавления - 19.02.2020 в 11:24
Nic70y Дата: Среда, 19.02.2020, 11:46 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7731
Репутация: 1856 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ(-ЛЕВБ(A1);СТРОКА();0)&ПСТР(A1;2;ДЛСТР(A1))


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Среда, 19.02.2020, 11:47
 
Ответить
Сообщение
Код
=ЕСЛИ(-ЛЕВБ(A1);СТРОКА();0)&ПСТР(A1;2;ДЛСТР(A1))

Автор - Nic70y
Дата добавления - 19.02.2020 в 11:46
Serge_007 Дата: Среда, 19.02.2020, 12:51 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 15415
Репутация: 2537 ±
Замечаний: ±

Excel 2016
Здравствуйте

Как преобразовать 1 в номер строки?
Код
=ЛЕВБ(A1)*СТРОКА()


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Как преобразовать 1 в номер строки?
Код
=ЛЕВБ(A1)*СТРОКА()

Автор - Serge_007
Дата добавления - 19.02.2020 в 12:51
Welets Дата: Пятница, 21.02.2020, 11:21 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!

А что сделать, все варианты ответа идут в столбик?

0 Картофель
0 Баклажан
1 Морковь

0 Маша
0 Петя
1 Даша
1 Глаша

Тогда получится: Морковь 3, Даша 7, Глаша 8

Как лучше сделать?
 
Ответить
СообщениеДобрый день!

А что сделать, все варианты ответа идут в столбик?

0 Картофель
0 Баклажан
1 Морковь

0 Маша
0 Петя
1 Даша
1 Глаша

Тогда получится: Морковь 3, Даша 7, Глаша 8

Как лучше сделать?

Автор - Welets
Дата добавления - 21.02.2020 в 11:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для вывода номера строки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!