Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/LOOKUP функция выдает неправильный результат. ЧЯДНТ? - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » LOOKUP функция выдает неправильный результат. ЧЯДНТ? (Формулы/Formulas)
LOOKUP функция выдает неправильный результат. ЧЯДНТ?
Chesno4ok Дата: Воскресенье, 23.02.2020, 01:16 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Имеется соверешенно простая табличка для практики. Задача - по значению B5 вывести цену. Самый очевидный вариант - использование функции лукап. Но по какой-то загадочной причине функция возвращает не совершенно другое значение. Уже игрался с копированием-вставкой туда-обратно ячеек, задавания значений заново, все равно результат плачевен.
Собственно, что я делаю не так в столь нетривиальной формуле то? Помогите понять, пожалуйста, у меня варианты закончились.
Табличку с неправильным выводом прикладываю.
К сообщению приложен файл: 3911991.xlsx(9.4 Kb)
 
Ответить
СообщениеИмеется соверешенно простая табличка для практики. Задача - по значению B5 вывести цену. Самый очевидный вариант - использование функции лукап. Но по какой-то загадочной причине функция возвращает не совершенно другое значение. Уже игрался с копированием-вставкой туда-обратно ячеек, задавания значений заново, все равно результат плачевен.
Собственно, что я делаю не так в столь нетривиальной формуле то? Помогите понять, пожалуйста, у меня варианты закончились.
Табличку с неправильным выводом прикладываю.

Автор - Chesno4ok
Дата добавления - 23.02.2020 в 01:16
Che79 Дата: Воскресенье, 23.02.2020, 01:38 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1649
Репутация: 306 ±
Замечаний: 0% ±

2013 Win, 365 Mac
И Вам здравствуйте.
Самый очевидный вариант - использование функции лукап
Ну, каждому своё...
у меня варианты закончились
предлагаю вариант - Прочитать справку о функции
Цитата
Важно: Значения в аргументе просматриваемый_вектор должны быть расположены в порядке возрастания: ..., -2, -1, 0, 1, 2, ..., A-Z, ЛОЖЬ, ИСТИНА; в противном случае функция ПРОСМОТР может возвратить неправильный результат


Делай нормально и будет нормально!
 
Ответить
СообщениеИ Вам здравствуйте.
Самый очевидный вариант - использование функции лукап
Ну, каждому своё...
у меня варианты закончились
предлагаю вариант - Прочитать справку о функции
Цитата
Важно: Значения в аргументе просматриваемый_вектор должны быть расположены в порядке возрастания: ..., -2, -1, 0, 1, 2, ..., A-Z, ЛОЖЬ, ИСТИНА; в противном случае функция ПРОСМОТР может возвратить неправильный результат

Автор - Che79
Дата добавления - 23.02.2020 в 01:38
Xenus91 Дата: Воскресенье, 23.02.2020, 01:39 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 113
Репутация: 11 ±
Замечаний: 0% ±

Excel 2016
Chesno4ok, доброй ночи
Код
=ВПР(B5;$A$16:$B$19;2;0)
К сообщению приложен файл: 8663986.xlsx(9.3 Kb)
 
Ответить
СообщениеChesno4ok, доброй ночи
Код
=ВПР(B5;$A$16:$B$19;2;0)

Автор - Xenus91
Дата добавления - 23.02.2020 в 01:39
Chesno4ok Дата: Вторник, 25.02.2020, 13:43 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Che79, действительно, я как-то не учел, что правило сортировки в том числе к колонке А относится...спасибо!
Xenus91, спасибо за решение! оптимальнейший подход, как по мне.
 
Ответить
СообщениеChe79, действительно, я как-то не учел, что правило сортировки в том числе к колонке А относится...спасибо!
Xenus91, спасибо за решение! оптимальнейший подход, как по мне.

Автор - Chesno4ok
Дата добавления - 25.02.2020 в 13:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » LOOKUP функция выдает неправильный результат. ЧЯДНТ? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!