Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как узнать формулу с истиной? - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как узнать формулу с истиной? (Формулы/Formulas)
Как узнать формулу с истиной?
stalber Дата: Среда, 26.02.2020, 22:41 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 320
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Добрый вечер, возможно ли это вообще решить?

Например: есть такая формула:
Код
=И(A1>0)+И(B1>0)+И(C1>0)

A1 = 0 у нас Ложь
B1 = 0 у нас Ложь
C1 = 1 у нас Истина

И мне нужно вытащить вот эту формулу в которой истина: И(C1>0) результат который нужно увидеть, это сама формула в которой истина.
Вот это нужно мне увидеть, формулу которая дала мне истину: И(C1>0)

Может быть такое:
A1 = 0 у нас Ложь
B1 = 1 у нас Истина
C1 = 1 у нас Истина
Тогда нужно будет увидеть 2 формулы: И(B1>0) И(C1>0)


Сообщение отредактировал stalber - Среда, 26.02.2020, 22:45
 
Ответить
СообщениеДобрый вечер, возможно ли это вообще решить?

Например: есть такая формула:
Код
=И(A1>0)+И(B1>0)+И(C1>0)

A1 = 0 у нас Ложь
B1 = 0 у нас Ложь
C1 = 1 у нас Истина

И мне нужно вытащить вот эту формулу в которой истина: И(C1>0) результат который нужно увидеть, это сама формула в которой истина.
Вот это нужно мне увидеть, формулу которая дала мне истину: И(C1>0)

Может быть такое:
A1 = 0 у нас Ложь
B1 = 1 у нас Истина
C1 = 1 у нас Истина
Тогда нужно будет увидеть 2 формулы: И(B1>0) И(C1>0)

Автор - stalber
Дата добавления - 26.02.2020 в 22:41
stalber Дата: Среда, 26.02.2020, 23:08 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 320
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Или может быть есть возможность удалить формулы с истиной из формулы:
Например : оставить в первом варианте: =И(A1>0)+И(B1>0) а во втором =И(A1>0)
 
Ответить
СообщениеИли может быть есть возможность удалить формулы с истиной из формулы:
Например : оставить в первом варианте: =И(A1>0)+И(B1>0) а во втором =И(A1>0)

Автор - stalber
Дата добавления - 26.02.2020 в 23:08
bigor Дата: Среда, 26.02.2020, 23:19 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 681
Репутация: 139 ±
Замечаний: 0% ±

нет
А зачем в ваших формулах И? И какова конечная цель всех этих действий?
 
Ответить
СообщениеА зачем в ваших формулах И? И какова конечная цель всех этих действий?

Автор - bigor
Дата добавления - 26.02.2020 в 23:19
gling Дата: Среда, 26.02.2020, 23:19 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2371
Репутация: 617 ±
Замечаний: 0% ±

2010
Добрый.
Так?
Код
=ЕСЛИ((A1>0)+(B1>0)+(C1>0);ЕСЛИ(A1>0;ПОДСТАВИТЬ(ЯЧЕЙКА("адрес";A1);"$";"")&"; ";"")&ЕСЛИ(B1>0;ПОДСТАВИТЬ(ЯЧЕЙКА("адрес";B1);"$";"")&"; ";"")&ЕСЛИ(C1>0;ПОДСТАВИТЬ(ЯЧЕЙКА("адрес";C1);"$";"");""))


ЯД-41001506838083
 
Ответить
СообщениеДобрый.
Так?
Код
=ЕСЛИ((A1>0)+(B1>0)+(C1>0);ЕСЛИ(A1>0;ПОДСТАВИТЬ(ЯЧЕЙКА("адрес";A1);"$";"")&"; ";"")&ЕСЛИ(B1>0;ПОДСТАВИТЬ(ЯЧЕЙКА("адрес";B1);"$";"")&"; ";"")&ЕСЛИ(C1>0;ПОДСТАВИТЬ(ЯЧЕЙКА("адрес";C1);"$";"");""))

Автор - gling
Дата добавления - 26.02.2020 в 23:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как узнать формулу с истиной? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!