Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула с 3 переменными и одним условием - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула с 3 переменными и одним условием (Формулы/Formulas)
Формула с 3 переменными и одним условием
SlavaK Дата: Четверг, 27.02.2020, 14:10 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Мучаюсь уже час с проблемой:

Есть два столбца с переменными и нужно чтобы в 3ю ячейку подставлялось значение. Сложность в том, что для одного из вариантов нужно по второй ячейке выбирать условие по ключевому слову.
Более понятно во вложении.

Помогите плз!!

Заранее спасибо!
К сообщению приложен файл: 9852397.xls(41.5 Kb)
 
Ответить
СообщениеМучаюсь уже час с проблемой:

Есть два столбца с переменными и нужно чтобы в 3ю ячейку подставлялось значение. Сложность в том, что для одного из вариантов нужно по второй ячейке выбирать условие по ключевому слову.
Более понятно во вложении.

Помогите плз!!

Заранее спасибо!

Автор - SlavaK
Дата добавления - 27.02.2020 в 14:10
YouGreed Дата: Четверг, 27.02.2020, 15:09 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 589
Репутация: 123 ±
Замечаний: 0% ±

Excel 2010
SlavaK, Да, пожалуйста.
Код
=ЕСЛИ($A3='Перечень ресурсов'!$D$3;'Перечень ресурсов'!$H$4;ЕСЛИ(И(March_2020!$A3='Перечень ресурсов'!$D$2;ЕЧИСЛО(НАЙТИ("Samsung";March_2020!$B3;1)));'Перечень ресурсов'!$H$2;ЕСЛИ(И(March_2020!$A3='Перечень ресурсов'!$D$2;ЕЧИСЛО(НАЙТИ("Danon";March_2020!$B3;1)));'Перечень ресурсов'!$H$3;"")))


В случае если ни одно из условий, не выполняется, ставим пусто.
К сообщению приложен файл: Incredible_else.xls(42.0 Kb)


Сообщение отредактировал YouGreed - Четверг, 27.02.2020, 15:11
 
Ответить
СообщениеSlavaK, Да, пожалуйста.
Код
=ЕСЛИ($A3='Перечень ресурсов'!$D$3;'Перечень ресурсов'!$H$4;ЕСЛИ(И(March_2020!$A3='Перечень ресурсов'!$D$2;ЕЧИСЛО(НАЙТИ("Samsung";March_2020!$B3;1)));'Перечень ресурсов'!$H$2;ЕСЛИ(И(March_2020!$A3='Перечень ресурсов'!$D$2;ЕЧИСЛО(НАЙТИ("Danon";March_2020!$B3;1)));'Перечень ресурсов'!$H$3;"")))


В случае если ни одно из условий, не выполняется, ставим пусто.

Автор - YouGreed
Дата добавления - 27.02.2020 в 15:09
SlavaK Дата: Четверг, 27.02.2020, 16:03 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Заработало!
Спасибо hands
 
Ответить
СообщениеЗаработало!
Спасибо hands

Автор - SlavaK
Дата добавления - 27.02.2020 в 16:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула с 3 переменными и одним условием (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!