Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Получить данные из массива и проссумировать их - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Получить данные из массива и проссумировать их (Формулы/Formulas)
Получить данные из массива и проссумировать их
Romanus Дата: Четверг, 27.02.2020, 18:44 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Доброго Вам времени суток!
Прошу Вас помочь с решением вот такой задачки:
Имеется массив данных (в прилагаемой таблице).
Среди данных каждая N-ная ячейка имеет текстовое содержимое типа (выделил несколько примеров желтым): MACHINING TIME =17'36.516"
где,
1) MACHINING TIME = - это постоянный текст, как ориентир для нас
2) цифра между знаками " = " и " ' " - это минуты
3) цифра между знаками " ' " и " " " - это секунды
в этом примере 17 минут и 36 секунд
Нам из такого типа ячеек необходимо получить данные о МИНУТАХ и СЕКУНДАХ и проссумировать их
Главная цель - получить ИТОГО в СЕКУНДАХ из всего массива данных в файле
К сообщению приложен файл: SuperMinets.xlsx(12.0 Kb)
 
Ответить
СообщениеДоброго Вам времени суток!
Прошу Вас помочь с решением вот такой задачки:
Имеется массив данных (в прилагаемой таблице).
Среди данных каждая N-ная ячейка имеет текстовое содержимое типа (выделил несколько примеров желтым): MACHINING TIME =17'36.516"
где,
1) MACHINING TIME = - это постоянный текст, как ориентир для нас
2) цифра между знаками " = " и " ' " - это минуты
3) цифра между знаками " ' " и " " " - это секунды
в этом примере 17 минут и 36 секунд
Нам из такого типа ячеек необходимо получить данные о МИНУТАХ и СЕКУНДАХ и проссумировать их
Главная цель - получить ИТОГО в СЕКУНДАХ из всего массива данных в файле

Автор - Romanus
Дата добавления - 27.02.2020 в 18:44
Pelena Дата: Четверг, 27.02.2020, 19:29 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18561
Репутация: 4204 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Вариант с помощью Power Query
К сообщению приложен файл: 4076893.xlsx(23.3 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Вариант с помощью Power Query

Автор - Pelena
Дата добавления - 27.02.2020 в 19:29
Светлый Дата: Четверг, 27.02.2020, 19:32 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1742
Репутация: 478 ±
Замечаний: 0% ±

Excel 2013, 2016
Добрый вечер!
Формула массива:
Код
=СУММ(ЕСЛИОШИБКА(ЛЕВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(B2:B301;"MACHINING TIME =";);"'";" ");6)*60+ЛЕВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПСТР(B2:B301;ПОИСК("'";B2:B301)+1;9);"""";" ");".";ПСТР(1/2;2;1));9);))
*Встречаются значения без ' , поэтому считает неправильно.
Формула массива:
Код
=СУММ(ЕСЛИОШИБКА(86400*ЛЕВБ("0:"&ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПСТР(B2:B301;ПОИСК(" =";B2:B301)+2;20);"'";":");"""";ПОВТОР(" ";99));".";ПСТР(1/2;2;1));20);))
**Намудрил. Всё проще:
Код
=СУММ(ЕСЛИОШИБКА(86400*("0:"&ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПСТР(B2:B301;ПОИСК(" =";B2:B301)+2;20);"'";":");"""";);".";ПСТР(1/2;2;1)));))
***
Код
=СУММ(86400*ЕСЛИОШИБКА("0:"&ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПСТР(B2:B301;ПОИСК(" =";B2:B301)+2;20);"'";":");"""";);".";ПСТР(1/2;2;1));))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Четверг, 27.02.2020, 22:34
 
Ответить
СообщениеДобрый вечер!
Формула массива:
Код
=СУММ(ЕСЛИОШИБКА(ЛЕВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(B2:B301;"MACHINING TIME =";);"'";" ");6)*60+ЛЕВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПСТР(B2:B301;ПОИСК("'";B2:B301)+1;9);"""";" ");".";ПСТР(1/2;2;1));9);))
*Встречаются значения без ' , поэтому считает неправильно.
Формула массива:
Код
=СУММ(ЕСЛИОШИБКА(86400*ЛЕВБ("0:"&ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПСТР(B2:B301;ПОИСК(" =";B2:B301)+2;20);"'";":");"""";ПОВТОР(" ";99));".";ПСТР(1/2;2;1));20);))
**Намудрил. Всё проще:
Код
=СУММ(ЕСЛИОШИБКА(86400*("0:"&ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПСТР(B2:B301;ПОИСК(" =";B2:B301)+2;20);"'";":");"""";);".";ПСТР(1/2;2;1)));))
***
Код
=СУММ(86400*ЕСЛИОШИБКА("0:"&ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПСТР(B2:B301;ПОИСК(" =";B2:B301)+2;20);"'";":");"""";);".";ПСТР(1/2;2;1));))

Автор - Светлый
Дата добавления - 27.02.2020 в 19:32
Светлый Дата: Пятница, 28.02.2020, 19:56 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1742
Репутация: 478 ±
Замечаний: 0% ±

Excel 2013, 2016
Можно даже так:
Код
=СУММ(ЕСЛИОШИБКА(86400*ПОДСТАВИТЬ("0:"&ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПСТР(B2:B301;19;20);"'";":");"""";);".";",");))
*
Код
=СУММ(ЕСЛИОШИБКА(86400*ПОДСТАВИТЬ("0:"&ПОДСТАВИТЬ(ПСТР(B2:B301;19;ДЛСТР(B2:B301)-19);"'";":");".";",");))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Пятница, 28.02.2020, 22:32
 
Ответить
СообщениеМожно даже так:
Код
=СУММ(ЕСЛИОШИБКА(86400*ПОДСТАВИТЬ("0:"&ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПСТР(B2:B301;19;20);"'";":");"""";);".";",");))
*
Код
=СУММ(ЕСЛИОШИБКА(86400*ПОДСТАВИТЬ("0:"&ПОДСТАВИТЬ(ПСТР(B2:B301;19;ДЛСТР(B2:B301)-19);"'";":");".";",");))

Автор - Светлый
Дата добавления - 28.02.2020 в 19:56
Romanus Дата: Вторник, 03.03.2020, 12:23 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Друзья, большое спасибо! Очень помогли)
 
Ответить
СообщениеДрузья, большое спасибо! Очень помогли)

Автор - Romanus
Дата добавления - 03.03.2020 в 12:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Получить данные из массива и проссумировать их (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!