Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматическое заполнение данных - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое заполнение данных (Формулы/Formulas)
Автоматическое заполнение данных
FoxLord Дата: Пятница, 28.02.2020, 09:16 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Приветствую.
Подскажите какие есть возможности для оформления такой задачи:
При выборе данных в A3 ячейки B3,C3,D3, заполняются автоматически: вытаскивает значения из таблицы соответствующие выбранному.
Через Индекс ПоискПоз могу проверить только один вариант. Может через несколько ЕСЛИ? Но для будущего интересно изучить вариант универсальный.
К сообщению приложен файл: ...xlsx(10.7 Kb)


Делить на ноль можно, как процесс, но результат непредсказуем.
 
Ответить
СообщениеПриветствую.
Подскажите какие есть возможности для оформления такой задачи:
При выборе данных в A3 ячейки B3,C3,D3, заполняются автоматически: вытаскивает значения из таблицы соответствующие выбранному.
Через Индекс ПоискПоз могу проверить только один вариант. Может через несколько ЕСЛИ? Но для будущего интересно изучить вариант универсальный.

Автор - FoxLord
Дата добавления - 28.02.2020 в 09:16
Nic70y Дата: Пятница, 28.02.2020, 09:23 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7722
Репутация: 1852 ±
Замечаний: 0% ±

Excel 2010
Через Индекс ПоискПоз могу проверить только один вариант
как это?
Код
=ЕСЛИОШИБКА(ВПР($A2;$K:$N;СТОЛБЕЦ(););"")
К сообщению приложен файл: xlsx.xlsx(11.5 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Через Индекс ПоискПоз могу проверить только один вариант
как это?
Код
=ЕСЛИОШИБКА(ВПР($A2;$K:$N;СТОЛБЕЦ(););"")

Автор - Nic70y
Дата добавления - 28.02.2020 в 09:23
FoxLord Дата: Пятница, 28.02.2020, 09:39 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Спасибо большое, все работает. На досуге изучу как работает :D
Примерно так, в соответствующие столбцы
Код
=ИНДЕКС(ГосНомер;ПОИСКПОЗ("Иванов.";А1;0))

Код
=ИНДЕКС(Марка;ПОИСКПОЗ("Иванов.";А1;0))

Код
=ИНДЕКС(Подрядчик;ПОИСКПОЗ("Иванов.";А1;0))


Делить на ноль можно, как процесс, но результат непредсказуем.

Сообщение отредактировал FoxLord - Пятница, 28.02.2020, 11:05
 
Ответить
СообщениеСпасибо большое, все работает. На досуге изучу как работает :D
Примерно так, в соответствующие столбцы
Код
=ИНДЕКС(ГосНомер;ПОИСКПОЗ("Иванов.";А1;0))

Код
=ИНДЕКС(Марка;ПОИСКПОЗ("Иванов.";А1;0))

Код
=ИНДЕКС(Подрядчик;ПОИСКПОЗ("Иванов.";А1;0))

Автор - FoxLord
Дата добавления - 28.02.2020 в 09:39
Nic70y Дата: Пятница, 28.02.2020, 11:11 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 7722
Репутация: 1852 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИОШИБКА(ИНДЕКС(Марка;ПОИСКПОЗ(A2;ФИО;));"")
Код
=ЕСЛИОШИБКА(ИНДЕКС(Подрядчик;ПОИСКПОЗ(A2;ФИО;));"")
Код
=ЕСЛИОШИБКА(ИНДЕКС(ГосНомер;ПОИСКПОЗ(A2;ФИО;));"")


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ИНДЕКС(Марка;ПОИСКПОЗ(A2;ФИО;));"")
Код
=ЕСЛИОШИБКА(ИНДЕКС(Подрядчик;ПОИСКПОЗ(A2;ФИО;));"")
Код
=ЕСЛИОШИБКА(ИНДЕКС(ГосНомер;ПОИСКПОЗ(A2;ФИО;));"")

Автор - Nic70y
Дата добавления - 28.02.2020 в 11:11
ЕТИ Дата: Четверг, 12.03.2020, 17:44 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый вечер!
Помогите пожалуйста решить задачу с указанием пути в ячейке Excel.
Есть папка "Счета" в которой находятся файлы Excel с одинаковыми таблицами и листами. Папка "Счета" с файлами находится на сервере и периодически дополняется новыми файлами.
Есть так же Excel файл "Статистика" на моем компьютере, который содержит данные из определенных ячеек всех файлов папки "Счета". В этом файле указаны имена всех файлов папки "Счета".
Как правильно прописать путь для отражения данных из файлов папки "Счета" в соответствующих ячейках Excel файла "Статистика"?
Когда в строке формул я прописываю прямой адрес документа, все получается. Я же хочу чтобы имя файла бралось из ячейки Excel файла "Статистика".
Надеюсь я смог вам правильно описать свою проблему.
Буду благодарен за помощь!


2902
 
Ответить
СообщениеДобрый вечер!
Помогите пожалуйста решить задачу с указанием пути в ячейке Excel.
Есть папка "Счета" в которой находятся файлы Excel с одинаковыми таблицами и листами. Папка "Счета" с файлами находится на сервере и периодически дополняется новыми файлами.
Есть так же Excel файл "Статистика" на моем компьютере, который содержит данные из определенных ячеек всех файлов папки "Счета". В этом файле указаны имена всех файлов папки "Счета".
Как правильно прописать путь для отражения данных из файлов папки "Счета" в соответствующих ячейках Excel файла "Статистика"?
Когда в строке формул я прописываю прямой адрес документа, все получается. Я же хочу чтобы имя файла бралось из ячейки Excel файла "Статистика".
Надеюсь я смог вам правильно описать свою проблему.
Буду благодарен за помощь!

Автор - ЕТИ
Дата добавления - 12.03.2020 в 17:44
Pelena Дата: Четверг, 12.03.2020, 19:17 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 18551
Репутация: 4200 ±
Замечаний: ±

Excel 2016 & Mac Excel
ЕТИ, прочитайте Правила форума и создайте свою тему, приложите файл с примером


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЕТИ, прочитайте Правила форума и создайте свою тему, приложите файл с примером

Автор - Pelena
Дата добавления - 12.03.2020 в 19:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое заполнение данных (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!