Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск уникальных значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск уникальных значений (Формулы/Formulas)
Поиск уникальных значений
roman66rus Дата: Вторник, 03.03.2020, 21:22 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 113
Репутация: 0 ±
Замечаний: 0% ±

2010
Доброго времени суток.
Помогите с решением. В жёлтых ячейках требуемый результат, красным выделил вспомогательные строки и столбцы не могу придумать как решить задачу без них. Нужно найти уникальные значения исключая значения из диапазона.
К сообщению приложен файл: 3081039.xls(76.0 Kb)
 
Ответить
СообщениеДоброго времени суток.
Помогите с решением. В жёлтых ячейках требуемый результат, красным выделил вспомогательные строки и столбцы не могу придумать как решить задачу без них. Нужно найти уникальные значения исключая значения из диапазона.

Автор - roman66rus
Дата добавления - 03.03.2020 в 21:22
Pelena Дата: Вторник, 03.03.2020, 23:03 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15466
Репутация: 3383 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Если правильно поняла, формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($E$6:$AC$6;НАИМЕНЬШИЙ(ЕСЛИ((ПОИСКПОЗ($E$6:$AC$6;$E$6:$AC$6;0)=СТОЛБЕЦ($E$6:$AC$6)-4)*ЕНД(ПОИСКПОЗ($E$6:$AC$6;$AG$6:$AG$9;0))*ЕТЕКСТ($E$6:$AC$6);СТОЛБЕЦ($E$6:$AC$6)-4);СТРОКА(1:1)));"")
К сообщению приложен файл: 9377273.xls(68.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Если правильно поняла, формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($E$6:$AC$6;НАИМЕНЬШИЙ(ЕСЛИ((ПОИСКПОЗ($E$6:$AC$6;$E$6:$AC$6;0)=СТОЛБЕЦ($E$6:$AC$6)-4)*ЕНД(ПОИСКПОЗ($E$6:$AC$6;$AG$6:$AG$9;0))*ЕТЕКСТ($E$6:$AC$6);СТОЛБЕЦ($E$6:$AC$6)-4);СТРОКА(1:1)));"")

Автор - Pelena
Дата добавления - 03.03.2020 в 23:03
roman66rus Дата: Среда, 04.03.2020, 00:08 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 113
Репутация: 0 ±
Замечаний: 0% ±

2010
Pelena, да все верно спасибо большое!
 
Ответить
СообщениеPelena, да все верно спасибо большое!

Автор - roman66rus
Дата добавления - 04.03.2020 в 00:08
roman66rus Дата: Среда, 04.03.2020, 02:11 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 113
Репутация: 0 ±
Замечаний: 0% ±

2010
Pelena, я конечно понимаю, что объединенные ячейки это зло, но все же никак не получится, чтоб формула их не воспринимала. Да я про это не писал ранее и это уже другая задача.
К сообщению приложен файл: _9377273.xls(71.0 Kb)
 
Ответить
СообщениеPelena, я конечно понимаю, что объединенные ячейки это зло, но все же никак не получится, чтоб формула их не воспринимала. Да я про это не писал ранее и это уже другая задача.

Автор - roman66rus
Дата добавления - 04.03.2020 в 02:11
Pelena Дата: Среда, 04.03.2020, 10:15 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 15466
Репутация: 3383 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Так?
К сообщению приложен файл: 7499220.xls(71.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеТак?

Автор - Pelena
Дата добавления - 04.03.2020 в 10:15
roman66rus Дата: Суббота, 07.03.2020, 21:01 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 113
Репутация: 0 ±
Замечаний: 0% ±

2010
Pelena, прошу прощения за столь поздний ответ, все работает как надо в файле примера, но когда помещаю формулу в исходник считает только с двух значений, поставил -3 и стало норм))) Спасибо!
 
Ответить
СообщениеPelena, прошу прощения за столь поздний ответ, все работает как надо в файле примера, но когда помещаю формулу в исходник считает только с двух значений, поставил -3 и стало норм))) Спасибо!

Автор - roman66rus
Дата добавления - 07.03.2020 в 21:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск уникальных значений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!