Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Улучшение формулы ИНДЕКС - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Улучшение формулы ИНДЕКС (Формулы/Formulas)
Улучшение формулы ИНДЕКС
mkotik Дата: Воскресенье, 08.03.2020, 21:00 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 160
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый вечер, уважаемые Форумчане!
Всех женщин - с праздником 8 Марта!

Есть ли возможность улучшить формулу:
Код
=ИНДЕКС($B$2:$E$14;ПОИСКПОЗ($H$3;$B$2:$B$14;0);ПОИСКПОЗ($G$2;$B$2:$E$2;0))+
ИНДЕКС($B$2:$E$14;ПОИСКПОЗ($H$4;$B$2:$B$14;0);ПОИСКПОЗ($G$2;$B$2:$E$2;0))+
ИНДЕКС($B$2:$E$14;ПОИСКПОЗ($H$5;$B$2:$B$14;0);ПОИСКПОЗ($G$2;$B$2:$E$2;0))

Файл прилагаю
PS Сложность заключается в том, что присутствие #НД невозможно ислючить

С Уважением, Игорь
К сообщению приложен файл: __-002.xlsx(10.1 Kb)
 
Ответить
СообщениеДобрый вечер, уважаемые Форумчане!
Всех женщин - с праздником 8 Марта!

Есть ли возможность улучшить формулу:
Код
=ИНДЕКС($B$2:$E$14;ПОИСКПОЗ($H$3;$B$2:$B$14;0);ПОИСКПОЗ($G$2;$B$2:$E$2;0))+
ИНДЕКС($B$2:$E$14;ПОИСКПОЗ($H$4;$B$2:$B$14;0);ПОИСКПОЗ($G$2;$B$2:$E$2;0))+
ИНДЕКС($B$2:$E$14;ПОИСКПОЗ($H$5;$B$2:$B$14;0);ПОИСКПОЗ($G$2;$B$2:$E$2;0))

Файл прилагаю
PS Сложность заключается в том, что присутствие #НД невозможно ислючить

С Уважением, Игорь

Автор - mkotik
Дата добавления - 08.03.2020 в 21:00
bmv98rus Дата: Воскресенье, 08.03.2020, 21:19 | Сообщение № 2
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2986
Репутация: 524 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=SUM(SUMIF(B2:B14;H3:H5;INDEX(C2:E14;;MATCH(G2;C2:E2;))))

Код
=SUMPRODUCT(IFERROR(C3:E14;);(C2:E2=G2)*(CEILING.MATH(B3:B14/3;1)=--RIGHT(H2)))

Код
=SUM(INDEX(C3:E14;N(INDEX(MATCH(H3:H5;B3:B14;);));MATCH(G2;C2:E2;)))


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Воскресенье, 08.03.2020, 21:37
 
Ответить
Сообщение
Код
=SUM(SUMIF(B2:B14;H3:H5;INDEX(C2:E14;;MATCH(G2;C2:E2;))))

Код
=SUMPRODUCT(IFERROR(C3:E14;);(C2:E2=G2)*(CEILING.MATH(B3:B14/3;1)=--RIGHT(H2)))

Код
=SUM(INDEX(C3:E14;N(INDEX(MATCH(H3:H5;B3:B14;);));MATCH(G2;C2:E2;)))

Автор - bmv98rus
Дата добавления - 08.03.2020 в 21:19
mkotik Дата: Воскресенье, 08.03.2020, 21:32 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 160
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо огромное за оперативность!
Особенно понравилась:
=СУММПРОИЗВ(ЕСЛИОШИБКА(C3:E14;);(C2:E2=G2)*(ОКРВВЕРХ.МАТ(B3:B14/3;1)=--ПРАВСИМВ(H2)))
 
Ответить
СообщениеСпасибо огромное за оперативность!
Особенно понравилась:
=СУММПРОИЗВ(ЕСЛИОШИБКА(C3:E14;);(C2:E2=G2)*(ОКРВВЕРХ.МАТ(B3:B14/3;1)=--ПРАВСИМВ(H2)))

Автор - mkotik
Дата добавления - 08.03.2020 в 21:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Улучшение формулы ИНДЕКС (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!