Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/УФ выделение повторяющихся значений с учетом рЕгиСТрА - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » УФ выделение повторяющихся значений с учетом рЕгиСТрА (Формулы/Formulas)
УФ выделение повторяющихся значений с учетом рЕгиСТрА
Reload Дата: Пятница, 13.03.2020, 15:25 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем привет!

Потребовалось выделять условным форматированием ячейки повторяющихся значений с учетом рЕгиСТрА.
Перерыв кучу страниц инета, понял что сам не справлюсь)
Помогите пожалуйста, если есть просветленные в excel. Нужно чтобы в условном форматировании выделялись ячейки только повторяющихся значений с учетом регистра, желательно только повторные, то есть первое значение не выделялось.
К сообщению приложен файл: ____.xls(34.0 Kb)


Сообщение отредактировал Reload - Пятница, 13.03.2020, 15:31
 
Ответить
СообщениеВсем привет!

Потребовалось выделять условным форматированием ячейки повторяющихся значений с учетом рЕгиСТрА.
Перерыв кучу страниц инета, понял что сам не справлюсь)
Помогите пожалуйста, если есть просветленные в excel. Нужно чтобы в условном форматировании выделялись ячейки только повторяющихся значений с учетом регистра, желательно только повторные, то есть первое значение не выделялось.

Автор - Reload
Дата добавления - 13.03.2020 в 15:25
Nic70y Дата: Пятница, 13.03.2020, 15:27 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6087
Репутация: 1338 ±
Замечаний: 0% ±

ru13;10;03
файл-пример в Excel приложите,
нужно же на чем-то это сделать.


Яндекс Деньги 41001841029809
 
Ответить
Сообщениефайл-пример в Excel приложите,
нужно же на чем-то это сделать.

Автор - Nic70y
Дата добавления - 13.03.2020 в 15:27
Reload Дата: Пятница, 13.03.2020, 15:32 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
файл-пример в Excel приложите,
нужно же на чем-то это сделать.


Добавил в первое сообщение
 
Ответить
Сообщение
файл-пример в Excel приложите,
нужно же на чем-то это сделать.


Добавил в первое сообщение

Автор - Reload
Дата добавления - 13.03.2020 в 15:32
Nic70y Дата: Пятница, 13.03.2020, 15:38 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 6087
Репутация: 1338 ±
Замечаний: 0% ±

ru13;10;03
Код
=СУММ(--ЕЧИСЛО(НАЙТИ(A2&"\";A$1:A1&"\")))
К сообщению приложен файл: 18.xls(34.0 Kb)


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
Код
=СУММ(--ЕЧИСЛО(НАЙТИ(A2&"\";A$1:A1&"\")))

Автор - Nic70y
Дата добавления - 13.03.2020 в 15:38
Reload Дата: Пятница, 13.03.2020, 16:09 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
=СУММ(--ЕЧИСЛО(НАЙТИ(A2&"\";A$1:A1&"\")))


СУПЕР!
Nic70y СПАСИБО большущее thumb
 
Ответить
Сообщение
=СУММ(--ЕЧИСЛО(НАЙТИ(A2&"\";A$1:A1&"\")))


СУПЕР!
Nic70y СПАСИБО большущее thumb

Автор - Reload
Дата добавления - 13.03.2020 в 16:09
Reload Дата: Пятница, 13.03.2020, 16:53 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Обнаружил странное поведение в результате: если перед значением стоит символ нижнего подчеркивания и перед подчеркиванием еще символ, то считает как повтор.
Пример:
Д_Завтрак
Завтрак
К сообщению приложен файл: 5952807.xls(34.5 Kb)
 
Ответить
СообщениеОбнаружил странное поведение в результате: если перед значением стоит символ нижнего подчеркивания и перед подчеркиванием еще символ, то считает как повтор.
Пример:
Д_Завтрак
Завтрак

Автор - Reload
Дата добавления - 13.03.2020 в 16:53
Nic70y Дата: Пятница, 13.03.2020, 17:02 | Сообщение № 7
Группа: Друзья
Ранг: Экселист
Сообщений: 6087
Репутация: 1338 ±
Замечаний: 0% ±

ru13;10;03
странное поведение
да, не, нормальное,
просто всего сразу не учтешь
Код
=СУММ(--ЕЧИСЛО(НАЙТИ("\"&A2&"\";"\"&A$1:A1&"\")))
или так, для надежности
Код
=СУММ(--(ЕСЛИ(ЕЧИСЛО(НАЙТИ(A2;A$1:A1));ДЛСТР(A$1:A1))=ДЛСТР(A2)))


Яндекс Деньги 41001841029809

Сообщение отредактировал Nic70y - Пятница, 13.03.2020, 17:11
 
Ответить
Сообщение
странное поведение
да, не, нормальное,
просто всего сразу не учтешь
Код
=СУММ(--ЕЧИСЛО(НАЙТИ("\"&A2&"\";"\"&A$1:A1&"\")))
или так, для надежности
Код
=СУММ(--(ЕСЛИ(ЕЧИСЛО(НАЙТИ(A2;A$1:A1));ДЛСТР(A$1:A1))=ДЛСТР(A2)))

Автор - Nic70y
Дата добавления - 13.03.2020 в 17:02
Reload Дата: Пятница, 13.03.2020, 17:13 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
=СУММ(--(ЕСЛИ(ЕЧИСЛО(НАЙТИ(A2;A$1:A1));ДЛСТР(A$1:A1))=ДЛСТР(A2)))

Эта формула бомбически сработала!
Еще раз, спасибо ОГРОМНОЕ!
 
Ответить
Сообщение
=СУММ(--(ЕСЛИ(ЕЧИСЛО(НАЙТИ(A2;A$1:A1));ДЛСТР(A$1:A1))=ДЛСТР(A2)))

Эта формула бомбически сработала!
Еще раз, спасибо ОГРОМНОЕ!

Автор - Reload
Дата добавления - 13.03.2020 в 17:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » УФ выделение повторяющихся значений с учетом рЕгиСТрА (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!