Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Счет одинаковых текстовых значений в столбце excel вверх - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Счет одинаковых текстовых значений в столбце excel вверх (Формулы/Formulas)
Счет одинаковых текстовых значений в столбце excel вверх
mih Дата: Воскресенье, 15.03.2020, 11:47 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день! Подскажите, как выполнить счет одинаковых текстовых значений в столбце excel вверх до ближайшего нулевого значения.
В ячейке A7 введена формула, которая возвращает значение "2" (количество комнат-жилая). При копировании формулы в ячейку A17 формула тоже выдает значение "2", а мне нужно, чтобы выдавала "4". Как сделать так, чтобы не двигать каждый раз при добавлении новой экспликации квартиры границы диапазона вручную, а автоматически при копировании он становился B9:B15 вместо B12:B15?
При суммировании итогов до ближайшего нулевого значения вверх применена формула массива:
Код
=ЕСЛИ (ЛЕВСИМВ (B7;2)="ит";ЕСЛИ (E6="";СУММ (ДВССЫЛ ("e"&НАИБОЛЬШИЙ (ЕСЛИ ($E$1:E6="";СТРОКА ($E$1:E6);"");2)&":e"&НАИБОЛЬШИЙ (ЕСЛИ ($E$1:E6="";СТРОКА ($E$1:E6);"");1)));"0");ЕСЛИ (B7="жилая";0;C7))

А вот как подобным образом считать количество жилых до ближайшего пустого значения? Или можно как-то попроще? Файл приложен. Спасибо всем кто ответит!
К сообщению приложен файл: __.xls(29.5 Kb)


Сообщение отредактировал mih - Воскресенье, 15.03.2020, 22:35
 
Ответить
СообщениеДобрый день! Подскажите, как выполнить счет одинаковых текстовых значений в столбце excel вверх до ближайшего нулевого значения.
В ячейке A7 введена формула, которая возвращает значение "2" (количество комнат-жилая). При копировании формулы в ячейку A17 формула тоже выдает значение "2", а мне нужно, чтобы выдавала "4". Как сделать так, чтобы не двигать каждый раз при добавлении новой экспликации квартиры границы диапазона вручную, а автоматически при копировании он становился B9:B15 вместо B12:B15?
При суммировании итогов до ближайшего нулевого значения вверх применена формула массива:
Код
=ЕСЛИ (ЛЕВСИМВ (B7;2)="ит";ЕСЛИ (E6="";СУММ (ДВССЫЛ ("e"&НАИБОЛЬШИЙ (ЕСЛИ ($E$1:E6="";СТРОКА ($E$1:E6);"");2)&":e"&НАИБОЛЬШИЙ (ЕСЛИ ($E$1:E6="";СТРОКА ($E$1:E6);"");1)));"0");ЕСЛИ (B7="жилая";0;C7))

А вот как подобным образом считать количество жилых до ближайшего пустого значения? Или можно как-то попроще? Файл приложен. Спасибо всем кто ответит!

Автор - mih
Дата добавления - 15.03.2020 в 11:47
Michael_S Дата: Воскресенье, 15.03.2020, 13:17 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1942
Репутация: 361 ±
Замечаний: 0% ±

Excel2016
Код
=ЕСЛИ(СЧЁТЕСЛИ(B2;"итого*");СЧЁТЕСЛИ($B$1:$B2;"жилая")-СУММ($A$1:$A1);"")
К сообщению приложен файл: _mih.xls(40.5 Kb)


ЯД: 41001136675053
WM: R389613894253


Сообщение отредактировал Michael_S - Воскресенье, 15.03.2020, 13:20
 
Ответить
Сообщение
Код
=ЕСЛИ(СЧЁТЕСЛИ(B2;"итого*");СЧЁТЕСЛИ($B$1:$B2;"жилая")-СУММ($A$1:$A1);"")

Автор - Michael_S
Дата добавления - 15.03.2020 в 13:17
Pelena Дата: Воскресенье, 15.03.2020, 16:03 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 15466
Репутация: 3383 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
mih, оформите формулу тегами с помощью кнопки fx в режиме правки поста


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеmih, оформите формулу тегами с помощью кнопки fx в режиме правки поста

Автор - Pelena
Дата добавления - 15.03.2020 в 16:03
mih Дата: Воскресенье, 15.03.2020, 22:32 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо огромное! Все работает!
К сообщению приложен файл: 2513442.xls(89.5 Kb)
 
Ответить
СообщениеСпасибо огромное! Все работает!

Автор - mih
Дата добавления - 15.03.2020 в 22:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Счет одинаковых текстовых значений в столбце excel вверх (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!