Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск одинаково заполненных столбцов в таблице - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск одинаково заполненных столбцов в таблице (Формулы/Formulas)
Поиск одинаково заполненных столбцов в таблице
billi0 Дата: Воскресенье, 15.03.2020, 18:31 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!
Прошу помочь специалистов. Самому не вытянуть...
Имеется таблица данных. В столбцах по 15 значений. Значение могут быть только 0, 1, 2, X (других не будет).
Из большого количества пронумерованных столбцов, необходимо найти и отобразить одинаковые Столбцы с одинаковыми значениями. Количество найденных повторяющихся столбцов отмечаются в строке ниже таблицы, под найденными столбцами. Если совпадений нет, ячейка НЕ ЗАПОЛНЯЕТСЯ (желательно, без цифры 0, если возможно). Во вложении, пример желаемого оформления. (выделять найденные одинаковые Столбцы цветом НЕ НУЖНО, в примере просто для наглядности закрасил).
Сама таблица, постоянно заполняется, то есть ограничение в количестве заполняемых столбцов нет. ( 1,2,3.... до бесконечности). Необходимо, чтобы после заполнения очередного столбца, автоматически производился поиск аналогично заполненных, с изменением кол-ва найденных, в соответствующей строке.
Если с "бесконечностью" проблематично, не беда, можно и ограничить (выделю массив с большим запасом).
Заранее спасибо всем, кто откликнется.
К сообщению приложен файл: 4956941.xlsx(11.9 Kb)
 
Ответить
СообщениеДобрый день!
Прошу помочь специалистов. Самому не вытянуть...
Имеется таблица данных. В столбцах по 15 значений. Значение могут быть только 0, 1, 2, X (других не будет).
Из большого количества пронумерованных столбцов, необходимо найти и отобразить одинаковые Столбцы с одинаковыми значениями. Количество найденных повторяющихся столбцов отмечаются в строке ниже таблицы, под найденными столбцами. Если совпадений нет, ячейка НЕ ЗАПОЛНЯЕТСЯ (желательно, без цифры 0, если возможно). Во вложении, пример желаемого оформления. (выделять найденные одинаковые Столбцы цветом НЕ НУЖНО, в примере просто для наглядности закрасил).
Сама таблица, постоянно заполняется, то есть ограничение в количестве заполняемых столбцов нет. ( 1,2,3.... до бесконечности). Необходимо, чтобы после заполнения очередного столбца, автоматически производился поиск аналогично заполненных, с изменением кол-ва найденных, в соответствующей строке.
Если с "бесконечностью" проблематично, не беда, можно и ограничить (выделю массив с большим запасом).
Заранее спасибо всем, кто откликнется.

Автор - billi0
Дата добавления - 15.03.2020 в 18:31
Pelena Дата: Воскресенье, 15.03.2020, 20:02 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15466
Репутация: 3383 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Формула массива
Код
=ЕСЛИ(СУММ(--(МУМНОЖ(--ТРАНСП((B2:B30=$B$2:$AE$30)*(B2:B30<>""));СТРОКА($B$2:$AE$30)^0)=СЧЁТЗ(B2:B30)))*(СУММ(B2:B30)<>0)>1;СУММ(--(МУМНОЖ(--ТРАНСП((B2:B30=$B$2:$AE$30)*(B2:B30<>""));СТРОКА($B$2:$AE$30)^0)=СЧЁТЗ(B2:B30)))*(СУММ(B2:B30)<>0);"")

если бы не условие
Если совпадений нет, ячейка НЕ ЗАПОЛНЯЕТСЯ (желательно, без цифры 0
, было бы в два раза короче
К сообщению приложен файл: 7713520.xlsx(13.8 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Формула массива
Код
=ЕСЛИ(СУММ(--(МУМНОЖ(--ТРАНСП((B2:B30=$B$2:$AE$30)*(B2:B30<>""));СТРОКА($B$2:$AE$30)^0)=СЧЁТЗ(B2:B30)))*(СУММ(B2:B30)<>0)>1;СУММ(--(МУМНОЖ(--ТРАНСП((B2:B30=$B$2:$AE$30)*(B2:B30<>""));СТРОКА($B$2:$AE$30)^0)=СЧЁТЗ(B2:B30)))*(СУММ(B2:B30)<>0);"")

если бы не условие
Если совпадений нет, ячейка НЕ ЗАПОЛНЯЕТСЯ (желательно, без цифры 0
, было бы в два раза короче

Автор - Pelena
Дата добавления - 15.03.2020 в 20:02
billi0 Дата: Понедельник, 16.03.2020, 03:23 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
СПАСИБО БОЛЬШОЕ !!!!
Избавляете меня от рутины и монотонной работы )))
Длина формулы не пугает.
По поводу "...( 1,2,3.... до бесконечности)", я так понимаю не возможно?
В любом случае, ОГРОМНОЕ СПАСИБО!

P.S. Дабы не нарушать правила форума, В соседней ветке, тему создавал из той же таблицы. Может и там глянете?
http://www.excelworld.ru/forum/2-44282-1#293313
 
Ответить
СообщениеСПАСИБО БОЛЬШОЕ !!!!
Избавляете меня от рутины и монотонной работы )))
Длина формулы не пугает.
По поводу "...( 1,2,3.... до бесконечности)", я так понимаю не возможно?
В любом случае, ОГРОМНОЕ СПАСИБО!

P.S. Дабы не нарушать правила форума, В соседней ветке, тему создавал из той же таблицы. Может и там глянете?
http://www.excelworld.ru/forum/2-44282-1#293313

Автор - billi0
Дата добавления - 16.03.2020 в 03:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск одинаково заполненных столбцов в таблице (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!