Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/последние цифры ячейки равны значению другой вывести да - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » последние цифры ячейки равны значению другой вывести да (Формулы/Formulas)
последние цифры ячейки равны значению другой вывести да
Artemon Дата: Воскресенье, 15.03.2020, 23:30 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 59
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте!
Помогите пожалуйста
Нужна формула
допустим есть число ячейка А1 содержащая любое длинное число, например 21211112122211221
и есть другая ячейка А2 которая содержит число 2211221
нужно в третьей ячейке А3 вывести: если последние 7 правых чисел ячейки А1 = числу ячейки А2, вывести "ДА"
в данном примере будет ответ да
если не равны вывести нет
 
Ответить
СообщениеЗдравствуйте!
Помогите пожалуйста
Нужна формула
допустим есть число ячейка А1 содержащая любое длинное число, например 21211112122211221
и есть другая ячейка А2 которая содержит число 2211221
нужно в третьей ячейке А3 вывести: если последние 7 правых чисел ячейки А1 = числу ячейки А2, вывести "ДА"
в данном примере будет ответ да
если не равны вывести нет

Автор - Artemon
Дата добавления - 15.03.2020 в 23:30
прохожий2019 Дата: Воскресенье, 15.03.2020, 23:39 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 9 ±
Замечаний: 0% ±

365
Код
=ЕСЛИ(ПРАВСИМВ(A1&"";7)=A2&"";"ДА";"НЕТ")


Сообщение отредактировал прохожий2019 - Воскресенье, 15.03.2020, 23:39
 
Ответить
Сообщение
Код
=ЕСЛИ(ПРАВСИМВ(A1&"";7)=A2&"";"ДА";"НЕТ")

Автор - прохожий2019
Дата добавления - 15.03.2020 в 23:39
Che79 Дата: Воскресенье, 15.03.2020, 23:47 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1436
Репутация: 260 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте.
Код
=--(--ПРАВБ(A1;7)=A2)
+ФЯ "да";;"нет"


Делай нормально и будет нормально!
 
Ответить
СообщениеЗдравствуйте.
Код
=--(--ПРАВБ(A1;7)=A2)
+ФЯ "да";;"нет"

Автор - Che79
Дата добавления - 15.03.2020 в 23:47
Artemon Дата: Воскресенье, 15.03.2020, 23:54 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 59
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
прохожий2019, Che79,
спасибо!
 
Ответить
Сообщениепрохожий2019, Che79,
спасибо!

Автор - Artemon
Дата добавления - 15.03.2020 в 23:54
AlexM Дата: Понедельник, 16.03.2020, 09:08 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4039
Репутация: 1008 ±
Замечаний: 0% ±

Excel 2003
Еще вариант
Код
=ПРАВБ(A1;7)-A2
+ФЯ "нет";"нет";"да"



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеЕще вариант
Код
=ПРАВБ(A1;7)-A2
+ФЯ "нет";"нет";"да"

Автор - AlexM
Дата добавления - 16.03.2020 в 09:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » последние цифры ячейки равны значению другой вывести да (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!