Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет табельных номеров по признаку в ячейке через зпт - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет табельных номеров по признаку в ячейке через зпт (Формулы/Formulas)
Подсчет табельных номеров по признаку в ячейке через зпт
Romanuch Дата: Вторник, 17.03.2020, 22:01 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Я не сильно умен в эксель, разбираюсь уже неделю, но успеха не достиг. Нужна формула, которая будет вставлять табельные номера с определенным признаком (линия, отп....) в одну ячейку через запятую, количество до 150 человек/табельных. (вместо фамилий я использовал цуфры) Файлик прикрепляю, если его посмотреть, то думаю все будет понятно, что мне нужно. Заранее спасибо.
К сообщению приложен файл: 7706392.xlsx(12.9 Kb)


Сообщение отредактировал Romanuch - Вторник, 17.03.2020, 22:03
 
Ответить
СообщениеЯ не сильно умен в эксель, разбираюсь уже неделю, но успеха не достиг. Нужна формула, которая будет вставлять табельные номера с определенным признаком (линия, отп....) в одну ячейку через запятую, количество до 150 человек/табельных. (вместо фамилий я использовал цуфры) Файлик прикрепляю, если его посмотреть, то думаю все будет понятно, что мне нужно. Заранее спасибо.

Автор - Romanuch
Дата добавления - 17.03.2020 в 22:01
dude Дата: Вторник, 17.03.2020, 22:33 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 193
Репутация: 28 ±
Замечаний: 0% ±

2016
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$A$41;АГРЕГАТ(15;6;СТРОКА($A$2:$A$41)/($C$2:$C$41=$A49);L$45))&$L$47;"")

и
Код
=СЦЕПИТЬ(L49;M49;N49;O49;P49;Q49;R49;S49;T49;U49;V49;W49;X49;Y49;Z49;AA49;AB49;AC49;AD49;AE49;AF49;AG49;AH49;AI49;AJ49;AK49;AL49;AM49;AN49;AO49;AP49;AQ49;AR49;AS49;AT49;AU49;AV49;AW49;AX49;AY49)
К сообщению приложен файл: 7905352.xlsx(14.0 Kb)
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$A$41;АГРЕГАТ(15;6;СТРОКА($A$2:$A$41)/($C$2:$C$41=$A49);L$45))&$L$47;"")

и
Код
=СЦЕПИТЬ(L49;M49;N49;O49;P49;Q49;R49;S49;T49;U49;V49;W49;X49;Y49;Z49;AA49;AB49;AC49;AD49;AE49;AF49;AG49;AH49;AI49;AJ49;AK49;AL49;AM49;AN49;AO49;AP49;AQ49;AR49;AS49;AT49;AU49;AV49;AW49;AX49;AY49)

Автор - dude
Дата добавления - 17.03.2020 в 22:33
Xenus91 Дата: Среда, 18.03.2020, 04:22 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 10 ±
Замечаний: 0% ±

Excel 2016
Romanuch, можно через UDF
описано здесь
Сцепить если
 
Ответить
СообщениеRomanuch, можно через UDF
описано здесь
Сцепить если

Автор - Xenus91
Дата добавления - 18.03.2020 в 04:22
Romanuch Дата: Среда, 18.03.2020, 08:33 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
dude, Я немного не понял того, что идет справа от таблицы.
У меня первая таблица - табельный, фамилия, признак (признак меняется в всплывающем окне), ниже еще одна таблица, с теми же признаками. Мне нужно, чтобы табельный номер с признаком из первой таб, перемещался во вторую с тем же признаком и записывались через запятую, все линейные, все стажеры, все отпускники и т.д... Я пытался делать через впр, поискпоз и индекс, но у меня никак не получается((((
 
Ответить
Сообщениеdude, Я немного не понял того, что идет справа от таблицы.
У меня первая таблица - табельный, фамилия, признак (признак меняется в всплывающем окне), ниже еще одна таблица, с теми же признаками. Мне нужно, чтобы табельный номер с признаком из первой таб, перемещался во вторую с тем же признаком и записывались через запятую, все линейные, все стажеры, все отпускники и т.д... Я пытался делать через впр, поискпоз и индекс, но у меня никак не получается((((

Автор - Romanuch
Дата добавления - 18.03.2020 в 08:33
Nic70y Дата: Среда, 18.03.2020, 08:59 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 6087
Репутация: 1338 ±
Замечаний: 0% ±

ru13;10;03
вдруг правильно ВПР+допы

апдейт неправильно перенес формулы
исправил, файл перезалил
К сообщению приложен файл: 9004567.xlsx(13.9 Kb)


Яндекс Деньги 41001841029809

Сообщение отредактировал Nic70y - Среда, 18.03.2020, 09:32
 
Ответить
Сообщениевдруг правильно ВПР+допы

апдейт неправильно перенес формулы
исправил, файл перезалил

Автор - Nic70y
Дата добавления - 18.03.2020 в 08:59
Romanuch Дата: Среда, 18.03.2020, 11:40 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Nic70y, низкий поклон, спасибо!!!
 
Ответить
СообщениеNic70y, низкий поклон, спасибо!!!

Автор - Romanuch
Дата добавления - 18.03.2020 в 11:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет табельных номеров по признаку в ячейке через зпт (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!