Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как разбить диапазон в формуле счётесли? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как разбить диапазон в формуле счётесли? (Формулы/Formulas)
Как разбить диапазон в формуле счётесли?
stalber Дата: Вторник, 17.03.2020, 23:35 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 295
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте, есть такая формула:

Код
=СЧЁТЕСЛИ(A1:A5;">0")


А мне нужно разные диапазоны прописать A1:A5 потом C1:C5 и так далее E6:E10
Писать кучу формул не хочется, хотелось бы одной формулой, в которой бы были прописаны все диапазоны.

Подскажи пожалуйста.
 
Ответить
СообщениеЗдравствуйте, есть такая формула:

Код
=СЧЁТЕСЛИ(A1:A5;">0")


А мне нужно разные диапазоны прописать A1:A5 потом C1:C5 и так далее E6:E10
Писать кучу формул не хочется, хотелось бы одной формулой, в которой бы были прописаны все диапазоны.

Подскажи пожалуйста.

Автор - stalber
Дата добавления - 17.03.2020 в 23:35
dude Дата: Вторник, 17.03.2020, 23:47 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 193
Репутация: 28 ±
Замечаний: 0% ±

2016
Цитата
A1:A5 потом C1:C5 и так далее E6:E10

и так далее не понял
 
Ответить
Сообщение
Цитата
A1:A5 потом C1:C5 и так далее E6:E10

и так далее не понял

Автор - dude
Дата добавления - 17.03.2020 в 23:47
stalber Дата: Вторник, 17.03.2020, 23:53 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 295
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Код
=СЧЁТЕСЛИ(A1:A5;C1:C5;E6:E10;">0")

Вот так формула не работает, как её исправить?


Сообщение отредактировал stalber - Вторник, 17.03.2020, 23:54
 
Ответить
Сообщение
Код
=СЧЁТЕСЛИ(A1:A5;C1:C5;E6:E10;">0")

Вот так формула не работает, как её исправить?

Автор - stalber
Дата добавления - 17.03.2020 в 23:53
Xenus91 Дата: Среда, 18.03.2020, 04:16 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 10 ±
Замечаний: 0% ±

Excel 2016
stalber, доброй ночи
может с файлом примером будет проще?
 
Ответить
Сообщениеstalber, доброй ночи
может с файлом примером будет проще?

Автор - Xenus91
Дата добавления - 18.03.2020 в 04:16
bmv98rus Дата: Среда, 18.03.2020, 07:39 | Сообщение № 5
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2986
Репутация: 524 ±
Замечаний: 0% ±

Excel 2013/2016
массивно летучая, не чествительнаяя к вставке строк и столбцов в диапазоне - одним словом ущербная
Код
=SUM(COUNTIF(INDIRECT(CHOOSE({1;2;3};"A1:A5";"C1:C5";"E6:E10"));">0"))


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениемассивно летучая, не чествительнаяя к вставке строк и столбцов в диапазоне - одним словом ущербная
Код
=SUM(COUNTIF(INDIRECT(CHOOSE({1;2;3};"A1:A5";"C1:C5";"E6:E10"));">0"))

Автор - bmv98rus
Дата добавления - 18.03.2020 в 07:39
AlexM Дата: Среда, 18.03.2020, 09:50 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4037
Репутация: 1008 ±
Замечаний: 0% ±

Excel 2003
Еще вариант
Код
=СУММПРОИЗВ(Ч(ВЫБОР({1;2;3};A1:A5;C1:C5;E6:E10)>0))
и массивные
Код
=СЧЁТ(1/(ВЫБОР({1;2;3};A1:A5;C1:C5;E6:E10)>0))
Код
=СУММ(Ч(ВЫБОР({1;2;3};A1:A5;C1:C5;E6:E10)>0))



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Среда, 18.03.2020, 09:55
 
Ответить
СообщениеЕще вариант
Код
=СУММПРОИЗВ(Ч(ВЫБОР({1;2;3};A1:A5;C1:C5;E6:E10)>0))
и массивные
Код
=СЧЁТ(1/(ВЫБОР({1;2;3};A1:A5;C1:C5;E6:E10)>0))
Код
=СУММ(Ч(ВЫБОР({1;2;3};A1:A5;C1:C5;E6:E10)>0))

Автор - AlexM
Дата добавления - 18.03.2020 в 09:50
bmv98rus Дата: Среда, 18.03.2020, 19:55 | Сообщение № 7
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2986
Репутация: 524 ±
Замечаний: 0% ±

Excel 2013/2016
AlexM, Алексей, где счётесли?!!! :D


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеAlexM, Алексей, где счётесли?!!! :D

Автор - bmv98rus
Дата добавления - 18.03.2020 в 19:55
AlexM Дата: Среда, 18.03.2020, 21:36 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4037
Репутация: 1008 ±
Замечаний: 0% ±

Excel 2003
В заголовке, что против правил .



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеВ заголовке, что против правил .

Автор - AlexM
Дата добавления - 18.03.2020 в 21:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как разбить диапазон в формуле счётесли? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!