Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автозаполнение с изменением шага в формуле по горизонтали - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автозаполнение с изменением шага в формуле по горизонтали (Формулы/Formulas)
Автозаполнение с изменением шага в формуле по горизонтали
kanalie Дата: Четверг, 26.03.2020, 17:14 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте. Задача такая:
К примеру возьмем формулу
Код
=A1+AA1

Нужно чтобы при автозаполнении изменения происходили следующим образом:
Код
=A11+AC1
;
Код
=A21+AE1
и т.д.
т.е. к первой части формулы добавлялся шаг отличный от стандартной единички, к примеру 10, как тут в примере.
А во второй части менялся бы столбец.
Спасибо)


Сообщение отредактировал kanalie - Четверг, 26.03.2020, 18:09
 
Ответить
СообщениеЗдравствуйте. Задача такая:
К примеру возьмем формулу
Код
=A1+AA1

Нужно чтобы при автозаполнении изменения происходили следующим образом:
Код
=A11+AC1
;
Код
=A21+AE1
и т.д.
т.е. к первой части формулы добавлялся шаг отличный от стандартной единички, к примеру 10, как тут в примере.
А во второй части менялся бы столбец.
Спасибо)

Автор - kanalie
Дата добавления - 26.03.2020 в 17:14
Pelena Дата: Четверг, 26.03.2020, 17:55 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16783
Репутация: 3621 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Пример покажете? И оформите формулы тегами с помощью кнопки fx в режиме правки поста


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Пример покажете? И оформите формулы тегами с помощью кнопки fx в режиме правки поста

Автор - Pelena
Дата добавления - 26.03.2020 в 17:55
kanalie Дата: Четверг, 26.03.2020, 18:04 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Pelena, Так нет примера, сделал fx). Я же не знаю даже можно такое реализовать или нет, просто было бы удобно, если бы такая возможность была..
 
Ответить
СообщениеPelena, Так нет примера, сделал fx). Я же не знаю даже можно такое реализовать или нет, просто было бы удобно, если бы такая возможность была..

Автор - kanalie
Дата добавления - 26.03.2020 в 18:04
Pelena Дата: Четверг, 26.03.2020, 19:05 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 16783
Репутация: 3621 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Без файла с данными только общий ответ: в таких случаях применяются функции ИНДЕКС(), СТРОКА(), СТОЛБЕЦ()
Пример использования


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеБез файла с данными только общий ответ: в таких случаях применяются функции ИНДЕКС(), СТРОКА(), СТОЛБЕЦ()
Пример использования

Автор - Pelena
Дата добавления - 26.03.2020 в 19:05
kanalie Дата: Четверг, 26.03.2020, 20:25 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Pelena, Большое спасибо. Первую часть вопроса получилось решить:
Код
=ИНДЕКС($A$1:$A$31;СТОЛБЕЦ(A1)+5*(СТРОКА(A1)-1))
вот по этой формуле с шагом 5 берутся значения из столбца с А1 по А31, а вот со второй задачей не разобрался...
Прикрепил файл... Нужно тоже самое, только чтобы протянув вниз в столбике "Формула 2" с шагом пускай таким же, 5, брались значения из строки с А1 по O25... %)
Если можно еще и с этим помочь, то будет совсем замечательно, но и так огромное спасибо, уже задача сильно упростилась))
К сообщению приложен файл: test_formula.xlsx(10.3 Kb)


Сообщение отредактировал kanalie - Четверг, 26.03.2020, 20:26
 
Ответить
СообщениеPelena, Большое спасибо. Первую часть вопроса получилось решить:
Код
=ИНДЕКС($A$1:$A$31;СТОЛБЕЦ(A1)+5*(СТРОКА(A1)-1))
вот по этой формуле с шагом 5 берутся значения из столбца с А1 по А31, а вот со второй задачей не разобрался...
Прикрепил файл... Нужно тоже самое, только чтобы протянув вниз в столбике "Формула 2" с шагом пускай таким же, 5, брались значения из строки с А1 по O25... %)
Если можно еще и с этим помочь, то будет совсем замечательно, но и так огромное спасибо, уже задача сильно упростилась))

Автор - kanalie
Дата добавления - 26.03.2020 в 20:25
Pelena Дата: Четверг, 26.03.2020, 21:52 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 16783
Репутация: 3621 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Дык, формула та же, диапазон измените на $A$1:$O$1
Код
=ИНДЕКС($A$1:$O$1;1+5*(СТРОКА(A1)-1))

Если надо чтобы менялась и строка и столбец
Код
=ИНДЕКС($A$1:$Z$31;1+5*(СТРОКА(A2)-1);1+5*(СТРОКА(A2)-1))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеДык, формула та же, диапазон измените на $A$1:$O$1
Код
=ИНДЕКС($A$1:$O$1;1+5*(СТРОКА(A1)-1))

Если надо чтобы менялась и строка и столбец
Код
=ИНДЕКС($A$1:$Z$31;1+5*(СТРОКА(A2)-1);1+5*(СТРОКА(A2)-1))

Автор - Pelena
Дата добавления - 26.03.2020 в 21:52
kanalie Дата: Четверг, 26.03.2020, 22:32 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Pelena, это то, что нужно! большое спасибо и здоровья) ^_^
 
Ответить
СообщениеPelena, это то, что нужно! большое спасибо и здоровья) ^_^

Автор - kanalie
Дата добавления - 26.03.2020 в 22:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автозаполнение с изменением шага в формуле по горизонтали (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!