Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет ячеек разных диапазонов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет ячеек разных диапазонов (Формулы/Formulas)
Подсчет ячеек разных диапазонов
Fokus-pokuS Дата: Пятница, 27.03.2020, 08:37 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброе время суток, подскажите пожалуйста формулу, как можно подсчитать количество ячеек входящих в диапазон, а если значения не входят в диапазон то пусто.
Файл приложил, там более понятно будет:)
К сообщению приложен файл: 8246533.xlsx(10.3 Kb)
 
Ответить
СообщениеДоброе время суток, подскажите пожалуйста формулу, как можно подсчитать количество ячеек входящих в диапазон, а если значения не входят в диапазон то пусто.
Файл приложил, там более понятно будет:)

Автор - Fokus-pokuS
Дата добавления - 27.03.2020 в 08:37
jakim Дата: Пятница, 27.03.2020, 09:22 | Сообщение № 2
Группа: Друзья
Ранг: Ветеран
Сообщений: 968
Репутация: 251 ±
Замечаний: 0% ±

Excel 2010
Формула

Код
=IFERROR(MATCH(M5;$B$5:$J$5;0)-MATCH(L5;$B$5:$J$5;0)+1;"")
К сообщению приложен файл: 6612787.xlsx(11.0 Kb)
 
Ответить
Сообщение
Формула

Код
=IFERROR(MATCH(M5;$B$5:$J$5;0)-MATCH(L5;$B$5:$J$5;0)+1;"")

Автор - jakim
Дата добавления - 27.03.2020 в 09:22
Fokus-pokuS Дата: Пятница, 27.03.2020, 10:38 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
jakim, Спасибо что не промолчали, но это немного не то что нужно, в строке В5:J5 цифры хаотичные расставлены, может быть даже не по порядку стоять, а диапазон 1 - 7, 8 - 11 и т.д.,
к примеру в строке стоят цифры 1, 2, 7, 15, 19., а диапазон с 11 до 20, надо что бы посчитало количество цифр входящие в диапазон, 2 числа (это 15 и 19)
 
Ответить
Сообщениеjakim, Спасибо что не промолчали, но это немного не то что нужно, в строке В5:J5 цифры хаотичные расставлены, может быть даже не по порядку стоять, а диапазон 1 - 7, 8 - 11 и т.д.,
к примеру в строке стоят цифры 1, 2, 7, 15, 19., а диапазон с 11 до 20, надо что бы посчитало количество цифр входящие в диапазон, 2 числа (это 15 и 19)

Автор - Fokus-pokuS
Дата добавления - 27.03.2020 в 10:38
Fokus-pokuS Дата: Пятница, 27.03.2020, 10:39 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
я прописал формулу, но не знаю как сделать что бы в ячейке где получается "0" была пустой ячейкой:(
К сообщению приложен файл: 7232644.xlsx(11.2 Kb)
 
Ответить
Сообщениея прописал формулу, но не знаю как сделать что бы в ячейке где получается "0" была пустой ячейкой:(

Автор - Fokus-pokuS
Дата добавления - 27.03.2020 в 10:39
китин Дата: Пятница, 27.03.2020, 11:07 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 6319
Репутация: 970 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Код
=СУММПРОИЗВ(ЕЧИСЛО($B$20:$J$20)*($B$20:$J$20>=--ЛЕВБ($M20;ПОИСК("-";$M20)-1))*($B$20:$J$20<=--ПОДСТАВИТЬ($M20;ЛЕВБ($M20;ПОИСК("-";$M20)-1)&"-";"")))

а 0 можно убрать файл параметры дополнительно снять галку с показывать 0 в ячейке
К сообщению приложен файл: 6746061.xlsx(11.9 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(ЕЧИСЛО($B$20:$J$20)*($B$20:$J$20>=--ЛЕВБ($M20;ПОИСК("-";$M20)-1))*($B$20:$J$20<=--ПОДСТАВИТЬ($M20;ЛЕВБ($M20;ПОИСК("-";$M20)-1)&"-";"")))

а 0 можно убрать файл параметры дополнительно снять галку с показывать 0 в ячейке

Автор - китин
Дата добавления - 27.03.2020 в 11:07
Fokus-pokuS Дата: Пятница, 27.03.2020, 11:29 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
китин, спасибо, все оказалось так просто )
 
Ответить
Сообщениекитин, спасибо, все оказалось так просто )

Автор - Fokus-pokuS
Дата добавления - 27.03.2020 в 11:29
jakim Дата: Пятница, 27.03.2020, 11:41 | Сообщение № 7
Группа: Друзья
Ранг: Ветеран
Сообщений: 968
Репутация: 251 ±
Замечаний: 0% ±

Excel 2010
Предлагаю формулу

Код
=IF(SUMPRODUCT(($B$12:$J$12>=L12)*($B$12:$J$12<=M12))>0;SUMPRODUCT(($B$12:$J$12>=L12)*($B$12:$J$12<=M12));"")

Также можно "0" спрятать условным форматированием, как в столбце "Т".
К сообщению приложен файл: 7232644-1.xlsx(12.0 Kb)
 
Ответить
Сообщение
Предлагаю формулу

Код
=IF(SUMPRODUCT(($B$12:$J$12>=L12)*($B$12:$J$12<=M12))>0;SUMPRODUCT(($B$12:$J$12>=L12)*($B$12:$J$12<=M12));"")

Также можно "0" спрятать условным форматированием, как в столбце "Т".

Автор - jakim
Дата добавления - 27.03.2020 в 11:41
Fokus-pokuS Дата: Пятница, 27.03.2020, 12:53 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
jakim, Спасибо:)
 
Ответить
Сообщениеjakim, Спасибо:)

Автор - Fokus-pokuS
Дата добавления - 27.03.2020 в 12:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет ячеек разных диапазонов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!