Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Преобразование ссылки в текст формулой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Преобразование ссылки в текст формулой (Формулы/Formulas)
Преобразование ссылки в текст формулой
shakirovtomsk Дата: Воскресенье, 29.03.2020, 13:38 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Работаю над файлом для расчета и постоянно что-то улучшаю, есть ячейка в которой функция ВПР изначально искала вручную написанный текст
Код
=ЕСЛИ(B2="Отвод";ВПР(C2;$A$107:$D$157;4;0);ЕСЛИ(B2="Гиб";ВПР(C2;$A$107:$D$157;4;0);"-"))

и она работала идеально, но теперь ячейка B2 и С2 заполняется не в ручную, а туда идет ссылка с другого листа (теперь ячейка В2 Выглядит
Код
=УЗТ!X3
, а ячейка С2
Код
=ЕСЛИ(УЗТ!AI3>0;УЗТ!AI3;"")

, но с тем же текстом и теперь эта формула не видит что в ячейке написано тоже самое, видимо видит ссылку и поэтому пишет ошибка, может есть такие формулы которые преобразуют ссылку в текст, знаю как сделать это в ручную, но не формулой. Сам файл выглядит так если кому необходимо (Рис 1). и таблица по которой он ищет (рис 2)
https://u.to/frvwFw (Рис 1)
https://u.to/f7vwFw (Рис 2)
К сообщению приложен файл: _c_.rar(235.6 Kb)


Сообщение отредактировал shakirovtomsk - Воскресенье, 29.03.2020, 17:21
 
Ответить
СообщениеРаботаю над файлом для расчета и постоянно что-то улучшаю, есть ячейка в которой функция ВПР изначально искала вручную написанный текст
Код
=ЕСЛИ(B2="Отвод";ВПР(C2;$A$107:$D$157;4;0);ЕСЛИ(B2="Гиб";ВПР(C2;$A$107:$D$157;4;0);"-"))

и она работала идеально, но теперь ячейка B2 и С2 заполняется не в ручную, а туда идет ссылка с другого листа (теперь ячейка В2 Выглядит
Код
=УЗТ!X3
, а ячейка С2
Код
=ЕСЛИ(УЗТ!AI3>0;УЗТ!AI3;"")

, но с тем же текстом и теперь эта формула не видит что в ячейке написано тоже самое, видимо видит ссылку и поэтому пишет ошибка, может есть такие формулы которые преобразуют ссылку в текст, знаю как сделать это в ручную, но не формулой. Сам файл выглядит так если кому необходимо (Рис 1). и таблица по которой он ищет (рис 2)
https://u.to/frvwFw (Рис 1)
https://u.to/f7vwFw (Рис 2)

Автор - shakirovtomsk
Дата добавления - 29.03.2020 в 13:38
bmv98rus Дата: Воскресенье, 29.03.2020, 13:42 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3244
Репутация: 558 ±
Замечаний: 0% ±

Excel 2013/2016
лучше на кросс ссылку давать


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениелучше на кросс ссылку давать

Автор - bmv98rus
Дата добавления - 29.03.2020 в 13:42
Pelena Дата: Воскресенье, 29.03.2020, 14:55 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 16765
Репутация: 3619 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
shakirovtomsk, оформите формулы тегами с помощью кнопки fx в режиме Правки поста


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеshakirovtomsk, оформите формулы тегами с помощью кнопки fx в режиме Правки поста

Автор - Pelena
Дата добавления - 29.03.2020 в 14:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Преобразование ссылки в текст формулой (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!