Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Назначение (слияние) формул расчета по условному признаку - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Назначение (слияние) формул расчета по условному признаку (Формулы/Formulas)
Назначение (слияние) формул расчета по условному признаку
Viyaliy Дата: Среда, 01.04.2020, 08:54 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте уважаемые форумчане! Помогите пожалуйста объединить две разных формулы в таблице "Наличие ЛСР (Планово и срочно по признаку)" указанному в колонке № 20. При условии "Срочно" - необходимо чтобы срабатывал один алгоритм подсчета, при "Планово" другой. (Исходные формулы подсчета обоих вариантов находятся в ячейках соответствующих таблиц файла)
К сообщению приложен файл: __-_3-v_31.03.2.xlsm(20.6 Kb)


ВВ
 
Ответить
СообщениеЗдравствуйте уважаемые форумчане! Помогите пожалуйста объединить две разных формулы в таблице "Наличие ЛСР (Планово и срочно по признаку)" указанному в колонке № 20. При условии "Срочно" - необходимо чтобы срабатывал один алгоритм подсчета, при "Планово" другой. (Исходные формулы подсчета обоих вариантов находятся в ячейках соответствующих таблиц файла)

Автор - Viyaliy
Дата добавления - 01.04.2020 в 08:54
DjiM Дата: Среда, 01.04.2020, 10:26 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 1 ±
Замечаний: 0% ±

Excel 2016
Так надо?
В файле 2 варианта, с диспетчером имен и чисто формулой, есть разница в длине все же… :)
Код
=ЕСЛИ(R10="Планово";ЕСЛИ(ПЛ<=7;600;ЕСЛИ(ПЛ<=14;500;ЕСЛИ(ПЛ<=21;400;ЕСЛИ(ПЛ<=28;300;ЕСЛИ(ПЛ<=35;200;ЕСЛИ(ПЛ<=42;0;ЕСЛИ(ПЛ<=49;-200;ЕСЛИ(ПЛ<=56;-400;ЕСЛИ(ПЛ<=63;-600;-1000)))))))));ЕСЛИ(R10="Срочно";ЕСЛИ(СР<=7;1000;ЕСЛИ(СР<=14;500;ЕСЛИ(СР<=21;0;-500)));""))

Код
=ЕСЛИ(R10="Планово";ЕСЛИ(РАЗНДАТ((C10-98);F10;"D")<=7;600;ЕСЛИ(РАЗНДАТ((C10-98);F10;"D")<=14;500;ЕСЛИ(РАЗНДАТ((C10-98);F10;"D")<=21;400;ЕСЛИ(РАЗНДАТ((C10-98);F10;"D")<=28;300;ЕСЛИ(РАЗНДАТ((C10-98);F10;"D")<=35;200;ЕСЛИ(РАЗНДАТ((C10-98);F10;"D")<=42;0;ЕСЛИ(РАЗНДАТ((C10-98);F10;"D")<=49;-200;ЕСЛИ(РАЗНДАТ((C10-98);F10;"D")<=56;-400;ЕСЛИ(РАЗНДАТ((C10-98);F10;"D")<=63;-600;-1000)))))))));ЕСЛИ(R10="Срочно";ЕСЛИ(РАЗНДАТ(Q10;F10;"D")<=7;1000;ЕСЛИ(РАЗНДАТ(Q10;F10;"D")<=14;500;ЕСЛИ(РАЗНДАТ(Q10;F10;"D")<=21;0;-500)));""))
К сообщению приложен файл: -3-v_31.03.2.xlsm(18.8 Kb)


Сообщение отредактировал DjiM - Среда, 01.04.2020, 10:56
 
Ответить
СообщениеТак надо?
В файле 2 варианта, с диспетчером имен и чисто формулой, есть разница в длине все же… :)
Код
=ЕСЛИ(R10="Планово";ЕСЛИ(ПЛ<=7;600;ЕСЛИ(ПЛ<=14;500;ЕСЛИ(ПЛ<=21;400;ЕСЛИ(ПЛ<=28;300;ЕСЛИ(ПЛ<=35;200;ЕСЛИ(ПЛ<=42;0;ЕСЛИ(ПЛ<=49;-200;ЕСЛИ(ПЛ<=56;-400;ЕСЛИ(ПЛ<=63;-600;-1000)))))))));ЕСЛИ(R10="Срочно";ЕСЛИ(СР<=7;1000;ЕСЛИ(СР<=14;500;ЕСЛИ(СР<=21;0;-500)));""))

Код
=ЕСЛИ(R10="Планово";ЕСЛИ(РАЗНДАТ((C10-98);F10;"D")<=7;600;ЕСЛИ(РАЗНДАТ((C10-98);F10;"D")<=14;500;ЕСЛИ(РАЗНДАТ((C10-98);F10;"D")<=21;400;ЕСЛИ(РАЗНДАТ((C10-98);F10;"D")<=28;300;ЕСЛИ(РАЗНДАТ((C10-98);F10;"D")<=35;200;ЕСЛИ(РАЗНДАТ((C10-98);F10;"D")<=42;0;ЕСЛИ(РАЗНДАТ((C10-98);F10;"D")<=49;-200;ЕСЛИ(РАЗНДАТ((C10-98);F10;"D")<=56;-400;ЕСЛИ(РАЗНДАТ((C10-98);F10;"D")<=63;-600;-1000)))))))));ЕСЛИ(R10="Срочно";ЕСЛИ(РАЗНДАТ(Q10;F10;"D")<=7;1000;ЕСЛИ(РАЗНДАТ(Q10;F10;"D")<=14;500;ЕСЛИ(РАЗНДАТ(Q10;F10;"D")<=21;0;-500)));""))

Автор - DjiM
Дата добавления - 01.04.2020 в 10:26
Pelena Дата: Среда, 01.04.2020, 10:30 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 16780
Репутация: 3621 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Признак брать из той же строки или надо как-то даты учитывать?
Если из той же строки, то для дней
Код
=F10-ЕСЛИ(R10="Планово";C10-98;Q10)
для баллов
Код
=ЕСЛИ(R10="Планово";ПРОСМОТР(G10;{0;8;15;22;29;36;43;50;57;64};{600;500;400;300;200;0;-200;-400;-600;-1000});ПРОСМОТР(G10;{0;8;15;22};{1000;500;0;-500}))
К сообщению приложен файл: 8122769.xlsm(17.3 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Признак брать из той же строки или надо как-то даты учитывать?
Если из той же строки, то для дней
Код
=F10-ЕСЛИ(R10="Планово";C10-98;Q10)
для баллов
Код
=ЕСЛИ(R10="Планово";ПРОСМОТР(G10;{0;8;15;22;29;36;43;50;57;64};{600;500;400;300;200;0;-200;-400;-600;-1000});ПРОСМОТР(G10;{0;8;15;22};{1000;500;0;-500}))

Автор - Pelena
Дата добавления - 01.04.2020 в 10:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Назначение (слияние) формул расчета по условному признаку (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!