Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Появление количества строк по количеству дней в месяце - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Появление количества строк по количеству дней в месяце (Формулы/Formulas)
Появление количества строк по количеству дней в месяце
nikaluka1 Дата: Четверг, 09.04.2020, 16:00 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007, 2010
График смены
Есть таблица, которая пишет календарь по месяцам.
Я указываю месяц и год.
Таблица состоит из 31 строки
Проблема в том, что, когда менее 31 дня в месяц, он записывает первое число следующего месяца в последнюю строку.

Как сделать, чтобы номер следующего месяца больше не появлялся.
спасибо
К сообщению приложен файл: 44.xlsx(12.0 Kb)


Сообщение отредактировал nikaluka1 - Четверг, 09.04.2020, 16:22
 
Ответить
СообщениеГрафик смены
Есть таблица, которая пишет календарь по месяцам.
Я указываю месяц и год.
Таблица состоит из 31 строки
Проблема в том, что, когда менее 31 дня в месяц, он записывает первое число следующего месяца в последнюю строку.

Как сделать, чтобы номер следующего месяца больше не появлялся.
спасибо

Автор - nikaluka1
Дата добавления - 09.04.2020 в 16:00
jakim Дата: Четверг, 09.04.2020, 16:26 | Сообщение № 2
Группа: Друзья
Ранг: Ветеран
Сообщений: 963
Репутация: 251 ±
Замечаний: 0% ±

Excel 2010
Смотрите Ваш пример с формулами от 28 дня месяца

Код
=IFERROR(DATE($L$1;$K$1;IF(DAY(DATE($L$1;$K$1;28))=28;28;""));"")

или формула от первого числа месяца

Код
=IF(MONTH(DATE($L$1;$K$1;ROWS($1:1)))=$K$1;DATE($L$1;$K$1;ROWS($1:1));"")
К сообщению приложен файл: 5939568.xlsx(12.5 Kb)


Сообщение отредактировал jakim - Четверг, 09.04.2020, 16:45
 
Ответить
Сообщение
Смотрите Ваш пример с формулами от 28 дня месяца

Код
=IFERROR(DATE($L$1;$K$1;IF(DAY(DATE($L$1;$K$1;28))=28;28;""));"")

или формула от первого числа месяца

Код
=IF(MONTH(DATE($L$1;$K$1;ROWS($1:1)))=$K$1;DATE($L$1;$K$1;ROWS($1:1));"")

Автор - jakim
Дата добавления - 09.04.2020 в 16:26
_Boroda_ Дата: Четверг, 09.04.2020, 16:30 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИ(МЕСЯЦ(B$1+СТРОКА()-1)=МЕСЯЦ(B$1);B1+1;"")

Код
=ЕСЛИ(МЕСЯЦ(B$1+СТРОКА()-1)=K$1;B1+1;"")

Еще там УФ поправил у Вас и в столбце С формулу
К сообщению приложен файл: 44_1.xlsx(12.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИ(МЕСЯЦ(B$1+СТРОКА()-1)=МЕСЯЦ(B$1);B1+1;"")

Код
=ЕСЛИ(МЕСЯЦ(B$1+СТРОКА()-1)=K$1;B1+1;"")

Еще там УФ поправил у Вас и в столбце С формулу

Автор - _Boroda_
Дата добавления - 09.04.2020 в 16:30
nikaluka1 Дата: Четверг, 09.04.2020, 16:39 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007, 2010
Спасибо большое
Все отлично работает!!!
 
Ответить
СообщениеСпасибо большое
Все отлично работает!!!

Автор - nikaluka1
Дата добавления - 09.04.2020 в 16:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Появление количества строк по количеству дней в месяце (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!