Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/вывести значение при определенном значении в столбце - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » вывести значение при определенном значении в столбце (Формулы/Formulas)
вывести значение при определенном значении в столбце
Artemon Дата: Четверг, 09.04.2020, 23:59 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 65
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте!
Помогите пожауйста с реализацией формулы
Если большой столбец с числами 1 и 2 вразнобой допустим 5000 строк, он обновляемый тоесть при обновлении таблица убирает верхнюю строку и добавляет нижнюю
нужно, чтобы выводилось сколько раз подряд после 21 было число 2
Важно: они не обязательно должны идти прямо по порядку
тоесть не обязательно должно быть чередование 11121212121, может быть и так 121121211121222221221 (другим языком если 21 разделяются двойками то они считаются подряд идущими)
во вложении в эксель файле привел пример как должно быть
надеюсь понятно что я имею ввиду
К сообщению приложен файл: 8398284.xlsx(9.0 Kb)


Сообщение отредактировал Artemon - Пятница, 10.04.2020, 01:15
 
Ответить
СообщениеЗдравствуйте!
Помогите пожауйста с реализацией формулы
Если большой столбец с числами 1 и 2 вразнобой допустим 5000 строк, он обновляемый тоесть при обновлении таблица убирает верхнюю строку и добавляет нижнюю
нужно, чтобы выводилось сколько раз подряд после 21 было число 2
Важно: они не обязательно должны идти прямо по порядку
тоесть не обязательно должно быть чередование 11121212121, может быть и так 121121211121222221221 (другим языком если 21 разделяются двойками то они считаются подряд идущими)
во вложении в эксель файле привел пример как должно быть
надеюсь понятно что я имею ввиду

Автор - Artemon
Дата добавления - 09.04.2020 в 23:59
AlexM Дата: Пятница, 10.04.2020, 09:35 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4257
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Формула массива
Код
=ЕСЛИ(И(A1:A2={2:1});ЕСЛИ(A3=2;ПРОСМОТР(9^9;--B$1:B1)+1;0);"")
Формат ячеек 0;;
К сообщению приложен файл: 8398284_01.xlsx(10.8 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеФормула массива
Код
=ЕСЛИ(И(A1:A2={2:1});ЕСЛИ(A3=2;ПРОСМОТР(9^9;--B$1:B1)+1;0);"")
Формат ячеек 0;;

Автор - AlexM
Дата добавления - 10.04.2020 в 09:35
Artemon Дата: Пятница, 10.04.2020, 20:30 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 65
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
AlexM,
вроде все верно, спасибо большое
но применить к основному файлу не могу, как ни пробовал пишет нельзя изменить формулу массива (про шифт, контрл энтер знаю)
Не совсем понимаю что значат данные с ячейкас С3:С16 и D3:D19
Если вас не затруднит, можете пожалуйста применить данную формулу к ячейкам AN до самого конца в файле? залил на яндекс диск, файл весит 1.5 мб
https://yadi.sk/i/nekDp7auSkeSvA
 
Ответить
СообщениеAlexM,
вроде все верно, спасибо большое
но применить к основному файлу не могу, как ни пробовал пишет нельзя изменить формулу массива (про шифт, контрл энтер знаю)
Не совсем понимаю что значат данные с ячейкас С3:С16 и D3:D19
Если вас не затруднит, можете пожалуйста применить данную формулу к ячейкам AN до самого конца в файле? залил на яндекс диск, файл весит 1.5 мб
https://yadi.sk/i/nekDp7auSkeSvA

Автор - Artemon
Дата добавления - 10.04.2020 в 20:30
AlexM Дата: Пятница, 10.04.2020, 21:00 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4257
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Не открывается у меня этот файл. "Сбой конвертера при открытии файла"
В файле первая формула в ячейке В3. Она вводится как формула массива, а потом протягивается.
Не совсем понимаю что значат данные с ячейкас С3:С16 и D3:D19
не понял о чем эта фраза.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеНе открывается у меня этот файл. "Сбой конвертера при открытии файла"
В файле первая формула в ячейке В3. Она вводится как формула массива, а потом протягивается.
Не совсем понимаю что значат данные с ячейкас С3:С16 и D3:D19
не понял о чем эта фраза.

Автор - AlexM
Дата добавления - 10.04.2020 в 21:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » вывести значение при определенном значении в столбце (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!