Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск в массиве по одному условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск в массиве по одному условию (Формулы/Formulas)
Поиск в массиве по одному условию
mafate Дата: Пятница, 10.04.2020, 12:43 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день!
Ищу способ научить Excel работать с акциями для проверки простых торговых стратегий.

Известны цены акций, а также даты «отсечки» по выплате дивидендов ("отсечка" - это последний день, когда можно купить акции, чтобы претендовать на получение дивидендов). После даты «отсечки» цена акций обычно падает. Необходимо найти ПЕРВУЮ после «отсечки» цену акции, которая больше или равна цене акции на дату «отсечки», а также дату, при которой это произошло. Вроде бы здесь нужна формула массива по условию, но никак не могу понять, что конкретно писать в моем случае. Спасибо за помощь!
К сообщению приложен файл: 3415639.xls(30.0 Kb)
 
Ответить
СообщениеДобрый день!
Ищу способ научить Excel работать с акциями для проверки простых торговых стратегий.

Известны цены акций, а также даты «отсечки» по выплате дивидендов ("отсечка" - это последний день, когда можно купить акции, чтобы претендовать на получение дивидендов). После даты «отсечки» цена акций обычно падает. Необходимо найти ПЕРВУЮ после «отсечки» цену акции, которая больше или равна цене акции на дату «отсечки», а также дату, при которой это произошло. Вроде бы здесь нужна формула массива по условию, но никак не могу понять, что конкретно писать в моем случае. Спасибо за помощь!

Автор - mafate
Дата добавления - 10.04.2020 в 12:43
AlexM Дата: Пятница, 10.04.2020, 15:05 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Для L5 формула
Код
=ВПР(L6;$A:$B;2)
Затем копировать ее в L7



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеДля L5 формула
Код
=ВПР(L6;$A:$B;2)
Затем копировать ее в L7

Автор - AlexM
Дата добавления - 10.04.2020 в 15:05
mafate Дата: Пятница, 10.04.2020, 16:14 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо за ответ! Но тут дело хитрее. Я не знаю заранее даты, при которых цена становится больше цены на дату "отсечки". То есть я не знаю L6 и L8. Я хочу, чтобы Excel их сам искал.

Логика такая: Excel должен искать в таблице $A:$B цену (больше ли цена, чем заранее заданная G5 или H5) и дату (новее ли дата, чем заранее заданная G4 или H4). Как только оба условия будут выполнены, Excel должен остановить поиск, выдав первый случай выполнения условий.

Excel вообще так умеет?
 
Ответить
СообщениеСпасибо за ответ! Но тут дело хитрее. Я не знаю заранее даты, при которых цена становится больше цены на дату "отсечки". То есть я не знаю L6 и L8. Я хочу, чтобы Excel их сам искал.

Логика такая: Excel должен искать в таблице $A:$B цену (больше ли цена, чем заранее заданная G5 или H5) и дату (новее ли дата, чем заранее заданная G4 или H4). Как только оба условия будут выполнены, Excel должен остановить поиск, выдав первый случай выполнения условий.

Excel вообще так умеет?

Автор - mafate
Дата добавления - 10.04.2020 в 16:14
AlexM Дата: Пятница, 10.04.2020, 16:51 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Для цены
Код
=ИНДЕКС($B$2:$B$99;ПОИСКПОЗ(1;($A$2:$A$99>=G4)*($B$2:$B$99>G5);))
и даты
Код
=ИНДЕКС($A$2:$A$99;ПОИСКПОЗ(1;($A$2:$A$99>=G4)*($B$2:$B$99>G5);))
Формулы массива
К сообщению приложен файл: 3415639_01.xls(30.0 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеДля цены
Код
=ИНДЕКС($B$2:$B$99;ПОИСКПОЗ(1;($A$2:$A$99>=G4)*($B$2:$B$99>G5);))
и даты
Код
=ИНДЕКС($A$2:$A$99;ПОИСКПОЗ(1;($A$2:$A$99>=G4)*($B$2:$B$99>G5);))
Формулы массива

Автор - AlexM
Дата добавления - 10.04.2020 в 16:51
mafate Дата: Понедельник, 13.04.2020, 16:43 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо! Все работает!
 
Ответить
СообщениеСпасибо! Все работает!

Автор - mafate
Дата добавления - 13.04.2020 в 16:43
_Boroda_ Дата: Понедельник, 13.04.2020, 17:08 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще варианты
Цена
Код
=--ПСТР(МИН(ЕСЛИ((A2:A99>G4)*(B2:B99>G5);--(A2:A99&B2:B99)));6;9)

Дата
Код
=МИН(--ТЕКСТ((A2:A99>G4)*(B2:B99>G5)*A2:A99;"0;;99999"))

Код
=МИН(ЕСЛИ((A2:A99>G4)*(B2:B99>G5);A2:A99))
К сообщению приложен файл: 3415639_1.xls(30.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще варианты
Цена
Код
=--ПСТР(МИН(ЕСЛИ((A2:A99>G4)*(B2:B99>G5);--(A2:A99&B2:B99)));6;9)

Дата
Код
=МИН(--ТЕКСТ((A2:A99>G4)*(B2:B99>G5)*A2:A99;"0;;99999"))

Код
=МИН(ЕСЛИ((A2:A99>G4)*(B2:B99>G5);A2:A99))

Автор - _Boroda_
Дата добавления - 13.04.2020 в 17:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск в массиве по одному условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!