Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет повторяющихся значений в диапазоне и сумма значений. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет повторяющихся значений в диапазоне и сумма значений. (Формулы/Formulas)
Подсчет повторяющихся значений в диапазоне и сумма значений.
Steel56 Дата: Воскресенье, 12.04.2020, 13:07 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день, форумчане. Прошу помочь разобраться с формулой, макрос не подходит. В общем сложность такая, необходимо найти сумму из диапазона "Задолжность" (B:B) учитывая только повторяющиеся значения в диапазоне "Номер заказа" (А:А) и вывести это в столбец F:F - единажды, т.е. если повтора к примеру 3, то значение сумма будет прописана 1 раз. В файле наглядно написал, как хочу чтобы получилось. Заранее спасибо за помощь.
К сообщению приложен файл: 5485081.xlsx(76.4 Kb)
 
Ответить
СообщениеДобрый день, форумчане. Прошу помочь разобраться с формулой, макрос не подходит. В общем сложность такая, необходимо найти сумму из диапазона "Задолжность" (B:B) учитывая только повторяющиеся значения в диапазоне "Номер заказа" (А:А) и вывести это в столбец F:F - единажды, т.е. если повтора к примеру 3, то значение сумма будет прописана 1 раз. В файле наглядно написал, как хочу чтобы получилось. Заранее спасибо за помощь.

Автор - Steel56
Дата добавления - 12.04.2020 в 13:07
Pelena Дата: Воскресенье, 12.04.2020, 13:28 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16795
Репутация: 3623 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Код
=ЕСЛИ(И(C2=1;СЧЁТЕСЛИ($A$2:A2;A2)=СЧЁТЕСЛИ($A$2:$A$304;A2));СУММЕСЛИ($A$2:$A$304;A2;$B$2:$B$304);0)

или сводной можно
К сообщению приложен файл: 7812934.xlsx(91.6 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ЕСЛИ(И(C2=1;СЧЁТЕСЛИ($A$2:A2;A2)=СЧЁТЕСЛИ($A$2:$A$304;A2));СУММЕСЛИ($A$2:$A$304;A2;$B$2:$B$304);0)

или сводной можно

Автор - Pelena
Дата добавления - 12.04.2020 в 13:28
Steel56 Дата: Воскресенье, 12.04.2020, 13:35 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Спасибо большое, очень быстро и оперативно. То что нужно!!!
 
Ответить
СообщениеСпасибо большое, очень быстро и оперативно. То что нужно!!!

Автор - Steel56
Дата добавления - 12.04.2020 в 13:35
AlexM Дата: Воскресенье, 12.04.2020, 14:06 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Еще вариант
Код
=ЕСЛИ((A1=A2)*(A2<>A3);СУММЕСЛИ(A$2:A$999;A2;B$2:B$999);)
или
Код
СУММЕСЛИ(A$2:A$999;(A2<>A3)*A2^(A1=A2);B$2:B$999)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Воскресенье, 12.04.2020, 14:25
 
Ответить
СообщениеЕще вариант
Код
=ЕСЛИ((A1=A2)*(A2<>A3);СУММЕСЛИ(A$2:A$999;A2;B$2:B$999);)
или
Код
СУММЕСЛИ(A$2:A$999;(A2<>A3)*A2^(A1=A2);B$2:B$999)

Автор - AlexM
Дата добавления - 12.04.2020 в 14:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет повторяющихся значений в диапазоне и сумма значений. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!