Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ВПР не учитывающий значение 0 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР не учитывающий значение 0 (Формулы/Formulas)
ВПР не учитывающий значение 0
Steel56 Дата: Воскресенье, 12.04.2020, 16:43 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день, форумчане. Не получается настроить формулу. Задача в следующем: в листе "Основной", пишется "номер заказа", и в столбец "Общая задолженность" должно подтягиваться значение из листа "Заказы" значение из столбца "Сумма заказа", проблема в том что функция ВПР берёт 1-ое значение удовлетворяющие условие, однако в столбце "Сумма заказа" встречается значение "0", которое не нужно учитывать, необходимо, чтобы всегда подтягивалось значение больше 0. Не пойму как это сделать, прошу помочь, спасибо.
К сообщению приложен файл: 6424599.xls(31.5 Kb)


Сообщение отредактировал Steel56 - Воскресенье, 12.04.2020, 16:45
 
Ответить
СообщениеДобрый день, форумчане. Не получается настроить формулу. Задача в следующем: в листе "Основной", пишется "номер заказа", и в столбец "Общая задолженность" должно подтягиваться значение из листа "Заказы" значение из столбца "Сумма заказа", проблема в том что функция ВПР берёт 1-ое значение удовлетворяющие условие, однако в столбце "Сумма заказа" встречается значение "0", которое не нужно учитывать, необходимо, чтобы всегда подтягивалось значение больше 0. Не пойму как это сделать, прошу помочь, спасибо.

Автор - Steel56
Дата добавления - 12.04.2020 в 16:43
_Boroda_ Дата: Воскресенье, 12.04.2020, 16:49 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММЕСЛИ(Заказы!A$2:A$999;B2;Заказы!B$2:B$999)

Код
=СУММЕСЛИ(Заказы!A:A;B2;Заказы!B:B)
К сообщению приложен файл: 6424599_1.xls(33.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММЕСЛИ(Заказы!A$2:A$999;B2;Заказы!B$2:B$999)

Код
=СУММЕСЛИ(Заказы!A:A;B2;Заказы!B:B)

Автор - _Boroda_
Дата добавления - 12.04.2020 в 16:49
Steel56 Дата: Воскресенье, 12.04.2020, 16:59 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Да, именно так. Убеждаюсь всё гениальное-просто, а я с ВПР мучаюсь. Спасибо большое.
 
Ответить
СообщениеДа, именно так. Убеждаюсь всё гениальное-просто, а я с ВПР мучаюсь. Спасибо большое.

Автор - Steel56
Дата добавления - 12.04.2020 в 16:59
Pelena Дата: Воскресенье, 12.04.2020, 17:35 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 16783
Репутация: 3621 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
а я с ВПР мучаюсь
вот именно поэтому в названии темы должна отражаться суть задачи, а не способ решения, который Вы себе придумали. Исправьте


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
а я с ВПР мучаюсь
вот именно поэтому в названии темы должна отражаться суть задачи, а не способ решения, который Вы себе придумали. Исправьте

Автор - Pelena
Дата добавления - 12.04.2020 в 17:35
AlexM Дата: Воскресенье, 12.04.2020, 19:15 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
с ВПР мучаюс
Можно и с ВПР(), но не так красиво и формула массива
Код
=ВПР(B2;ЕСЛИ({1;0};ЕСЛИ(Заказы!B$2:B$99;Заказы!A$2:A$99);Заказы!B$2:B$99);2;)
К сообщению приложен файл: 6424599_01.xls(32.0 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
с ВПР мучаюс
Можно и с ВПР(), но не так красиво и формула массива
Код
=ВПР(B2;ЕСЛИ({1;0};ЕСЛИ(Заказы!B$2:B$99;Заказы!A$2:A$99);Заказы!B$2:B$99);2;)

Автор - AlexM
Дата добавления - 12.04.2020 в 19:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР не учитывающий значение 0 (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!