Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как найти повторяющиеся значение из базы - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как найти повторяющиеся значение из базы (Формулы/Formulas)
Как найти повторяющиеся значение из базы
ark835 Дата: Вторник, 14.04.2020, 16:46 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Есть один ряд в 300-800 чисел - результаты анализа.
Есть второй ряд в 30-50 чисел - результаты анализа.

Надо найти повторы. Идеальный ответ "есть, строка 25/нет"
В принципе решается через Ctrl+F, но когда ее приходится решать по 10 раз в день ... :(
К сообщению приложен файл: 5247481.xlsx(19.2 Kb)


Сообщение отредактировал ark835 - Вторник, 14.04.2020, 18:49
 
Ответить
СообщениеЕсть один ряд в 300-800 чисел - результаты анализа.
Есть второй ряд в 30-50 чисел - результаты анализа.

Надо найти повторы. Идеальный ответ "есть, строка 25/нет"
В принципе решается через Ctrl+F, но когда ее приходится решать по 10 раз в день ... :(

Автор - ark835
Дата добавления - 14.04.2020 в 16:46
_Boroda_ Дата: Вторник, 14.04.2020, 16:53 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16359
Репутация: 6352 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Прочитайте Правила форума. Приложите пример файла с необходимым результатом (вручную)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПрочитайте Правила форума. Приложите пример файла с необходимым результатом (вручную)

Автор - _Boroda_
Дата добавления - 14.04.2020 в 16:53
ark835 Дата: Вторник, 14.04.2020, 18:50 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, файл с желаемым результатом приложил
 
Ответить
Сообщение_Boroda_, файл с желаемым результатом приложил

Автор - ark835
Дата добавления - 14.04.2020 в 18:50
прохожий2019 Дата: Вторник, 14.04.2020, 18:53 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 908
Репутация: 250 ±
Замечаний: 0% ±

365 Beta Channel
Код
=ЕСЛИОШИБКА("есть строка "&ПОИСКПОЗ(L2;$B$1:$B$304;);"нет")
К сообщению приложен файл: 0772518.xlsx(20.6 Kb)
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА("есть строка "&ПОИСКПОЗ(L2;$B$1:$B$304;);"нет")

Автор - прохожий2019
Дата добавления - 14.04.2020 в 18:53
_Boroda_ Дата: Вторник, 14.04.2020, 21:02 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16359
Репутация: 6352 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Возможно, нужно как-то обозначать, если в 300 есть повторы (в примере значение "56454 повтор")
Вариант такой
Код
=ЕСЛИОШИБКА("есть, строка "&ПОИСКПОЗ(O2;$B$1:$B$304;)&ТЕКСТ(СЧЁТЕСЛИ(B:B;O2);"[>1]\, кол-во\: 0;;");"нет")
К сообщению приложен файл: 5247481_1.xlsx(20.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВозможно, нужно как-то обозначать, если в 300 есть повторы (в примере значение "56454 повтор")
Вариант такой
Код
=ЕСЛИОШИБКА("есть, строка "&ПОИСКПОЗ(O2;$B$1:$B$304;)&ТЕКСТ(СЧЁТЕСЛИ(B:B;O2);"[>1]\, кол-во\: 0;;");"нет")

Автор - _Boroda_
Дата добавления - 14.04.2020 в 21:02
ark835 Дата: Суббота, 18.04.2020, 09:21 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо всем. Все работает. Решение Бороды на мой взгляд более изящное,
 
Ответить
СообщениеСпасибо всем. Все работает. Решение Бороды на мой взгляд более изящное,

Автор - ark835
Дата добавления - 18.04.2020 в 09:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как найти повторяющиеся значение из базы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!