Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Промежуточные.итоги и суммесли() - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Промежуточные.итоги и суммесли() (Формулы/Formulas)
Промежуточные.итоги и суммесли()
Tupik Дата: Четверг, 16.04.2020, 00:19 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый вечер.
Помогите, пожалуйста, к сожалению ещё новичок и то "Готовое решение" которое предлагается во многих вопросах не могу понять, как применить к своему случаю и подходит ли вообще.

Проблема такая:
Нужно, чтобы при установке фильтра, в промежуточных итогах суммировались только значения, которые, для примера меньше 50.
А в следующей строке с формулой установленном фильтре в промежуточных итогах подсчитывалось количество значение, которые меньше 50,

Вариант с дополнительным столбцом не подходит, т.к. в оригинале таблица на +356 столбцов и вниз на несколько тысяч строк.

Фрагмент файла во вложении.
Подсветкой выделила ячейки, которые должны пересчитываться в зависимости от выбранного фильтра.

К сообщению приложен файл: __.xlsx(11.1 Kb)


Сообщение отредактировал Tupik - Четверг, 16.04.2020, 00:32
 
Ответить
СообщениеДобрый вечер.
Помогите, пожалуйста, к сожалению ещё новичок и то "Готовое решение" которое предлагается во многих вопросах не могу понять, как применить к своему случаю и подходит ли вообще.

Проблема такая:
Нужно, чтобы при установке фильтра, в промежуточных итогах суммировались только значения, которые, для примера меньше 50.
А в следующей строке с формулой установленном фильтре в промежуточных итогах подсчитывалось количество значение, которые меньше 50,

Вариант с дополнительным столбцом не подходит, т.к. в оригинале таблица на +356 столбцов и вниз на несколько тысяч строк.

Фрагмент файла во вложении.
Подсветкой выделила ячейки, которые должны пересчитываться в зависимости от выбранного фильтра.


Автор - Tupik
Дата добавления - 16.04.2020 в 00:19
_Boroda_ Дата: Четверг, 16.04.2020, 00:36 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;СМЕЩ(C1;СТРОКА(2:20)-1;))*C2:C20*(C2:C20<50))

Код
=СУММПРОИЗВ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;СМЕЩ(C1;СТРОКА(2:20)-1;))*(C2:C20<50))
К сообщению приложен файл: 877879_1.xlsx(11.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;СМЕЩ(C1;СТРОКА(2:20)-1;))*C2:C20*(C2:C20<50))

Код
=СУММПРОИЗВ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;СМЕЩ(C1;СТРОКА(2:20)-1;))*(C2:C20<50))

Автор - _Boroda_
Дата добавления - 16.04.2020 в 00:36
Tupik Дата: Четверг, 16.04.2020, 00:46 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Да, именно так, огромнейшее спасибо.
hands До слез спасибо.
Я пока не поняла как эта формула работает, но один в один подставлю и буду только диапазон под свой подстраивать.
Благодарность не знает границ.

Подскажите, пожалуйста, а где можно почитать по подробнее про этот синтаксис, чтобы уже разобраться то.


Сообщение отредактировал Tupik - Четверг, 16.04.2020, 01:48
 
Ответить
СообщениеДа, именно так, огромнейшее спасибо.
hands До слез спасибо.
Я пока не поняла как эта формула работает, но один в один подставлю и буду только диапазон под свой подстраивать.
Благодарность не знает границ.

Подскажите, пожалуйста, а где можно почитать по подробнее про этот синтаксис, чтобы уже разобраться то.

Автор - Tupik
Дата добавления - 16.04.2020 в 00:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Промежуточные.итоги и суммесли() (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!