Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Порядковый номер - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Порядковый номер (Формулы/Formulas)
Порядковый номер
Kuznetsov_R Дата: Суббота, 25.04.2020, 02:06 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте, форумчане!
Хотел бы вас попросить помочь в решении следующей задачи.
Имеется таблица с тремя столбцами. Первые два настроены при помощи двухуровневой сортировки. В третьем необходимо прописать формулу, которая бы проставляла порядковый номер в зависимости от сортированных данных в первых двух столбцах.
Игрался с функцией СМЕЩ, но что-то пока задачу не решил. Файл прилагаю.
Буду очень признателен вам за помощь!
К сообщению приложен файл: 01-Poryadkovy_N.xlsx(11.4 Kb)
 
Ответить
СообщениеЗдравствуйте, форумчане!
Хотел бы вас попросить помочь в решении следующей задачи.
Имеется таблица с тремя столбцами. Первые два настроены при помощи двухуровневой сортировки. В третьем необходимо прописать формулу, которая бы проставляла порядковый номер в зависимости от сортированных данных в первых двух столбцах.
Игрался с функцией СМЕЩ, но что-то пока задачу не решил. Файл прилагаю.
Буду очень признателен вам за помощь!

Автор - Kuznetsov_R
Дата добавления - 25.04.2020 в 02:06
gling Дата: Суббота, 25.04.2020, 02:17 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2194
Репутация: 545 ±
Замечаний: 0% ±

2010
Здравствуйте. Попробуйте такую
Код
=СЧЁТЕСЛИМН($A$2:A2;A2;$B$2:B2;B2)


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте. Попробуйте такую
Код
=СЧЁТЕСЛИМН($A$2:A2;A2;$B$2:B2;B2)

Автор - gling
Дата добавления - 25.04.2020 в 02:17
_Boroda_ Дата: Суббота, 25.04.2020, 07:29 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще варианты
Код
=ЕСЛИ((A2=A1)*(B2=B1);C1)+1

Код
=ЕСЛИ(A2&B2=A1&B1;C1)+1

Код
=(A2&B2=A1&B1)*Ч(C1)+1
К сообщению приложен файл: 3450370.xlsx(11.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще варианты
Код
=ЕСЛИ((A2=A1)*(B2=B1);C1)+1

Код
=ЕСЛИ(A2&B2=A1&B1;C1)+1

Код
=(A2&B2=A1&B1)*Ч(C1)+1

Автор - _Boroda_
Дата добавления - 25.04.2020 в 07:29
Kuznetsov_R Дата: Воскресенье, 26.04.2020, 23:14 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
gling, _Boroda_ !
Спасибо вам большое! Всё работает! Что-то я совсем не туда копал.. (
 
Ответить
Сообщениеgling, _Boroda_ !
Спасибо вам большое! Всё работает! Что-то я совсем не туда копал.. (

Автор - Kuznetsov_R
Дата добавления - 26.04.2020 в 23:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Порядковый номер (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!