Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Заполнение ячеек на основе данных в других ячейках - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение ячеек на основе данных в других ячейках (Формулы/Formulas)
Заполнение ячеек на основе данных в других ячейках
akanil Дата: Вторник, 28.04.2020, 20:34 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый вечер, уважаемые эксперты! Прошу вашей помощи.

Дано:
Есть выгрузка базы товаров поставщика для интернет магазина (в реальности более 3000 позиций).
В этой выгрузке у товаров не заполнено значение в колонке "Производитель".
В колонке с именем товара, у каждого товара имя начинается как раз с названия производителя.
Название производителя у некоторых товаров состоит из 2-3 и более слов.
Есть список производителей.
Я даже сделал отдельный файлик, в котором сопоставил первое слово в названии производителя с его полным названием. Предполагаю, что это может пригодиться.

Нужно:
Заполнить столбец "Производитель" на основе того, что указано в имени товара.

Второстепенная задача:
Удалить у каждого товара из его названия производителя.

Как я это вижу:
Какая-то формула, которая читает первое слово в названии товара, сопоставляет его со столбцом, где указаны первые слова имени производителей и при совпадении заполняет соответствующую ячейку полным именем производителя. После этого, удаляет полное имя производителя из названия товара (опционально).
К сообщению приложен файл: brand-name.xlsx(14.6 Kb) · brands_short-fu.xlsx(14.3 Kb)


Сообщение отредактировал akanil - Вторник, 28.04.2020, 20:35
 
Ответить
СообщениеДобрый вечер, уважаемые эксперты! Прошу вашей помощи.

Дано:
Есть выгрузка базы товаров поставщика для интернет магазина (в реальности более 3000 позиций).
В этой выгрузке у товаров не заполнено значение в колонке "Производитель".
В колонке с именем товара, у каждого товара имя начинается как раз с названия производителя.
Название производителя у некоторых товаров состоит из 2-3 и более слов.
Есть список производителей.
Я даже сделал отдельный файлик, в котором сопоставил первое слово в названии производителя с его полным названием. Предполагаю, что это может пригодиться.

Нужно:
Заполнить столбец "Производитель" на основе того, что указано в имени товара.

Второстепенная задача:
Удалить у каждого товара из его названия производителя.

Как я это вижу:
Какая-то формула, которая читает первое слово в названии товара, сопоставляет его со столбцом, где указаны первые слова имени производителей и при совпадении заполняет соответствующую ячейку полным именем производителя. После этого, удаляет полное имя производителя из названия товара (опционально).

Автор - akanil
Дата добавления - 28.04.2020 в 20:34
_Boroda_ Дата: Вторник, 28.04.2020, 21:58 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Перенес список в эту книгу на другой лист
Если как Вы видите, то
Код
=ЕСЛИОШИБКА(ВПР(СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ПОДСТАВИТЬ(B2;"""";" "));" ";ПОВТОР(" ";99));99));brands!A$1:B$999;2;);"")
но так не покатит - Вы же сами выделили желтым задвоения
Вариант такой
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(ПОИСК(brands!B$1:B$186;B2)<3);brands!B$1:B$186);"")

Код
=СЖПРОБЕЛЫ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(B2;C2;"";1);"""""";""))

А лучше вот так
Код
=СЖПРОБЕЛЫ(ПОДСТАВИТЬ(ЗАМЕНИТЬ(B2;ПОИСК(C2;B2);ДЛСТР(C2););"""""";""))

И нужно обязательно, чтобы бренды по возрастанию были отсортированы


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПеренес список в эту книгу на другой лист
Если как Вы видите, то
Код
=ЕСЛИОШИБКА(ВПР(СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ПОДСТАВИТЬ(B2;"""";" "));" ";ПОВТОР(" ";99));99));brands!A$1:B$999;2;);"")
но так не покатит - Вы же сами выделили желтым задвоения
Вариант такой
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(ПОИСК(brands!B$1:B$186;B2)<3);brands!B$1:B$186);"")

Код
=СЖПРОБЕЛЫ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(B2;C2;"";1);"""""";""))

А лучше вот так
Код
=СЖПРОБЕЛЫ(ПОДСТАВИТЬ(ЗАМЕНИТЬ(B2;ПОИСК(C2;B2);ДЛСТР(C2););"""""";""))

И нужно обязательно, чтобы бренды по возрастанию были отсортированы

Автор - _Boroda_
Дата добавления - 28.04.2020 в 21:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение ячеек на основе данных в других ячейках (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!