Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Если переработка в выходные дни то не считать сверхурочные - Страница 2 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 2 из 2
  • «
  • 1
  • 2
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если переработка в выходные дни то не считать сверхурочные (Формулы/Formulas)
Если переработка в выходные дни то не считать сверхурочные
gling Дата: Среда, 06.05.2020, 19:24 | Сообщение № 21
Группа: Друзья
Ранг: Старожил
Сообщений: 2065
Репутация: 521 ±
Замечаний: 0% ±

2010
по Вашей подсказке
У меня эта формула насчитала 53 часа, попробуйте такую
Код
=СУММ(ЕСЛИ((СЧЁТЕСЛИ(DATA!F$2:F$30;E$3:AI$3)+(ДЕНЬНЕД($E$3:$AI$3;2)>5));E4:AI4;ТЕКСТ(E4:AI4;"[>8]8;;0;\0")-СЧЁТЕСЛИМН(DATA!H$2:H$30;E$3:AI$3*(E4:AI4>7);DATA!H$2:H$30;E$3:AI$3*ЕЧИСЛО(E4:AI4))))
В вашей формуле можно еще чуть укоротить (E4:AI4={"в*";"у";"о";"б";"н";"а"})


ЯД-41001506838083

Сообщение отредактировал gling - Среда, 06.05.2020, 19:24
 
Ответить
Сообщение
по Вашей подсказке
У меня эта формула насчитала 53 часа, попробуйте такую
Код
=СУММ(ЕСЛИ((СЧЁТЕСЛИ(DATA!F$2:F$30;E$3:AI$3)+(ДЕНЬНЕД($E$3:$AI$3;2)>5));E4:AI4;ТЕКСТ(E4:AI4;"[>8]8;;0;\0")-СЧЁТЕСЛИМН(DATA!H$2:H$30;E$3:AI$3*(E4:AI4>7);DATA!H$2:H$30;E$3:AI$3*ЕЧИСЛО(E4:AI4))))
В вашей формуле можно еще чуть укоротить (E4:AI4={"в*";"у";"о";"б";"н";"а"})

Автор - gling
Дата добавления - 06.05.2020 в 19:24
DrMini Дата: Среда, 06.05.2020, 19:34 | Сообщение № 22
Группа: Проверенные
Ранг: Ветеран
Сообщений: 506
Репутация: 9 ±
Замечаний: 0% ±

Excel 2010, 2013, 2019 RUS
попробуйте такую

Да спасибо. Работает. Завтра с утречка проверю полностью.
[offtop]Сегодня уже не даёт поднять репутацию. Завтра.[/offtop]


Сообщение отредактировал DrMini - Среда, 06.05.2020, 19:35
 
Ответить
Сообщение
попробуйте такую

Да спасибо. Работает. Завтра с утречка проверю полностью.
[offtop]Сегодня уже не даёт поднять репутацию. Завтра.[/offtop]

Автор - DrMini
Дата добавления - 06.05.2020 в 19:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если переработка в выходные дни то не считать сверхурочные (Формулы/Formulas)
  • Страница 2 из 2
  • «
  • 1
  • 2
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!