Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Счет значений в строке с учетом интервала и повторяемости - Страница 2 - Мир MS Excel

Старая форма входа
  • Страница 2 из 2
  • «
  • 1
  • 2
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Счет значений в строке с учетом интервала и повторяемости (Формулы/Formulas)
Счет значений в строке с учетом интервала и повторяемости
Светлый Дата: Вторник, 07.07.2020, 00:30 | Сообщение № 21
Группа: Друзья
Ранг: Старожил
Сообщений: 1569
Репутация: 409 ±
Замечаний: 0% ±

Excel 2010, 2013
У меня такая формула получилась:
Код
=СУММПРОИЗВ(Ч(B2:G2*СМЕЩ(B2:G2;;L2+1)=1))
*Или универсальная, если размер таблицы изменится:
Код
=СУММПРОИЗВ(Ч(СМЕЩ(B2;;;;СЧЁТЗ(B$1:J$1)-1-L2)*СМЕЩ(B2;;L2+1;;СЧЁТЗ(B$1:J$1)-1-L2)=1))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Вторник, 07.07.2020, 00:41
 
Ответить
СообщениеУ меня такая формула получилась:
Код
=СУММПРОИЗВ(Ч(B2:G2*СМЕЩ(B2:G2;;L2+1)=1))
*Или универсальная, если размер таблицы изменится:
Код
=СУММПРОИЗВ(Ч(СМЕЩ(B2;;;;СЧЁТЗ(B$1:J$1)-1-L2)*СМЕЩ(B2;;L2+1;;СЧЁТЗ(B$1:J$1)-1-L2)=1))

Автор - Светлый
Дата добавления - 07.07.2020 в 00:30
dimahk Дата: Вторник, 07.07.2020, 20:08 | Сообщение № 22
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Спасибо за разъяснения, суть уловил, но вот переделать под дальнейшие вводные не выходит :(

дополнительная постановка такая:
суть остается та же, но:
1) смотреть не только в ячейке через заданное кол-во ячеек, но и дальше. То есть раньше было - есть ли "единица" через две ячейки от первой "единицы", то теперь есть ли "единица" через две ячейки и дальше
2) вот это "дальше" из последнего пункта нужно ограничить 29 ячейками то есть первая "единица" в первой, вторая в тридцатой, между ними 28 ячеек, если больше то не подходит.

Результат складывается как и раньше: если по условию находим первое совпадение переходим к следующей. (суммировать все найденные в диапазоне промежутки от двойки не надо, только первый)

Файл приложил. Буду очень благодарен.

Надеюсь понятно объяснил.
К сообщению приложен файл: 1899623.xlsx(9.9 Kb)
 
Ответить
СообщениеСпасибо за разъяснения, суть уловил, но вот переделать под дальнейшие вводные не выходит :(

дополнительная постановка такая:
суть остается та же, но:
1) смотреть не только в ячейке через заданное кол-во ячеек, но и дальше. То есть раньше было - есть ли "единица" через две ячейки от первой "единицы", то теперь есть ли "единица" через две ячейки и дальше
2) вот это "дальше" из последнего пункта нужно ограничить 29 ячейками то есть первая "единица" в первой, вторая в тридцатой, между ними 28 ячеек, если больше то не подходит.

Результат складывается как и раньше: если по условию находим первое совпадение переходим к следующей. (суммировать все найденные в диапазоне промежутки от двойки не надо, только первый)

Файл приложил. Буду очень благодарен.

Надеюсь понятно объяснил.

Автор - dimahk
Дата добавления - 07.07.2020 в 20:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Счет значений в строке с учетом интервала и повторяемости (Формулы/Formulas)
  • Страница 2 из 2
  • «
  • 1
  • 2
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!