Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Счет значений в строке с учетом интервала и повторяемости - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Счет значений в строке с учетом интервала и повторяемости (Формулы/Formulas)
Счет значений в строке с учетом интервала и повторяемости
dimahk Дата: Пятница, 01.05.2020, 20:14 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Всем привет! Прошу помощи у знатоков!
Сразу скажу, очень похожее решение есть в теме http://www.excelworld.ru/forum/2-42857-1 , но не смог реализовать под свои нужды и реалии, а именно:
Условие:
в строке, в 30 ячейках значения - либо 1, либо пустота (0 или любой другой символ)(таких строк в моей задаче может быть до 200 000)
Задача:
Для каждой строки вывести максимальное кол-во единиц с условием, что эти единицы находятся в соседних ячейках
Пример:
1 _ 1 1 1 _ _ 1 1 1 1 _ _ _ _ правильный ответ - 4
_ _ _ 1 _ 1 _ _ _ 1 1 _ _ _ _ правильные ответ - 2
_ _ 1 _ _ 1 _ _ _ _ _ _ _ _ 1 правильный ответ - 1
 
Ответить
СообщениеВсем привет! Прошу помощи у знатоков!
Сразу скажу, очень похожее решение есть в теме http://www.excelworld.ru/forum/2-42857-1 , но не смог реализовать под свои нужды и реалии, а именно:
Условие:
в строке, в 30 ячейках значения - либо 1, либо пустота (0 или любой другой символ)(таких строк в моей задаче может быть до 200 000)
Задача:
Для каждой строки вывести максимальное кол-во единиц с условием, что эти единицы находятся в соседних ячейках
Пример:
1 _ 1 1 1 _ _ 1 1 1 1 _ _ _ _ правильный ответ - 4
_ _ _ 1 _ 1 _ _ _ 1 1 _ _ _ _ правильные ответ - 2
_ _ 1 _ _ 1 _ _ _ _ _ _ _ _ 1 правильный ответ - 1

Автор - dimahk
Дата добавления - 01.05.2020 в 20:14
AlexM Дата: Пятница, 01.05.2020, 21:53 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4164
Репутация: 1024 ±
Замечаний: 0% ±

Excel 2003
Надо прикладывать файл пример
Код
=МАКС(ЧАСТОТА(СТОЛБЕЦ(A:O);(A1:O1<>1)*СТОЛБЕЦ(A:O)))-1

Пробуйте, должно получится.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеНадо прикладывать файл пример
Код
=МАКС(ЧАСТОТА(СТОЛБЕЦ(A:O);(A1:O1<>1)*СТОЛБЕЦ(A:O)))-1

Пробуйте, должно получится.

Автор - AlexM
Дата добавления - 01.05.2020 в 21:53
dimahk Дата: Пятница, 01.05.2020, 22:33 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Офигеть! Работает, большое спасибо, пробую разобраться как работает!

Еще вопрос, прикрепил файл примера, в последней ячейке ваша формула, настроил ее на пересчет "0" все работает как надо, а как добавить условие, что повторение должно считаться только между "1" ?

В файле все выделил и пометил
К сообщению приложен файл: 2743222.xlsx(10.5 Kb)
 
Ответить
СообщениеОфигеть! Работает, большое спасибо, пробую разобраться как работает!

Еще вопрос, прикрепил файл примера, в последней ячейке ваша формула, настроил ее на пересчет "0" все работает как надо, а как добавить условие, что повторение должно считаться только между "1" ?

В файле все выделил и пометил

Автор - dimahk
Дата добавления - 01.05.2020 в 22:33
прохожий2019 Дата: Суббота, 02.05.2020, 13:24 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 111
Репутация: 20 ±
Замечаний: 0% ±

365
по такому раскладу нужно диапазон ограничить, получился монстрик
Код
=МАКС(ЧАСТОТА(СТОЛБЕЦ(ИНДЕКС(A2:AF2;ПОИСКПОЗ(1;A2:AF2;0)):ИНДЕКС(A2:AF2;ПРОСМОТР(;-1/(A2:AF2=1);СТОЛБЕЦ(A2:AF2))));(ИНДЕКС(A2:AF2;ПОИСКПОЗ(1;A2:AF2;0)):ИНДЕКС(A2:AF2;ПРОСМОТР(;-1/(A2:AF2=1);СТОЛБЕЦ(A2:AF2)))=1)*СТОЛБЕЦ(ИНДЕКС(A2:AF2;ПОИСКПОЗ(1;A2:AF2;0)):ИНДЕКС(A2:AF2;ПРОСМОТР(;-1/(A2:AF2=1);СТОЛБЕЦ(A2:AF2))))))-1
либо сделать именованную формулу диапазон
Код
=ИНДЕКС(Лист1!$A2:$AF2;ПОИСКПОЗ(1;Лист1!$A2:$AF2;0)):ИНДЕКС(Лист1!$A2:$AF2;ПРОСМОТР(;-1/(Лист1!$A2:$AF2=1);СТОЛБЕЦ(Лист1!$A2:$AF2)))
и тогда просто
Код
=МАКС(ЧАСТОТА(СТОЛБЕЦ(диапазон);(диапазон=1)*СТОЛБЕЦ(диапазон)))-1
К сообщению приложен файл: 8132080.xlsx(10.4 Kb)
 
Ответить
Сообщениепо такому раскладу нужно диапазон ограничить, получился монстрик
Код
=МАКС(ЧАСТОТА(СТОЛБЕЦ(ИНДЕКС(A2:AF2;ПОИСКПОЗ(1;A2:AF2;0)):ИНДЕКС(A2:AF2;ПРОСМОТР(;-1/(A2:AF2=1);СТОЛБЕЦ(A2:AF2))));(ИНДЕКС(A2:AF2;ПОИСКПОЗ(1;A2:AF2;0)):ИНДЕКС(A2:AF2;ПРОСМОТР(;-1/(A2:AF2=1);СТОЛБЕЦ(A2:AF2)))=1)*СТОЛБЕЦ(ИНДЕКС(A2:AF2;ПОИСКПОЗ(1;A2:AF2;0)):ИНДЕКС(A2:AF2;ПРОСМОТР(;-1/(A2:AF2=1);СТОЛБЕЦ(A2:AF2))))))-1
либо сделать именованную формулу диапазон
Код
=ИНДЕКС(Лист1!$A2:$AF2;ПОИСКПОЗ(1;Лист1!$A2:$AF2;0)):ИНДЕКС(Лист1!$A2:$AF2;ПРОСМОТР(;-1/(Лист1!$A2:$AF2=1);СТОЛБЕЦ(Лист1!$A2:$AF2)))
и тогда просто
Код
=МАКС(ЧАСТОТА(СТОЛБЕЦ(диапазон);(диапазон=1)*СТОЛБЕЦ(диапазон)))-1

Автор - прохожий2019
Дата добавления - 02.05.2020 в 13:24
AlexM Дата: Воскресенье, 03.05.2020, 17:25 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4164
Репутация: 1024 ±
Замечаний: 0% ±

Excel 2003
С ограничением диапазона
Код
=МАКС(ЧАСТОТА(СТОЛБЕЦ(ИНДЕКС(B2:AF2;ПОИСКПОЗ(1;B2:AF2;)):ИНДЕКС(B2:AF2;-ПРОСМОТР(;1-СТОЛБЕЦ(B:AF)/B2:AF2)));(B2:AF2<>0)*СТОЛБЕЦ(B:AF)))-1
К сообщению приложен файл: 2743222_01.xlsx(9.1 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеС ограничением диапазона
Код
=МАКС(ЧАСТОТА(СТОЛБЕЦ(ИНДЕКС(B2:AF2;ПОИСКПОЗ(1;B2:AF2;)):ИНДЕКС(B2:AF2;-ПРОСМОТР(;1-СТОЛБЕЦ(B:AF)/B2:AF2)));(B2:AF2<>0)*СТОЛБЕЦ(B:AF)))-1

Автор - AlexM
Дата добавления - 03.05.2020 в 17:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Счет значений в строке с учетом интервала и повторяемости (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!