Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск последних 3-х чисел - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск последних 3-х чисел (Формулы/Formulas)
Поиск последних 3-х чисел
frankenshtein Дата: Суббота, 02.05.2020, 14:27 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день.
2 столбца. В Первом номер, во втором столбце число "0 или 1"
3 и 4 столбцы состоят из 3-х ячеек.

Нужно, чтобы в 3 и 4 столбцах отображались данные последних "ТРЕХ" ячеек где стоят 1.
Т.е. там должны будут отобразиться - В зеленом столбце (4;8;13). В красном (1;1;1).
Я их туда вписал уже для примера.

Как прописать формулу, чтобы числа в эти столбцы автоматически подставлялись.
Т.Е. отображает последние три ячейки где стоит "1"

В Первом столбце числа меняются постоянно и разные.
Во втором тоже меняются, только на "0" и "1"
К сообщению приложен файл: 9124796.xlsx(10.3 Kb)
 
Ответить
СообщениеДобрый день.
2 столбца. В Первом номер, во втором столбце число "0 или 1"
3 и 4 столбцы состоят из 3-х ячеек.

Нужно, чтобы в 3 и 4 столбцах отображались данные последних "ТРЕХ" ячеек где стоят 1.
Т.е. там должны будут отобразиться - В зеленом столбце (4;8;13). В красном (1;1;1).
Я их туда вписал уже для примера.

Как прописать формулу, чтобы числа в эти столбцы автоматически подставлялись.
Т.Е. отображает последние три ячейки где стоит "1"

В Первом столбце числа меняются постоянно и разные.
Во втором тоже меняются, только на "0" и "1"

Автор - frankenshtein
Дата добавления - 02.05.2020 в 14:27
Pelena Дата: Суббота, 02.05.2020, 14:41 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16763
Репутация: 3619 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Цитата frankenshtein, 02.05.2020 в 14:27, в сообщении № 1 ()
данные последних "ТРЕХ" ячеек где стоят 1

"данные" - это номер строки или значение в столбце 1?
Почему (4;8;13), а не (46;42;38)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Цитата frankenshtein, 02.05.2020 в 14:27, в сообщении № 1 ()
данные последних "ТРЕХ" ячеек где стоят 1

"данные" - это номер строки или значение в столбце 1?
Почему (4;8;13), а не (46;42;38)

Автор - Pelena
Дата добавления - 02.05.2020 в 14:41
frankenshtein Дата: Суббота, 02.05.2020, 14:46 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Числа поступают с верху в низ и там где "4" это последняя поступившая информация которая нам интересна
Данные, Это значение в столбце, она может быть любой 765 например

или так
34 1
23 0
543 0
342 1


Сообщение отредактировал frankenshtein - Суббота, 02.05.2020, 14:52
 
Ответить
СообщениеЧисла поступают с верху в низ и там где "4" это последняя поступившая информация которая нам интересна
Данные, Это значение в столбце, она может быть любой 765 например

или так
34 1
23 0
543 0
342 1

Автор - frankenshtein
Дата добавления - 02.05.2020 в 14:46
прохожий2019 Дата: Суббота, 02.05.2020, 14:57 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 381
Репутация: 64 ±
Замечаний: 0% ±

365 Beta Channel
Код
=ИНДЕКС($A$1:$A$51;НАИМЕНЬШИЙ(ЕСЛИ($D$2:$D$51;СТРОКА($D$2:$D$51);"");СТРОКА(A1)))
К сообщению приложен файл: 2270484.xlsx(10.9 Kb)
 
Ответить
Сообщение
Код
=ИНДЕКС($A$1:$A$51;НАИМЕНЬШИЙ(ЕСЛИ($D$2:$D$51;СТРОКА($D$2:$D$51);"");СТРОКА(A1)))

Автор - прохожий2019
Дата добавления - 02.05.2020 в 14:57
Pelena Дата: Суббота, 02.05.2020, 15:00 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 16763
Репутация: 3619 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Для зеленых
Код
=ИНДЕКС($A$2:$A$51;АГРЕГАТ(15;6;(СТРОКА($A$2:$A$51)-1)/($D$2:$D$51=1);СТРОКА(A1)))

а в красных тогда всегда единицы?
К сообщению приложен файл: 0016419.xlsx(10.9 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеДля зеленых
Код
=ИНДЕКС($A$2:$A$51;АГРЕГАТ(15;6;(СТРОКА($A$2:$A$51)-1)/($D$2:$D$51=1);СТРОКА(A1)))

а в красных тогда всегда единицы?

Автор - Pelena
Дата добавления - 02.05.2020 в 15:00
frankenshtein Дата: Суббота, 02.05.2020, 15:46 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
да все правильно.
Спасибо.


Сообщение отредактировал frankenshtein - Суббота, 02.05.2020, 21:33
 
Ответить
Сообщениеда все правильно.
Спасибо.

Автор - frankenshtein
Дата добавления - 02.05.2020 в 15:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск последних 3-х чисел (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!