Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск и сортировка параметров с присвоением им символов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск и сортировка параметров с присвоением им символов (Формулы/Formulas)
Поиск и сортировка параметров с присвоением им символов
kirille Дата: Понедельник, 04.05.2020, 11:12 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте!
Помогите пожалуйста найти решение.
Есть формула
Код
=IF((VLOOKUP("L150";$B$5:$K$26;3;1)>=T31);"★")
, находит L150 в таблице (столбце) действий и этому действию присваивает символ, но этих действий несколько.
Подскажите как сделать, что бы ко всем остальным действиям тоже присваивались свои символы.
Так формула не работает
Код
=IF((VLOOKUP("L150";$B$5:$K$26;3;1)>=T31);"★") ; IF((VLOOKUP("L150";$B$5:$K$26;3;1)>=S31);"▲")
и т.д.
К сообщению приложен файл: 123.xlsx(11.2 Kb)


Сообщение отредактировал kirille - Понедельник, 04.05.2020, 11:31
 
Ответить
СообщениеЗдравствуйте!
Помогите пожалуйста найти решение.
Есть формула
Код
=IF((VLOOKUP("L150";$B$5:$K$26;3;1)>=T31);"★")
, находит L150 в таблице (столбце) действий и этому действию присваивает символ, но этих действий несколько.
Подскажите как сделать, что бы ко всем остальным действиям тоже присваивались свои символы.
Так формула не работает
Код
=IF((VLOOKUP("L150";$B$5:$K$26;3;1)>=T31);"★") ; IF((VLOOKUP("L150";$B$5:$K$26;3;1)>=S31);"▲")
и т.д.

Автор - kirille
Дата добавления - 04.05.2020 в 11:12
AlexM Дата: Понедельник, 04.05.2020, 13:34 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4163
Репутация: 1024 ±
Замечаний: 0% ±

Excel 2003
Так нужно?
Код
=ВПР(ВПР("L150";$B$5:$H$25;3;);$F$29:$G$30;2;)
К сообщению приложен файл: 123_01.xlsx(10.9 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеТак нужно?
Код
=ВПР(ВПР("L150";$B$5:$H$25;3;);$F$29:$G$30;2;)

Автор - AlexM
Дата добавления - 04.05.2020 в 13:34
kirille Дата: Вторник, 05.05.2020, 06:56 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
AlexM, Большое спасибо! Вы мне очень помогли.
Как вы думаете, можно добавить поиск по частичному совпадению?
 
Ответить
СообщениеAlexM, Большое спасибо! Вы мне очень помогли.
Как вы думаете, можно добавить поиск по частичному совпадению?

Автор - kirille
Дата добавления - 05.05.2020 в 06:56
AlexM Дата: Вторник, 05.05.2020, 08:09 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4163
Репутация: 1024 ±
Замечаний: 0% ±

Excel 2003
можно добавить поиск по частичному совпадению?
Поясните и покажите пример.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
можно добавить поиск по частичному совпадению?
Поясните и покажите пример.

Автор - AlexM
Дата добавления - 05.05.2020 в 08:09
kirille Дата: Вторник, 05.05.2020, 11:47 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
AlexM,
Код
=ВПР(ВПР("L150";$B$5:$H$25;3;);$F$29:$G$30;2;)
ищет и меняет только при полном совпадение текста.
Код
=ЕСЛИ((ВПР("L150";$B$5:$K$26;3;1)>=T31);"★")
ищет и меняет при полном или частичном совпадение текста.
К сообщению приложен файл: 7038132.xlsx(11.2 Kb)
 
Ответить
СообщениеAlexM,
Код
=ВПР(ВПР("L150";$B$5:$H$25;3;);$F$29:$G$30;2;)
ищет и меняет только при полном совпадение текста.
Код
=ЕСЛИ((ВПР("L150";$B$5:$K$26;3;1)>=T31);"★")
ищет и меняет при полном или частичном совпадение текста.

Автор - kirille
Дата добавления - 05.05.2020 в 11:47
AlexM Дата: Вторник, 05.05.2020, 14:56 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4163
Репутация: 1024 ±
Замечаний: 0% ±

Excel 2003
kirille, вы неверно понимаете работу второй формулы. Посмотрите как она работает в ячейке С28
К сообщению приложен файл: 7038132_01.xlsx(11.0 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщениеkirille, вы неверно понимаете работу второй формулы. Посмотрите как она работает в ячейке С28

Автор - AlexM
Дата добавления - 05.05.2020 в 14:56
gling Дата: Вторник, 05.05.2020, 22:01 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 2066
Репутация: 521 ±
Замечаний: 0% ±

2010
Вариант в файле, может наведет на новые идеи
что бы ко всем остальным действиям тоже присваивались свои символы
К сообщению приложен файл: 2815876.xlsx(13.5 Kb)


ЯД-41001506838083

Сообщение отредактировал gling - Вторник, 05.05.2020, 22:02
 
Ответить
СообщениеВариант в файле, может наведет на новые идеи
что бы ко всем остальным действиям тоже присваивались свои символы

Автор - gling
Дата добавления - 05.05.2020 в 22:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск и сортировка параметров с присвоением им символов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!