Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматизация переноса текста - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматизация переноса текста (Автоматический перенос текста)
Автоматизация переноса текста
solololo Дата: Понедельник, 04.05.2020, 18:47 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016 и выше
Здравствуйте, решил упорядочить базу на работе и столкнулся с проблемой.
Нужно что бы текст с ячейки "Корзина" переносился в ячейку "Товар" и забивался друг под другом,но не знаю как это сделать. Текст либо идет с отрывами, либо налипает друг на друга.
К сообщению приложен файл: 7149259.png(72.3 Kb)


Сообщение отредактировал solololo - Понедельник, 04.05.2020, 18:48
 
Ответить
СообщениеЗдравствуйте, решил упорядочить базу на работе и столкнулся с проблемой.
Нужно что бы текст с ячейки "Корзина" переносился в ячейку "Товар" и забивался друг под другом,но не знаю как это сделать. Текст либо идет с отрывами, либо налипает друг на друга.

Автор - solololo
Дата добавления - 04.05.2020 в 18:47
Pelena Дата: Понедельник, 04.05.2020, 18:59 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15745
Репутация: 3430 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Файл покажете?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФайл покажете?

Автор - Pelena
Дата добавления - 04.05.2020 в 18:59
solololo Дата: Понедельник, 04.05.2020, 19:04 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016 и выше
Pelena, Вот.Буду благодарен за подсказки
К сообщению приложен файл: MoyaRabota222.xlsm(31.8 Kb)
 
Ответить
СообщениеPelena, Вот.Буду благодарен за подсказки

Автор - solololo
Дата добавления - 04.05.2020 в 19:04
Pelena Дата: Понедельник, 04.05.2020, 19:09 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 15745
Репутация: 3430 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Именно макрос нужен, формулы не предлагать?

И да, у Вас Макбук или случайно в этой ветке запостили?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИменно макрос нужен, формулы не предлагать?

И да, у Вас Макбук или случайно в этой ветке запостили?

Автор - Pelena
Дата добавления - 04.05.2020 в 19:09
solololo Дата: Понедельник, 04.05.2020, 19:12 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016 и выше
Pelena, Можно все. Чем больше вариаций тем лучше. Я работаю на винде. Первый раз на форуме, случайно тут запостил.
 
Ответить
СообщениеPelena, Можно все. Чем больше вариаций тем лучше. Я работаю на винде. Первый раз на форуме, случайно тут запостил.

Автор - solololo
Дата добавления - 04.05.2020 в 19:12
Pelena Дата: Понедельник, 04.05.2020, 19:26 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 15745
Репутация: 3430 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Вариант формулой
Код
=ЕСЛИОШИБКА(ИНДЕКС($P$3:$P$1000;АГРЕГАТ(15;6;(СТРОКА($P$3:$P$1000)-2)/($P$3:$P$1000<>"");СТРОКА(A1)));"")

Формулу для Корзины тоже немного подредактировала
К сообщению приложен файл: 3356337.xlsm(31.6 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВариант формулой
Код
=ЕСЛИОШИБКА(ИНДЕКС($P$3:$P$1000;АГРЕГАТ(15;6;(СТРОКА($P$3:$P$1000)-2)/($P$3:$P$1000<>"");СТРОКА(A1)));"")

Формулу для Корзины тоже немного подредактировала

Автор - Pelena
Дата добавления - 04.05.2020 в 19:26
solololo Дата: Понедельник, 04.05.2020, 19:31 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016 и выше
Pelena, Спасибо вам большое. Просто ради интереса. Где вы работаете? Извиняюсь за надоедливость
 
Ответить
СообщениеPelena, Спасибо вам большое. Просто ради интереса. Где вы работаете? Извиняюсь за надоедливость

Автор - solololo
Дата добавления - 04.05.2020 в 19:31
Pelena Дата: Понедельник, 04.05.2020, 19:35 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 15745
Репутация: 3430 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
в данный момент #сижудома


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениев данный момент #сижудома

Автор - Pelena
Дата добавления - 04.05.2020 в 19:35
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматизация переноса текста (Автоматический перенос текста)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!